Mouse button middle click does not always trigger screen rotation

Avatar
  • Views 491
  • updated
  • Closed

About 70% of the time, clicking the middle mouse button causes the screen to tilt the screen rather than rotate and it takes multiple clicks before it recognizes the rotation input.  I am using a reasonably new Logitech M510 mouse.

Version:
1.02
Platform:
Windows PC
Store:
Steam

How would you rate the customer service you received?

Satisfaction mark by guy sotomayor 2 months ago

Add a comment about quality of support you received (optional):

Avatar
Dominik Customer Support
  • Pending Customer

Hi Guy!

Sorry to hear you are having some problem with screen rotating. Our team will definitely would like to take a look at it but in order to do so, I have to ask you for some game files so please visit this LINK for instructions how to get them. 

If you would also be able to record a short video showing us the problem, that would be lovely!

Best,

Dominik

Avatar
n h.

On my end, the issue seems to be that holding the middle mouse button allows only for either rotation or panning, never both; depending on which input comes first.

Which is especially confusing/annoying when the mouse somehow picked up the other type of input than you intended.

Avatar
Dominik Customer Support
Quote from n h.

On my end, the issue seems to be that holding the middle mouse button allows only for either rotation or panning, never both; depending on which input comes first.

Which is especially confusing/annoying when the mouse somehow picked up the other type of input than you intended.

Hey N!

What you are describing is actually an intended feature, I am sorry that it may feel a little annoying!

As for the initial issue raised by Guy, I am still awaiting a video of the problem to forward it further.

Thanks all!

Avatar
guy sotomayor

Good morning! 


It seems like what n h. is describing is what is happening with my issue as well.  There seems to be no difference from my end in the input, but it does not seem to provide a consistent output.  I have included the requested files in ticket #3459.  Thank you!

Avatar
Dominik Customer Support
  • Closed

Thank you for all the information provided! I have already forwarded the bug report to our team with files provided in another ticket, I will be closing this thread and provide any updates in the second one if I get any response from our team.

Thank you for understanding!

Best,

Dominik