Completed - Resolved

(Mighty Script Editor) Empire owned party doesn't follow assigned patrol routes

Péter Dániel 5 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 5 years ago 11


So I've been experimenting with scripts, currently working on a campaign, and when I tried spawning Empire units in an area, on testing they were completely motionless. When I attacked them, they responded one by one in 5-8 second intervals per unit. It was probably the pathetic AI I thought, put it on to Master, rechecked, still braindead behavior. Felt it necessary to script a patrol route for them, so on game start they will be assigned to a patrolling route like this: 

Image 5637

Surprisingly, the 5-man party spawned on their designated location, but they did not move to their first point. I re-assigned the starting point as the 1st stop of the patrol. On test, the units were walking towards the middle of the tile, and kept pushing eachother away from it, perpetually. I took to the WTFO MSE tutorial's party spawn solution, which made the party spawn on startup, have the same patrolling route, and start on the 1st stop. The party persisted to act defective. Messed with the party member spawn interval, the idle times and idle block ranges, nothing helped.

Image 5638

The editor did not display any bugs. I have no idea what the issue may be. Should I attach any files?

Game Version:
Steam Public

thank you for being so quick at responding to issues. This game is a reboot of a childhood favorite of mine and for many other people. its great to see the massive support you guys lend when sht hits the fan. :D

Satisfaction mark by Péter Dániel 5 years ago

Also, in case it helps, as I was working on the map, I've accidentally hit esc when the MSE was open. This resulted in a different bug, where the two menus overlapped, and whenever I clicked the MSE button on the hud, the UI appeared for a split second, and it instantly faded out, as if I had it enabled, and the click dismissed the window. At this point I restarted WTFO, but when I tried loading the map, there were a bunch of entity IDs missing (first there even was a critical error message when loading the unfinished version of the map, I loaded the "finished" version I exported sooner, and that didn't give an error message. A ton of bugs appeared that were related to cutscene camera not having assigned tiles, KOable units arent assigned, etc. At first I couldnt even fix them, because on re-editing all scripts to be functional, the missing ID bugs persisted (later I simply restarted my game, and that fixed the persisting bug issue). My guess is, is it possible that all the tiles lost their IDs when the error occured? I might have this error log somewhere, that described the critical error message my game gave, when I couldn't load the map in question.


This thread is probably related to my current issue, this is the same map after all. The error logs and output file is there if needed.

Hello Péter ,

Could you provide me with the save file of the _edit version please ?

As described here

Hello Nanorock! The guide helped, originally i wasn't able to find map saves, so thanks for that as well. :D



The tile at Patrol point 4 is unwalkable for faction 3 and 4.
We still need to find out why this is. 

The only things that do change walkability for a certain faction are locked doors and toggled impasse flags.

Was maybe anything like this placed at this tile (Patrol point 4) before?

I haven't experimented with impasse flags yet. Locked doors occasionally happen inbetween closed off areas, but i've disabled most of them due to ai being incapable of moving. Most moving armies were supposed to be controlled by patrol routes. The near-dungeoncore dwarves follow the one way route to the core though, they seem to be responding fine.

We are well disposed, this issue was introduced between two versions of the game where we had no proper autofix for it.

Can you simply put an earth wall at the tile marked red:

and then replace it with a claimed Empire tile again as it was before.
This should fix the entire problem.

Alright, i'll be off working for today, tomorrow morning i'll test this out, thank you!

Completed - Next Patch