0
Completed - Resolved

[OSX] Cannot start the campaign.

dyegreenluke 4 years ago updated by Cian Noonan (Graphics Plumber) 3 years ago 35 2 duplicates

I am on a macOS Sierra iMac Late 2013, and I cannot start the campaign.

It pans to some textures once i click "play" and it makes a wind noise. Any help?

Game Version:
Steam Public
Platform:
OS X

Answer

Answer
Completed - Next Patch

Hey all, 


We will be pushing an update in the next few days which has fixed this issue. Please get back to us once you have updated if you still experience the crash

Duplicates 2

Under Review

Is it possible you can upgrade to OSX 10.12 "Sierra"? Or is there a reason you need to be on Capitan?

I'm working with Cubase 8.5 Pro and although they say it works perfectly on 10.12 I had weird crashes and so I decided to go back to 10.11. Additionally I'm using TotalFinder which also works very poorly in 10.12.

Do you use headphones by any chance? We've had reports in the past where if the headphones or unplugged the game will start working.

I updated to Sierra since I have been assured that everything will be working properly. Only thing that changed is that the grahics artifacts are gone now. When I press "play" to start a level of the campaign I still get the same frozen picture with the repeating short part of audio. I tried to unplug my headphones => didn't work. Disconnected secondary monitor and headphones => didn't work.

Could you please upload a new Player.log file for review? Thanks.

Thanks. I can see a number of problems occurring in the log there. However they are very vague and do not appear to be caused by our own code. I suspect some kind of hardware incompatibility between your hardware and the 3D engine we use (Unity).


Unfortunately I cannot provide any immediate steps to resolve this for you - It works on all the OS X hardware we have here. It may be resolved in a patch or two, however I understand that you may not want to wait that long and so I would suggest that you request a refund through Steam to get your money back.


I'm really sorry I cannot assist you immediately. We'll keep looking into the problem regardless. :(

Ok thanks for your help. I already have like 30 hours in the game so I can't refund it. Maybe I'll try to play it in Windows 10 with BootCamp.

Pending Customer

Best of luck, let us know how you get on. If you still have issues we'll try to remember to let you know as we update Unity that might help fix the issue for you.

Under Review

Hello K.r.,
Sorry for such troubles, the log shows indeed a crash but Unity3d (our game engine) was failing on reporting any pointer for the cause.
All we got is:
Receiving unhandled NULL exception
Obtained 16 stack frames.

Which does not help to look for any cause.

Can you trigger the problem again and try to upload another Player.log?
With some luck next time we get a more decent stack trace.

Is it possible for you to skip the introduction video by quickly pressing space bar?

I hope it is not a general incompatibility issue.
However the way video scenes are put into Unity3d based games will change drastically in Unity 5.6
and I hope it reduces issues caused by cutscenes.
But till then there is still some time to wait.

Hello

Thanks for a fast reply :)

I tried skipping with space but no luck I'm afraid; the freeze seems instant the moment I press "play".


I'm attaching two new logs - hope you can find something useful.

Let me know if you need anything else.


Player.log

Player 2.log

Accepted

It's a bummer all three Player.log files look exactly the same.
All is fine, no errors and then suddently "Receiving unhandled NULL exception" which does not help.

It seems we will have to contact the support of Unity Technologies for this one, which means it could take quite some time to get this sorted.
If you not want to wait longer for a fix and just recently bought the game, then it is possible to refund it on steam store if you are less than 2 hours into the game.

Otherwise it will take up some time to get this sorted out I fear.
We could look into a way to disable cutscenes entirely by introducing a special command though,
but this could only be a temporary solution and finally you want to see the cutscenes as well.

In Unity 5.6 they are changing how cutscenes are integrated totally which will likely reduce issues caused by them especially on non-windows platforms.
But it's still some time to wait before this technology becomes available to us.

I am sorry, that we are unable to help quickly on this this problem.
Thanks for reporting and sharing your logs.

I was actually looking for "skip cutscenes" in the options before I submitted here; I wouldn't mind playing without them.


Thanks for swift replies and for your help!

Thanks for being understanding.
Then the way to go is introducing a way to disable cutscenes for now.
Can you just make 100% sure this is the root cause by confirming that clicking on "Replay Intro Cutscene" in the campaign menu view causes this freeze?
We are going to add a cutscene skip command for next hotfix, which hopefully will allow you to play campaign mode.

Sorry the button I mentioned is only available in Heart of Gold campaign view in case you own it.
Would be interesting if this one causes as well a freeze or if it is limitted to the main campaign cutscene.

Yes, I can confirm it causes the crash (I have the HoG DLC). When I press "Replay cutscene" the exact same problem occurs.


Btw, I just updated my OS to the latest version (Sierra 10.12.2) but the problem still remain (in case the Unity guys are interested).

Thanks for testing this for us.
Watch out for hotfix patch v1.5.0f12, which comes with a new Display Option to disable cutscenes.

http://imgur.com/a/DylI6

+1

Thanks a lot for your help and quick response, I really appreciate it!

The hotfix is now out, try to use above setting and let us know if you can play campaign in this way.
Cheers

Wow that was fast! Yes, the game loads fine after disabling cutscenes. Again - thanks a lot for great support!


(I've seen others with the same issue, maybe you want to post this info somewhere for other OS X users)

First off glad you can finally play campaign!

Oh did you see others with the same issue?
We got some OSX crashes caused by a Chromium engine bug which should be unrelated to video cutscenes
and does in fact have no quickfix or bypass.
But if you know other reports of this particular issue?
Ofc I would like to have no one suffering from this crash.

We are keeping this ticket in Accepted state until we found a solution with Unity that makes the cutscenes actually work for you.

Enjoy :)

Hello Marcel,
you get the crash when you start the first campaign level?
I guess this could be related to cutscenes not working for what ever reason on OSX.
Could you take a look here and try if you can play for now by disabling video cutscenes:
http://brightrockgames.userecho.com/topics/1680-game-freeze-starting-campaign-mode/#comment-7853

Try to activete this checkbox before starting a campaign:
http://imgur.com/a/DylI6

Let us know if it works.

+1

I found Marcel Schulz's post here with the same issue: http://brightrockgames.userecho.com/topics/1256-os-x-crash-on-startup-v140/ posted just a couple of days ago. (didn't see it before I created this thread)


I've also seen the artefacts he's including screenshots of, but didn't take much notice to it since it happens to many games on OS X during loading. Seems his log file include the same Receiving unhandled NULL exception

Obtained 16 stack frames as mine.


Anyway, I'm off to enjoy your game, thanks again for super fast weekend hotfixing :)

I updated all OSX reports which could suffer the same issue by now.
Cheers and have fun :)

I installed the game on Windows 10 using BootCamp for now and everything works beautifully. I just tried disabling the cutscenes in Sierra and I can confirm the game now works.

Thanks for reporting back Marcel,
I am merging your report into this one, so you get updated once we got a solution for cutscenes that works with your OSX.

Pending Customer

Hi Dyegreenluke,


I found your ticket in the General Help & Support forum as opposed to the WFTO Bug Tracker, as a result I've moved it to the bug tracker where it's meant to be. :)


I suspect that you're suffering from a known issue that has cropped up with OS X as of the latest update. Essentially for some reason on a select number of OS X systems the system is unable to play the video files that are part of the campaign. We implemented a workaround in a hotfix which allows you to skip these videos.


If you go to the options menu and click "Disable Cutscenes" under the Display Options tab you should be able to start the campaign with no issue.


Let me know how you get on. In the meantime I'll write a knowledgebase article for this.


Cheers,


Lee

+2
Accepted

Hello dyegreenluke,
You are not alone. It seems multiple OSX users crash on video cutscenes in or current game version.
(this wasn't an issue before and we are still investigating, it is likely a Unity3d issues)

However you can bypass the problem by disabling the video cutscenes in gameoptions.
(There are is one for campaign begin and end, so you wont miss much)
Just activate this option:
http://imgur.com/a/DylI6

We hope we can find a complete solution oon. I will merge your report to the others having the same problem.




Pending Third Party

Pending 3rd party for full solution

Answer
Completed - Next Patch

Hey all, 


We will be pushing an update in the next few days which has fixed this issue. Please get back to us once you have updated if you still experience the crash

Completed - Next Patch

Hi! I've just tried the game on 10.13 (High Sierra) and the cut scenes work without problem. I'm on an 5k iMac

Thats great news! Glad to hear that everything is working as expected!