0
Backlog

Will Only Launch in "Airplane Mode"

cmiles74 3 months ago updated by Lee "Noontide" Moon (Designer & Community Manager) 1 week ago 12

The game will only launch if I have my laptop in "airplane mode". If I am connected to a wireless network it won't launch; I see the first splash screen with the game's title and then the second process starts but exits before the loading screen is displayed. I purchased and run the game through Steam.

With the laptop in "airplane mode", the game runs just fine. It's truly odd.

Is this a known issue, is there a workaround?

Thank you!

Windows Device Information


Processor Intel(R) Core(TM) i7-1065G7 CPU @ 1.30GHz 1.50 GHz
Installed RAM 32.0 GB (31.6 GB usable)
System type 64-bit operating system, x64-based processor
Pen and touch Pen and touch support with 10 touch points

NVIDIA System Information report created on: 09/05/2020 15:34:55


[Display]
Operating System: Windows 10 Enterprise, 64-bit
DirectX version: 12.0
GPU processor: GeForce GTX 1650 with Max-Q Design
Driver version: 442.92
Driver Type: DCH
Direct3D API version: 12
Direct3D feature level: 12_1
CUDA Cores: 1024
Core clock: 1245 MHz
Memory data rate: 7.00 Gbps
Memory interface: 128-bit
Memory bandwidth: 112.03 GB/s
Total available graphics memory: 20275 MB
Dedicated video memory: 4096 MB GDDR5
System video memory: 0 MB
Shared system memory: 16179 MB
Video BIOS version: 90.17.3F.00.0E
IRQ: Not used
Bus: PCI Express x4 Gen3
Device Id: 10DE 1F91 00321414
Part Number: 4905 0010

Game Version:
Steam Public
Platform:
Windows
10th-Gen Mobile Intel CPU - Splash Screen Crash
Pending Customer

Hi Cmiles74,

Sorry for getting back to you so late. We've been heads down on important milestone work on our new project and I've just had time to come back up to the surface to go through our tickets here.

That's truly a peculiar issue and not one I've seen before. However I have seen others with 10th Gen Mobile Intels which report the same crash as shown in this article: Game does not start. Crash after splash screen on start up. [Windows 10 - 10th Gen Intel Iris Laptop, Microsoft Surface 7]

What is very interesting is that you seem to be able to boot the game when Airplane mode is enabled which is very different from what others have reported so far and may actually be a potential workaround for this particular crash. I'll have to check in with a few others suffering this issue to see if they can replicate the same results you've reported.


Unfortunately I don't know of another way around this yet but I'm super curious to get a few more things from you so please can you do the following for me:


  1. Upload your DXDiag files for me How To: Generate a DXDiag Report.
  2. Try booting the game without airplane mode. Assuming it crashes send me your Output.log and Launcher.log How to: Submit a Bug Ticket
  3. Enable airplane mode and do the same again and send these logs. Make sure you rename them so we can tell the difference.
  4. With Airplane mode off try disabling your wifi adapter in Windows, then launch the game. Let us know if this allows you to boot the game. Don't forget to re-enable it after!

Cheers,

Lee

Your suspicion was correct: the game runs with the WiFi adapter disabled. Attached is a ZIP archive with the DXDiag report as well as the output.log and launcher.log files for all three scenarios.

Thank you!


War for the Overworld - Diagnostics.zip

Thanks for bringing all that together for us. It's certainly very interesting and may help us determine the root cause of this frustrating issue. 


One thought we have is that there's an authentication issue occurring for some reason. But we're not sure what might be failing to authenticate, there's not many things we have that "call home" as it were, and certainly not so early in the process. What is most confusing is the role the particular hardware seems to play here.

There's a small chance it's a steam authentication issue that isn't throwing back an error code. To help us test that could you try running Steam in offline mode while your wifi is enabled. We'd really love to know if this changes anything at all.

In the meantime it seems the workaround, while not ideal is to ensure your device cannot connect to the internet.


Thanks,


Lee 

I tried placing Steam in "offline" mode but the game still doesn't launch. :-(

Attached are the output and launcher log files.


Log Files

Thanks for the update Cmiles74,

I've been in touch with other affected users and I'm pleased to say that disabling internet connectivity also works for them. Interestingly one user also reported if they reconnect at any point while the game is running it will close abruptly after ~30 seconds. We're not exactly sure what the cause of this would be but we're eager to investigate further so we're trying to get our hands and eyes on similarly affected hardware from friends and family to see if we can replicate in a more controlled environment.

We'll update everyone as soon as we know more. In the meantime we'll be asking each affected user to give the game a try on GOG (I'll provide a code separately) just to narrow down whether this is affecting only the Steam version or whether the DRM-Free version is affected as well.

Thanks,

Lee

I installed the game with the GOG Galaxy Client and it appears to have the same issue. I start the game and the splash screen appears, then the game exits. In the Galaxy client the play button switches from gray to purple, indicating (I think) that it thinks the game exited normally.

I have attached the output and launcher logs and will give the offline installer a try. :-)

Thank you for the copy of the game! :-D

output_log.txt
War for the Overworld Launcher Log.txt

Backlog

Thanks for the update Cmiles74,

We've confirmed this issue affects all GOG versions as well. We're still investigating and I can't say for certain when a fix might be deployed as our code team are very busy at the moment working on our upcoming title. I'll see if I can push to have further investigation on their side scheduled. In the meantime I can only advise utilising the workaround you discovered and I apologise for the inconvenience.


Thanks,


Lee

the exact same issue  !!!!!!

Hi Dan,

Sorry to hear you're also affected by this issue. We'd like to ask you to raise your own ticket for this and include the appropriate logs and files including a DXDiag report and the make and model of your system. 


How to: Submit a Bug Ticket

How To: Generate a DXDiag Report.

We are tracking this issue and we will be investigating for a solution in our next maintenance patch, currently there's no ETA on when this might be. But we want to make sure we have as much data as possible to help us pinpoint this issue.

Thanks,

Lee

Hi Cmiles74,

I've been thinking a little on this issue and on how we might preserve internet access for affected devices while still enabling you to play War for the Overworld.

If possible could I ask you to try adding a set of outbound rules to Windows Firewall to block the game's access to the internet? Theoretically this should have the same impact as disabling your internet connectivity entirely but for the game alone. Hopefully this should enable the workaround to stay in play while keeping your internet access enabled.

If you're not familiar with Windows Firewall this article should be helpful. Here are the step by step instructions:

  1. Open Windows Defender Firewall (Control Panel) by searching "Firewall" in the Windows Start Menu
  2. From the Windows Firewall settings on Control Panel click "Advanced Settings"
  3. In the Advanced Settings window open the "Outbound Rules" tab.
  4. In the Actions menu click "New Rule"
  5. Click next to confirm this is a program rule
  6. Click browse to navigate to your WFTO install folder. Select WFTOGame.exe as the target and confirm by clicking next.
  7. Select the option to "Block the connection" and click next
  8. Select all profiles and click next
  9. Name this as something memorable such as "War for the Overworld - Workaround 1"
  10. Launch the game to test. If the problem persists repeat the steps above adding WFTO.exe as well as a second rule. (Do not remove the WFTOGame.exe rule)

If you give this a try let us know if either of these rules help your issue. My feeling is that blocking WFTOGame.exe should be enough but both may be required. Reverting the change is simply a matter of deleting the rule(s) you created in this outbound rules list.

Cheers,

Lee

I went ahead and blocked the first executable and then both, but the issue persists. After I read your message I was kicking myself for not thinking of this myself, I was really surprised to see the issue even with these rules in place. I've attached some screenshots as proof that I did setup the rules!

For me, playing the game with the wireless turned off is not a big deal. I can still eyeball mail and stuff on my phone.

Thank you for looking into this issue, I appreciate it. :-)

WFTO-firewall-2.png
WFTO-firewall-1.png

War for the Overworld Launcher Log.txt

output_log.txt

Thanks for the update Cmiles74 and Apologies for my delayed response.

It's truly peculiar, I'm going to ask if anyone else on the team can think of any reason this might be. Logically if it was WFTO misfiring blocking its access to the internet via the Firewall should have resulted in the same workaround.

Most interestingly another user reported that they get a different result when blocking the game in the firewall. I wonder if there's a potential conflicting rule. Have you checked the normal "Allow apps to communicate through Windows Defender Firewall" list. It's possible WFTO is allowed in there and removing it may allow the block to work correctly.