0
Pending Customer

Game doesn't launch after splash screen

liam.dou 8 months ago in Crash updated by Lee "Noontide" Moon (Designer & Community Manager) 1 week ago 16

Core Information

  • Specify your platform - Surface Pro 7 (i5 258GB
    • OS - Windows 10 64bit
      • Ram - 8GB
      • CPU - i5-1035G4
      • GPU - Intel® Iris™ Plus Graphics
  • Specify the build you are using (there will be a timestamp visible on the main menu)
    • Cannot tell, cannot get to main menu. 4/7/2020 version
  • Include as much information as possible (what map you were on, screenshots, videos, etc)
    • Launched game via steam, splash screen comes up, disappears, then nothing happens.
  • Include an output log, crash report or launcher log as required (see below for info)
  • Specify any troubleshooting steps you've already undertaken
    • Found and looked through output log
    • Checked M$ VC redistro 2008, 2010, 2012, 2013, 2015 are installed
    • Checked .NET 4.0 x64 is installed. 
    • Tried to install .NET Framework 4.5.2 suggested in another thread but could not, ".NET Framework 4.5.2 or a later update is already installed on this computer."
    • Checked required specs. Surface Pro 7 gfx card only has onboard RAM of 128MB. Tested on another laptop that also has only 128MB onboard RAM on gfx card, runs just fine.
  • Search the Bug Tracker for any similar or identical open reports, if one exists comment there instead of opening a new ticket
    • Did that.
Game Version:
Steam Public
Platform:
Windows
10th-Gen Mobile Intel CPU - Splash Screen Crash
Pending Customer

Hi Liam.Dou,

Sorry to hear you're having issues with the game not launching beyond the splash screen. Reviewing the output log it seems as though the Unity Engine does begin to boot but for whatever reason it seems it hangs at some point in the process and does not proceed any further. Pretty odd, it's not the first time I've seen this issue recently but I've had trouble getting reports from other affected users so I've yet to be able to determine a common cause.

My current suspicion is that the issue lies with users on non-gaming laptops which do not have discrete Nvidia or AMD GPUs and instead use Intel inbuilt graphics. While the game does run on some deployments of Intel graphics there are known issues with the UI MIddleware (Coherent) and Intel cards, which is why we recommend against them in our System Requirements . The steps you have taken so far are all correct, if possible I'd ask to ensure that your GPU's drivers are up to date as well.

I wonder if you could send me a full dxdiag report for both your affected system and the system where the game runs. Additionally can you send me an output log for the system that the game runs on so I can compare these?


Thanks,


Lee

Ah drat, I did save an output of the dxdiag from the laptop where the game functioned, but I was in the process of wiping it and backing up various files before I send the laptop back to my company, and did not retrieve the dxdiag report before shipping it out. I'm sorry =/

I do have the output log and launcher logs from that laptop though. 

I have run various games on other "non-gaming" laptops with integrated intel cards, but they were likely not Iris. I suspected as you did that maybe this "deployment" of Intel integrated chip/card is the culprit.

I also do have the dxdiag from the laptop where the game did not "function" (Surface Pro 7 - SP7). Can confirm on the SP7 the gfx card driver was up to date

Dxdiag from Surface Pro 7 (where it did not run past splash screen): DxDiag from non-functioning laptop.txt

Output log and launcher log from laptop where game did work:

output_log.txt

War for the Overworld Launcher Log.txt

Hi Liam.dou,

Sorry to keep you waiting. As it stands this issue is still eluding me, though as mentioned you're not alone in being affected and I'm hoping to identify a common cause for all users who are suffering this. 


I want to confirm that the behaviour is as follows:


  1. You launch the game on Steam, the splash screen appears
  2. After a few moments the splash screen disappears but WFTO itself never appears. There is no WFTO program on the taskbar or in task manager. The process just ends.

Can you also try launching WFTO.exe and WFTOGame.exe separately from the game's folder. Just to see if the behaviour is any different. In particular WFTOGame.exe is the game itself, while WFTO.exe is the initial booter program which is meant to launch the game once it's done.


Finally can you confirm if you're running any Anti Virus programs or similar. If so which ones are you running and can you try adding both exes to your exceptions, if that fails try adding the whole folder to the exceptions.


Cheers,


Lee

    Hi Liam, 

    Just checking in to see if there's been any developments on this. To give you an update on our side we're currently operating on the assumption that this is caused by the latest Intel Iris chips in the new 10th Gen Intel CPUs. As only users with Iris are affected. 

    In addition to what I dropped in above could you also try the Intel Driver update tool to see if we get anything from that? 


    Unfortunately if nothing comes of the above we may be at the end of potential workarounds and we will need to proceed with our investigations into other long-term solutions. Unfortunately that means the issue will probably not be resolved for some time, if we ever can. So we can only advise in that case you seek a refund from Steam and indicate the issues you've faced and that you've been working with us to try and troubleshoot the issue.


    Thanks,


    Lee

    Hello Lee,

    Apologies for the delayed response, I appreciate the follow-up.

    I forgot to say in the very first post, I had already tried both executables, to no joy. I put an exception to the Steam folder with the AV (Windows default Defender), no effect.

    I've tried the driver update tool you suggested, same effect (splash screen, executable appears in taskbar and taskmgr briefly for a couple seconds, then disappears).

    Regarding long term solution and refund, I understand, thank you for the guidance and troubleshooting. You may close this ticket if need be.

    Hi Liam,

    One more thing occurred to me as a potential workaround overnight though I can't say how feasible it is as the tech behind the 10th gen Intels are new to me. If our suspicions are correct that it is indeed related to the integrated graphics we could try disabling that in one of two ways.

    1. We could try disabling the Intel Iris display adaptor in device manager (if present). Then try launching the game again.
    2. If that doesn't seem to make any difference. There'll probably be a bios option to disable integrated graphics entirely. 

    I have no idea if those options would make a difference. But it seems worth a shot, naturally I'd have to advise you're careful when fiddling with these settings as they can yield some pretty undesirable results.


    If you have yet to process the refund request please give that a go. If you've already processed the refund then just let me know.

    Thanks,

    Lee

    Hi Liam,

    Scratch that. I had mixed up your system specs with another affected user who actually has a dedicated GPU as well. Please do not try disabling your display adapter or bios settings for Iris, as I believe that would leave you without any GPU enabled!

    At this point we've certainly exhausted our troubleshooting options. So yes please proceed with the refund. 

    In the meantime I'll be leaving this ticket open as it is an unresolved issue and I'll post any updates here.

    Cheers,

    Lee

    Hi Liam,

    I hope you have been keeping well. I wanted to drop in a message as another user has recently reported a similar issue with the same hardware profile. Interestingly this user was able to reach the game on the affected system while it was in Airplane mode. I've yet to confirm this works for other affected users so I thought you might like to give it a go. It's truly a peculiar one as we wouldn't have anticipated a networking issue.

    Here's a few steps you can try:

    1. Try launching the game while Steam is in offline mode, on the off-chance it's a steam authentication issue.
    2. If your laptop has an airplane mode try enabling this and launching the game
    3. Try disabling the the network adapter via Windows. First in the networking adapter menu and if that doesn't work then via the device manager. Instructions.

    Let us know if any of these work!

    Cheers,

    Lee

    Hi Lee,

    Thanks for follow-up on this. Much appreciated. I honestly did not expect to hear anymore on this. I hope you have been faring well as well

    I gave the first two of your suggestions a go, the third I deemed unnecessary as you will see why in a moment.

    1. Steam offline mode

    The result for this was peculiar. The splash screen did not disappear immediately anymore. Instead, it now hangs there and does nothing. I killed the process after a minute or two.

    2. Airplane mode

    My "gaming rig" being a tablet - Surfae Pro 7 - does indeed have airplane mode. I turned this on and the game did indeed launch. I confirmed that it reached the menu and the dungeon keeper said something then I closed the game down.

    3. Disabling the network card

    I did not bother to try this as I imagine it would work as well since option #2 worked.


    Additionally

    Out of curiosity I tried blocking WftO's executable on the Windows Firewall, that did not work. I tried blocking Steam on the Windows Firewall as well (rather, I had to remove it it from the whitelist based Firewall), and whenever I launched Steam it would just get added automatically to Windows Firewall despite me not allowing it when prompted. I don't expect you guys to be able to affect Steam behavior, but just thought I'd let you know.

    Hi Liam,

    Thanks for confirming that for us. We're pleased to hear that this workaround does indeed function at least for those affected on MS Surface hardware. 

    We're still not sure what is causing it and another affected user confirms that if you reconnect to the internet while the game is running it will close abruptly after ~30 seconds. This at least is something for us to go on and we'll be looking into it further once we've got our hands and eyes on an affected model that we can control.

    Cheers,

    Lee

    Hi Liam,

    I've been thinking a little on this issue and on how we might preserve internet access for affected devices while still enabling you to play War for the Overworld.

    If possible could I ask you to try adding a set of outbound rules to Windows Firewall to block the game's access to the internet? Theoretically this should have the same impact as disabling your internet connectivity entirely but for the game alone. Hopefully this should enable the workaround to stay in play while keeping your internet access enabled.

    If you're not familiar with Windows Firewall this article should be helpful. Here are the step by step instructions:

    1. Open Windows Defender Firewall (Control Panel) by searching "Firewall" in the Windows Start Menu
    2. From the Windows Firewall settings on Control Panel click "Advanced Settings"
    3. In the Advanced Settings window open the "Outbound Rules" tab.
    4. In the Actions menu click "New Rule"
    5. Click next to confirm this is a program rule
    6. Click browse to navigate to your WFTO install folder. Select WFTOGame.exe as the target and confirm by clicking next.
    7. Select the option to "Block the connection" and click next
    8. Select all profiles and click next
    9. Name this as something memorable such as "War for the Overworld - Workaround 1"
    10. Launch the game to test. If the problem persists repeat the steps above adding WFTO.exe as well as a second rule. (Do not remove the WFTOGame.exe rule)

    If you give this a try let us know if either of these rules help your issue. My feeling is that blocking WFTOGame.exe should be enough but both may be required. Reverting the change is simply a matter of deleting the rule(s) you created in this outbound rules list.

    Cheers,

    Lee

    Hi Lee,

    I've already tried that in my last post ;) I tried blocking both the WftO, separately and together, as well as Steam. No joy.

    "Out of curiosity I tried blocking WftO's executable on the Windows Firewall, that did not work. I tried blocking Steam on the Windows Firewall as well (rather, I had to remove it it from the whitelist based Firewall), and whenever I launched Steam it would just get added automatically to Windows Firewall despite me not allowing it when prompted. I don't expect you guys to be able to affect Steam behavior, but just thought I'd let you know."


    Is this what you're asking me to do? Or is it something different?

    Hi Lee,

    More update. Apologies, seems I had misunderstood your instructions.

    Previously when I tried to block WftO from the firewall, I had went in here:

    And then here:

    And since it said "allow apps", I thought it was a whitelist based firewall, so I removed WftO executables from it and thought that was that. I went back and re-read your instructions. I didn't realized advanced settings allow you to specify block or allow, and then I followed that instruction.

    Interestingly, blocking the game exec from the firewall had this effect after the partial splash screen comes up:

    At least this is something different. I do believe I have the adequate DirX installed, because when I tried the aforementioned wifi-disabling method, the game did not complain about this.

    Pending Customer

    Well that's certainly something. Interestingly your experience is different from another affected user, when they blocked the game it simply refused to launch as previous.

    I'm at a loss as to why this would have such a drastic effect as seemingly preventing the Engine from initialising your GPU.

    As an off-the-cuff thought perhaps you could try different render modes. 

    Solution 2: Forcing DirectX rendering mode

    1. Right click the game in your steam library and go to properties
    2. Click "Set launch options"
    3. Add "-force-d3d9" in this box (No quotation marks)
    4. If this fails and you have a DX11 compatible GPU then add "-force-d3d11" instead.

    But before you do anything else could you send me a new Output_log and launcher.log when trying to launch the game with this new issue?