Completed - Resolved

the game wont'launch osx

notacode 6 years ago updated by Scott Richmond (Programmer & Producer) 6 years ago 22

*Snip* - Noontide


Game Version:
Steam Public


Satisfaction mark by notacode 6 years ago
Pending Customer

Hi Notacode,

Thanks for the report and sorry to hear about the trouble's you're facing.

I'd like to gather a few more details from you please can you answer these questions:

  • What version of OS X are you running
  • How long have you owned WFTO has it worked previously?
  • What happens when the crash occurs?

Just to let you know I've also put your log into a file and uploaded it to make the opening post easier to read.

Please give the following threads a read:

How to: Submit a Bug Ticket - See if there's anything more you can provide that you think might assist us in diagnosing this issue.

OS X Crash on Startup (v1.4.0+) - We had an OS X crash previously which was fixed in 1.4.2f5 but just in case check this thread to see if the crash is similar, if so give the workaround a try.



1) macOS Sierra 10.12

2) i've buyed 20 mar 2015 play 2 months then stop for a bug in 5 level and new stuck

3) steam>play> wtfo configurations> crash after 0.1 sec and ask for reopen ( tried with every settings )


If you receive an error message can you provide a screenshot of that as well? Give the workaround a try and let us know how you get on in the meantime I'll forward this for review by our coders.

it's enough? it's correct? thanks

Hi Notacode,

The screenshot you provided is an screenshot of the error log. What I'd like to see is if when you crash you receive an output from the game or engine, though I confess my knowledge of Mac is not extensive I would expect to see some sort of popup box with a message in it.

Still I've forwarded this onto our code team for review one of whom is familiar with OS X related issues. We'll look into the log provided and see what might be happening.



no output at all, ask for reopening of atto config and error log

Forgive my ignorance but might be important. What is atto config?

wtfo configurations sorry for the typo

Under Review

This means that not even Unity3d engine can start at all.
Now there could be various reasons why this is the case.
The log shows it is crashing when trying to initialize your graphics device.

  • 12 dyld 0x000000010be1dd5b ImageLoaderMachOCompressed::doBindFastLazySymbol(unsigned int, ImageLoader::LinkContext const&, void (*)(), void (*)()) + 363
  • 13 unity.Subterranean Games.War For The Overworld 0x0000000101153970 GfxDisplayGL_Init(dynamic_array<GfxDisplayGL, 8ul>&) + 240
  • 14 unity.Subterranean Games.War For The Overworld 0x00000001011909b7 CreateGLGfxDevice() + 135
  • 15 unity.Subterranean Games.War For The Overworld 0x0000000100a87e20 CreateRealGfxDevice(GfxDeviceRenderer, bool) + 48
  • 16 unity.Subterranean Games.War For The Overworld 0x00000001011df9b9 GfxDeviceWorker::Startup(GfxDeviceRenderer, bool, bool) + 25
  • 17 unity.Subterranean Games.War For The Overworld 0x00000001011cefbc CreateClientGfxDevice(GfxDeviceRenderer, unsigned int) + 172
  • 18 unity.Subterranean Games.War For The Overworld 0x0000000100a88620 InitializeGfxDevice(unsigned int) + 432
  • 19 unity.Subterranean Games.War For The Overworld 0x0000000100b6b345 InitializeEngineGraphics(bool) + 69
  • 20 unity.Subterranean Games.War For The Overworld 0x0000000100b4d298 PlayerInitEngineGraphics(bool) + 24
  • 21 unity.Subterranean Games.War For The Overworld 0x0000000101154372 SetupUnityPlayer(bool, int, char**) + 7

So chances are there is something wrong in the setup of your GPU.
Do you have other Unity3d based games that work for you?
Are your GPU drivers up to date and have no misconfiguration?

Can you share your full system specs with us to see which hardware is involved?


sorry for the delay....

I dont think that i have others unity games installed

driver are handled in osx so updated

here my config:

Model: iMac15,1, BootROM IM151.0207.B07, 4 processors, Intel Core i7, 4 GHz, 16 GB, SMC 2.23f11
Graphics: AMD Radeon R9 M295X, AMD Radeon R9 M295X, PCIe, 4096 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x802C, 0x31364B544631473634485A2D314736453220
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x802C, 0x31364B544631473634485A2D314736453220
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x142), Broadcom BCM43xx 1.0 (
Bluetooth: Version 5.0.1f7, 3 services, 27 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: APPLE SSD SM0512F, 500,28 GB
USB Device: USB 3.0 Bus
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: FaceTime HD Camera (Built-in)
USB Device: HP LaserJet 200 colorMFP M276n
USB Device: USB Optical Mouse
USB Device: Keyboard Hub
USB Device: Apple Keyboard
Thunderbolt Bus: iMac, Apple Inc., 26.1


Closing due to lack of response from customer.

Pending Customer

Hello Notacode,

I see you have marked this topic as not satisfied. I closed this as we were awaiting your response for over two weeks as per our standard policy.

As you are not satisfied I have reopened the ticket please respond to Stefan's post above and we will proceed to troubleshoot further.




Hrm this doesn't look too good, seems like one of Unity3d's incompatibility issues with OSX.
However they constantly do fix these and we always update to newest stable version they release.
Recently there were some OSX issues but they fixed most of them so that we don't get reports like yours in the last weeks.
But we have hopes that meanwhile your issue got fixed by Unity as well.

So we hope that the new Patch we are releasing at the end of this week does resolve this issue for you.
If not please let us know, then we need to reach out Unity Technologies support to make them aware that there are still issues.

I am sorry for inconvenience but also we depend on third party software which has sometimes issues on certain system configurations.
Hope it will be sorted this weekend.

Pending Customer

Does it work now correctly with the new Patch?

Welcome back underlord!!!!!! wow!!!!!

Great news, sounds like you're back in again? :)

Completed - Resolved

Awesome news, I'm marking this as complete now :)

And still unsatisfied? (^.^)/)