+8
Completed

Heart of Gold lvl 1: Torturing Mandalf does not trigger next stage, level unwinnable

knightenterprises 3 years ago • updated by Lee "Noontide" Moon (Community Manager) 3 years ago 17 1 duplicate

Hi, when I torture Mandalf on Heart of Gold level 1, he acts like a normal enemy being tortured. The dialogue that I have seen on other people youtube videos is not trigged. Eventually he is converted to my side, but that is no use to me as the level is now unwinnable.


My specs:

I5 processor

8GB RAM

Windows 7

64 bit

Game Version:
Steam Public
Platform:
Windows

Duplicates 1

Accepted

hello Knightenterprises


im sorry to hear about your troubles, this issue is known (and i will probably merge your ticket) sadly the only way to progress at that point is to replay the mission, we are working on a fix however.


im sorry for the inconvenience

Same here. Steam - mac version.

+1

Hi Jan,

Is it known what causes this problem? Because I really want to play heart of gold, but I don't want to play that whole level again, just to encounter the same issue.

Glad to hear you guys are working on a fix.

As in was the problem caused by something I did in the level (and so when I play it again I will make sure not to do it)?

+2

Same here. I captured him, tortured, eventually converted. Nothing happened.

+3

My "select unit bar" dissapeared, so I cound not just pick Mandalf using that. Maybe it's related. I have also managed to clone Mandals using quick freeze potion on him, which caused to spawn him but also the first one in my prison stayed. That was useful actually, because I have then spend 4 hours torturing, transforming, humiliating, beating, slapping (also put him against bard in the arene) multiple Mandalfs, just to discover that it's a bug.

Well hope you will fix this quickly and also in a way we don't have to replay the mission ^^

+1

Just for more information for the developers - my unit bar did not disappear, and Mandalf appeared in the bar like a normal minion.

+2

I also and still have the problem that i can`t end level 1. I capture and torture him but nothing happens. I also tried to restart 2 times right now. When or how will it be fixed?

In my case, I had to start the map anew a few times, and then rush to him (his level is low anyway) to capture and torture to find out if the script is going to work this time or not. Eventually it worked.

+1

i will also send this through even if the old issue has been "completed" as it obviously hasnt really been fixed, merging your new thread with this one

Hello = ) Before I can start on that can I get a save file with the problem please ? (To upload a save file refer to https://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/)

Thanks

Thanks for the quick response :] I've found the issue and fixed it internally, I was able to load the save game and finish the level properly, it will be available in the next patch ; ) again thanks for reporting the bug and sorry for the delay ! We've been quite busy lately ^^"

Completed - Next Patch
+1

Don't suppose you could tell us what the issue was?


Would like to know what either I did differently during game to cause this, or if it was something to do with my computer being different in some way from the vast majority of users.


Also yay for it being fixed during next patch.