Completed - Resolved

Cannot fry creatures in taverns anymore

Old Cat 7 years ago updated by Stefan Furcht (Programmer) 7 years ago 10

I believe after last patches it's not possible to use both creatures and prisoners as a meat in taverns. I simply cannot drop them there, in the cooking device. Tried it in the home realm.

Game Version:
Steam Public

+1 to this, I observed it last night, hope this will get resolved soon!

Under Review

i cannot really reproduce, i mean yes the slaughterpen gets filled really fast and the game blocks the drop if it is full. I can send this through as an improvement, however i want to make sure this is not a real issue.

can you guys check if you can throw prisoners into the Spitroast when you do not support i with micropiglets?


I can test it more a bit later, for now I can tell that it was approximately at 2/3 of its capability when I tried to do it. Clearly not full.

Yeah, turns out you can't drop creatures inside if it already has more than 1/2 of its capability. It seems a little too strict, if I want to quickly free some space in prison with no access to graveyard, tavern probably is the best way.

Just as a recommendation, unlock Blood Money. You got the waste, might as well turn it into money.

I think this is related to the fact that roasting prisoners now adds 60 or so meals meals to the tavern, and the roast won't accept more meals than it can storage.

Very minor however, imho.

Yup, forgot about blood money :)

Still, I don't see a reason to limit overlord's freedom in this case.


Cheers guys. We agree and will get this resolved shortly.