0
Completed - Resolved

CTD report before title menu

NoobNooberNoobest 4 years ago updated by Stefan Furcht (Programmer) 4 years ago 22

The first of the beginning that I purchased was able to play.

But CTD came to happen from the second play.

Meanwhile, because it did not pass with 1st, I think that it is not the problem of the driver.I updated a driver, but was no use for the time beng.
It was no use even if I installed a game again.

OS:Windows7-64bit

CPU:Intel core i7 4770

GPU:NVIDIA geforce GTX 760


Game Version:
Steam Public
Platform:
Windows

Answer

Answer

Hello NoobNooberNoobest,

Did you by any chance install the Japanese Translation mod from:
https://steamcommunity.com/sharedfiles/filedetails/?id=611504489
???

I think the issue is indirectly caused by this, because it adds a new column to the games translation file for Japanese, which then allows to select Japanese language in the game options, what you did.
However with the new Patch 1.4 the translation file was updated and overwritten, so that the additional Japanese translation column is now gone.
And now in the game options the selected language points to this non existing column for Japanese, which is causing the game to not load properly anymore.

But even if you would now reinstall the Japanese translation mod to the new patch, it would cause issues, because many translation keys were changed or added recently.
So to play in Japanese, I fear you will need to wait a little while till a new version of the Japanese mod is released, matching the new keys added with patch 1.4.

For now you can quick fix the problem by editing the Options.txt file to set your language back to English.
We will make on our end sure for next patch, that the game falls back to English and starts properly in case the selected language in options does not exist in the translation file.

To set your language back to English:
- Go to your games library in steam
- Right click on "War for the Overworld"
- In the context menu select "Properties"
- Switch to "Local Files" tab
- Click on "Browse Local Files"
- Go to subfolder "WFTOGame_Data/GameData"
- And open the file "Options.txt" in a text editor
- Find the line "Lang=7" (non-existing Japanese translation) and change it to "Lang=0" (existing English translation)

Then your game should start correctly again, but in English language.
Once an updated version of the Japanese translation mod is available you can install it again to play in Japanese.

As said we will make sure that future changes on the translation file will not break the game in case such translation mod is applied.

I hope this helps!

Cheers and good luck,
Stefan
(WFTO Programmer)

Try validating the game cache in Steam. Right click the game then Properties -> Local Files -> Verify Integrity Of Game Cache


Tried.

But cant play.

I tried Uninstall and Reinstall, the result was the same...

Accepted

can you please check if a crash_log was generated also please upload your output_log as well.


you can find both here (or your designated steam libray location)

X:\Program Files (x86)\Steam\steamapps\common\War For The Overworld


the crash_log can be found in a folder with the date it crashed, the output log is in the WFTOGame_Data folder and is overwritten after each start.


please also tell me if you have a integrated GPU and which resolution you set for the game.


thanks for your report!

output_log.txt

This one?

Prbably I do not use on board GPU.

And dont touch BIOS between the first play and the second plays.

Pending Customer

uff.


so i really need to know if you have a integrated GPU (probably IntelHD) or if you only have a dedicated GPU.


other than that please read this topic: http://steamcommunity.com/app/230190/discussions/0/523890681426547342/


there may be a solution for you there, if not please come back to me and ill try my best to find and solve your issue

BIOS

System Agent Configuration

VT-d = Enabled

Graphics Configuration

Primary Display = Auto

iGPU Multi-Monitor = Disabled


and use GPU-z


I do not use the audio system of the usb connection.


I cut security software.
and set NVIDIA Control Panel individually.
and started in -dx11.
But can not play.

Try using this in the launch options:

-force-d3d9

Tried -force-d3d9 too

fmm....

Accepted

Ah we've found a potential bug in your log file! We'll get back to you once we've looked at the issue in more detail.

You said you know how to fix Stefan ; )

Answer

Hello NoobNooberNoobest,

Did you by any chance install the Japanese Translation mod from:
https://steamcommunity.com/sharedfiles/filedetails/?id=611504489
???

I think the issue is indirectly caused by this, because it adds a new column to the games translation file for Japanese, which then allows to select Japanese language in the game options, what you did.
However with the new Patch 1.4 the translation file was updated and overwritten, so that the additional Japanese translation column is now gone.
And now in the game options the selected language points to this non existing column for Japanese, which is causing the game to not load properly anymore.

But even if you would now reinstall the Japanese translation mod to the new patch, it would cause issues, because many translation keys were changed or added recently.
So to play in Japanese, I fear you will need to wait a little while till a new version of the Japanese mod is released, matching the new keys added with patch 1.4.

For now you can quick fix the problem by editing the Options.txt file to set your language back to English.
We will make on our end sure for next patch, that the game falls back to English and starts properly in case the selected language in options does not exist in the translation file.

To set your language back to English:
- Go to your games library in steam
- Right click on "War for the Overworld"
- In the context menu select "Properties"
- Switch to "Local Files" tab
- Click on "Browse Local Files"
- Go to subfolder "WFTOGame_Data/GameData"
- And open the file "Options.txt" in a text editor
- Find the line "Lang=7" (non-existing Japanese translation) and change it to "Lang=0" (existing English translation)

Then your game should start correctly again, but in English language.
Once an updated version of the Japanese translation mod is available you can install it again to play in Japanese.

As said we will make sure that future changes on the translation file will not break the game in case such translation mod is applied.

I hope this helps!

Cheers and good luck,
Stefan
(WFTO Programmer)

Completed - Resolved

I just implemented a fix, which will make the game fallback to English, when game options refer to a non existing language translation column.
Next Patch or Hotfix update will contain this fix.
We are sorry for the inconvenience we caused to all Japanese players using the "War for the Overworld日本語化プロジェクト" mod.

Thanks a lot for pointing us to this issue, NoobNooberNoobest.




I was able to arrive at a title menu!!!

sorry and very very thank you!

I troubled all of you really for a long time.

I intend that I play this game and study English.


Thank you! and thank you!

Hah it was our failure that the game did not load when someone puts an invalid language index into the options.
But as said, it will be fixed next version.
I am glad it is fixed for you now.
Have fun! :)

+1

thanks!

I 'll enjoy this game!

thank you.

I download it.

Thank you for updating the mod so quickly CurryDays.
Top! :)