0
Completed - Resolved

Random artifacts always give gold.

Галиев Рустем 4 years ago updated 4 years ago 25

Windows 8.1 64 bit, 8 Gm RAM, Intel(R) Core(TM) I7-4500 CPU1.80 GHz 2.40 GHz GPU: AMD Radeon R7 M265, Intel(R) HD Graphics Family. Version game fresh, 1.3.2f3


Random artifacts always give gold.

It does not matter, set all of the weights in the manual, or left at 0 (default).
Tested repeatedly. Last time, on my map Λαβύρινθος του Μινώταυρου.
There are about 15 random artifacts. They all give gold. Here the 2 screenshots next to my dungeon core.


You can see that there are weights for some values - but the weight of gold remained at 0! However, they gave gold, like all other artifacts.

Moreover, try it for yourself in the map editor to create sloany artifact. Hover over it with the mouse. Will indicate that this is an artifact of gold.

Please fix this bug.

War for the Overworld Launcher Log.txt

output_log.txt
Game Version:
Steam Public
Platform:
Windows
BAD, I'M UNSATISFIED

2 times the topic is closed, as a solution. But the problem persists.


Satisfaction mark by Галиев Рустем 4 years ago
+1
Accepted

Can confirm this, sending through.. thanks for the report.

Completed - Resolved

The bug is fixed? Now random artifacts can not only give gold?

It's fixed internally, and will show up for you when the next public build is released.

Not fixed. Just checked. 8 random artifacts. All gave gold.
With it, the map updated today too (adding random artifacts) and checked into the game.

Confirmed not fixed.


@Nano see this map created by Riva http://steamcommunity.com/sharedfiles/filedetails/?id=696141077

Each artefact is random, different artefact grouping and different slider values but all come out as Plentiful Gold.

When I just test it on a new map it works fine.

Debugging the linked map and I see the cause.

Fixed the problem but the fix will not be contained in currently uploading hotfix 1.4.0f10 since it is too late now,
but in the next update after this one random artefacts will work as intended.

Completed - Resolved

Not fixed [2].

1. Created in map 8 random artifacts. Chose random (which have a separate menu icon random artifact, and in which the weight of any event = 0).
2. Assign each a separate group, from 0 to 7.
Began to play in the map. All artifacts were given gold.
Check.

It should be fixed in v1.4.0f11 and it was tested on the map linked by Nutter, where it was not working and we made it work.
Did you update to this version and if you did, can you upload a save game where it doesn't work for you?
Cheers

Tested it again and it worked fine, so either you are not updated or we need a save to see why it does not work for you.

Ready. 2 save, one before I began to study the artifacts. Another after examining all 10 artifacts.
Test random artifacts (before studying the artifacts).rar

Test random artifacts (after studying the artifacts).rar

Video of the map editor, I show that assigned each of the 10 artifacts group (0 to 9).

ice_video_20160607-222330.webm

Screenshot after studying the artifacts.


A little clarification, it might be important.
At first I just put the map in 10 random artifacts. Then, they changed the group from 0 to 9.

And Yes, for some reason, in this map, I can't put the artifact on Research Shrines. Maybe this happens in all maps, in which Research Shrine in advance (from the beginning) the owners of the player.

I loaded your "Test random artifacts (before studying the artifacts).rar" save game and debugged it.
The problem is that all weights on your artefacts are set to zero and in this case it will always chose the first one which is the gold artefact.

Can you double check the weights you set up in the map editor if they are really non-zero?
Maybe you forgot to save or something?

This is a bug, isn't it?
In the menu there are artifacts. There is an artifact called "random". I, and every other player has the right to expect that this truly random artifact. But this is not so.
I have no reason to believe that this is not a bug.

P.S. If you 1) provided in the map editor, an artifact called "random"
2) Set all weights default to 0.
3) Artifact not working as random, but will work, if you specify a weight greater than 0.
= Can you make it so that by default, all the weights in a random artifact would be equal to 100? Or 50, which is a bit more convenient for manipulation.

P. P. S. I do not understand, what is your phrase at the end "Maybe you forgot to save or something?" What saving could I forget, what is it?

Random artifact in the map editor has all weights equal to 0.

Look: in the map editor, in addition to specific artifacts, is an artifact called "random". Because it is not written that this artifact gives priority to anything that I, when creating the card - have the right to expect that enough for me to put it. And in the game, after the study, can be obtained by any possible effect. With equal probability.

Nowhere is it written that I need to manually set weight. This feature existents, but as an option, not as mandatory requirement. And if I put "random artifact "default", I expect that he will give something by accident. With equal probability. That's how it should work.

Should be something in the map editor that the game doesn't work. And a random artifact is not working. If you do not put weight. But vyselenie hand weights is not specified anywhere as a mandatory. It is much more convenient for all if the random artifact will be immediately employed, without additional manipulation. Logically, then all the odds must be the same.

+1

You are right it should be random by default, but with all weights zero it can't be.
We will change it to be random by default.
But if you setup positive weights for multiple it will correctly select each with a probability according to given weight.
Eg. if you set all weights to one (slider max right) it will be random for you without hotfix.

Next hotfix it will be random even in the corner case if all weights are set to zero.

+1

It is changed now to be random by default and will be patched with next update.