Completed - Resolved

Game Crashes Upon Opening

c24math-first 4 years ago updated by anonymous 4 years ago 21

I just bought the game and every time I try to run it it gets to a loading screen with a loading bar, progresses, but then crashes (without notification or message) before the loading bar is complete. I have not yet been able to play because of this. I'm running Mac OSX 10.10.5 and playing the game through Steam. I looked at the Player.log and found this message "Fallback handler could not load library /Users/Outrider/Library/Application Support/Steam/steamapps/common/War For The Overworld/WFTO.app/Contents/Frameworks/MonoEmbedRuntime/osx/GalaxyCSharpGlue"

Game Version:
Steam Public
Pending Customer

Can you send us that file, please?


I hope this is sufficient!

Can you please try these steps


I'll look into this and let you know what we come up with

Do I follow Case 1 and try to install that even though I'm on a Mac?

if the games install folder does not contain a _redist folder then ignore it

Uninstalling and re-installing has not helped. One extra piece of info: when the game starts, it automatically goes into full screen mode. When it crashes (before leaving the loading screen), it reverts as the game window disappears.

We have a patch that should be out soon, can I get you to wait and try that? I'll post again when its live

Two questions:

  1. When do you expect that the patch be coming out?
  2. How likely do you think it is that the patch will solve the problem?
  1. Right now
  2. 60%

Let me know if it's working if not I will move forward with further diagnostics

I installed the updates that Steam had (27.5MB) and tried to run it again. Same problem. The loading screen says "Untold Depths patch 2.0".

I quit Steam and restarted it, but nothing changed.

Yeah the loading screen art only changes for major version (1.4, 1.5, 1.6, 2.0 etc)

The behaviour is the same? Do you crash at the end of the bar?

Attached is a zip file, it contains a ".bundle" file. Can you please do the following

  1. Right click WFTO in steam
  2. Click properties
  3. Click Local Files
  4. Click "Browse Local Files"
  5. Right Click WFTO in Finder
  6. Click "Show Package Contents"
  7. Go to the "Plugins" folder inside the "Contents" folder
  8. Replace the CSteamworks.bundle with the one I sent you

Let me know if that changes anything when you try to load after doing that


I did as you instructed and had the same result. The game quits after the loading bar is about 70% full.

Can you send me another log please

Are there any updates on this?

Pending Customer

Sorry no there's not.

We have not been able to replicate this issue on any version of macOS we have available to us, we have also had no other reports of this issue. I would suggest that you attempt to upgrade to Mojave and see if that fixes the issue. There's not a lot we can do as it looks to be some sort of broken security config on your machine, please let us know if upgrading changes anything.

Hey c24math-first,

Any luck upgrading to Mojave?

Yes! Thank you, upgrading to Mojave fixed or avoided whatever problem there was and the game works now.

Completed - Resolved

Great! Let us know if you have any further issues