Exporting maps to steam workshop doesnt work in 2.0f9

Hiding Korvek 5 years ago updated by Scott Richmond (Programmer & Producer) 5 years ago 21

I tried to export a map to the steam workshop (in 2.0f9) (Nutter and I already discussed that on the discord #map-design 16:52 CEST 26/4/18)

If i try to publish it on steam it seems to work at first

Image 5517

but then shows an error message a while after clicking "OK".

Image 5518

In the workshop it then looks like on

Image 5519


Image 5520

Output log: output_log.txt

Game Version:
Steam Public

The support is super nice and seems to really care for the customers/tries to solve problems instead of telling you "we cant help you with that". Feels great :)

Satisfaction mark by Hiding Korvek 5 years ago


You may need to make sure that you've accepted the Steam Workshop agreement before you can publish. You can do this at this link here: https://steamcommunity.com/workshop/workshoplegalagreement/

Sadly that didnt work. I even already tryed that before. If you ask me it looks like WftO fails submitting the map to the workshop entirely but im not a specialist.

By the way i forgot to attach the link to the map (dont know if thats helpfull but rather have some more information than too less): Its here

Edit: might also be a steam issue because i just noticed it never stops saying i accepted it at 4. of january no matter how often i click the button

Maybe try uninstalling and reinstalling your Steam client (youe installed games should be unimpacted by this).

Sometimes this fixes such Steam related issues.

Please let us know if it helped.

I tried and it did nothing :(

Pending Customer

Looks like the minimap file is missing for this map. Can you try and publish locally and see if you're able to play it. 

If you can try to publish again after starting it once

Sadly this gets me the same error message over and over again. But I am able to publish locally so it seems to either be a steam only or a WftO-Steam-communication problem

Hi Hiding Korvek,

Sorry it's been a little while since we last responded. We've been extremely busy lately.

Can you confirm this issue still persists so we can confirm it's not a temporary steam related issue before I pass it back for review by our team.



Can you try again and send another log?

Does it still happen if you create a new map?

I'll try on tuesday. Sadly im not at home until then

No worries, get back to us then

Hi Hiding,

I suspect an issue between Steam and your firewall, but can you upload the actual map you're trying to publish  (the _edit version)? How to: Locate your save files

Or is it any map ? (If it is any map, as said it might be your firewall /antivirus, maybe try to disable it temporarily and try again ?)

Pending Customer

The map

I turned of my firewall and all antivirus but the same error continues to occure

Im not shure if it was the correct file.

The other one is here.

So testing to publish your map worked for me. 

It is an issue with your local Steam. Sadly Steam  is unhelpful with their k_EResultFail as it's their generic "There is an issue" message.

So it's not firewall, nor their EULA.

1) Have you got a lot of save files / workshop subscription ? (If so try to delete a bunch and see if it helps)

2) Does the workshop works for other games by any chance ?

3) If the firewall did not help, there is still a chance that your router is blocking the traffic, if you have any chance of uploading a map outside of your normal environment and it works, that would point to the router. (like this thread for example)

I'm running out of other idea to find the culprit. But the map uploading fine on my side shows that something somewhere in your local setup prevents it ^^' We just need to find out what is preventing the upload

In that case its most likely my router. It doesnt like some stuff in generell if I recall correctly. Thank you for your help though. I really appreciate this customer support :D

Ill try these things out asap but especially the router may take a while

Let us know how it goes