+1
Completed - Resolved

Black screen on launch

walgleaf 1 year ago • updated by Cian Noonan (Development Support Engineer) 1 year ago 12

Core information:

OS: Windows

Version: 7

64 Bit

Ram: 4.00 GB

CPU: Intel core i5 CPU @2.27 Gh

GPU: ATI Mobility Radeon HD 5470

WFTO Build: 2.0


Launched War for the overworld via Stream, Screen got stuck at black screen for 5 minutes. Killed it. Verified integrity of game files, launched game. Was stuck on black screen for 15 minutes, killed it. Restarted computer, launched game, waited 20 minutes, was stuck on black screen for that duration. Ended the process. Launched game, opened task manager and set the game to 'High priority'. Left room, waited 20 minutes and came back to the black screen, ended process.


output_log.txt


Additional notes: I saw other problematic black screen bug reports, but those being before 2.0 came out reasoned with me, that I should post a new bug report. I hope you all don't mind this new one.

Game Version:
Steam Public
Platform:
Windows

Heyy

I'm experiencing the exact same issue. The game responds normally, can easily alt-tab in and out of it, but it stays in a permanent black screen after splash. I'm pretty sure its 2.0 related. Just gotten HoG and the Underlord edition alongside with the update, but the HoG troubleshooting didn't help, nor the general crash guides. 


Also Windows 7

 
War for the Overworld Launcher Log.txt In case launcher log is needed too.
output_log.txt


For some reason my system has not updated since last November. So I went ahead and updated the computer, restarted, and verified game files. Still black screen.

Went to download Microsoft Visual C++ 2015 Redistributable Update 3 RC, but when I run it, it says I already have it installed. Which is odd, because I have every instance of Microsoft Visual C++ 2005-2017 installed, but not instances of 2015.

Uninstalled every instance of Microsoft Visual C++ 2017 Redistributable.

Installed Microsoft Visual C++ 2015 Redistributable from the War for the Overworld file ("_CommonRedist/vcredist/2015") Restarted computer.

Validated file integrity of WFTO. For some reason, one file keeps needing to be re-acquired. Launched game. Still black screen.


output_log.txt


Please help me.

Hey walgleaf


A similar issue was solved in my case, dunno if you checked that thread already


https://brightrockgames.userecho.com/communities/1/topics/3928-blank-screen-after-splash


In case you're on a win7/8 machine, did you install every single update you had in queue except for language packs? 

Coincidentally that was the exact thread I was trying to work off from.

Yes, I had about 59 updates, got them all and restarted the computer. still black screen.

And if you check you're 100% done with them right?



Sorry for pushing it, but sometimes updates can pop up right after you did a lot.


ps.: hilariously enough i just got the message popping up that there's 8 more important update to do.

Yes, 100% certain. I only have optional updates left. I'm going to install the 22 optional Windows updates and see if that does anything.

Alright! Good luck man, hope they'll get to you soon, in case the update wont cut it.

Pending Customer

Hey walgleaf,


Can you please verify that you have Windows 7 Service Pack 1 installed

Yes, I have service pack 1 installed. Here is a screen shot.


Can you please double check that the game is running on your dedicated GPU and not your Integrated one


Solution 1: Forcing WFTO to use the most powerful GPU in your computer


Follow the instructions below based on what GPU you have (NVidia or AMD).


How to force the more powerful AMD GPU to turn on:

  1. First, go to the AMD website[support.amd.com] and download and install the latest drivers for your GPU.
  2. Right click on your desktop -> Select "AMD Catalyst Control Center"
    This should open your graphics card control panel.
  3. Select "Power" -> "Switchable Graphics".
  4. In the page displayed, disable Switchable Graphics.
  5. Launch the game to test.

How to force the more powerful NVidia GPU to turn on:

  1. First, go to the NVidia website[www.nvidia.co.uk] and install the latest drivers for your GPU.
  2. Right click on your desktop -> Select "NVIDIA Control Panel"
    This should open your graphics card control panel.
  3. Select "3D settings" -> "Manage 3D settings" -> "Global settings".
    In the drop-down menu "Preferred graphic processor" select "High-performance NVIDIA processor" instead of "Auto-select".
  4. Launch the game to test.

If the above doesn't work you can attempt to force the switch specifically on WFTO.


Forcing WFTO to use your Nvidia GPU


  1. Open Nvidia control panel as above
  2. Select 3D Settings and reset your settings to default
  3. Select "Program Settings" tab from the 3D Settings menu
  4. Add WFTOGame.exe from your WFTO Directory (You can find this by right clicking the game in steam, going to properties and clicking "Browse local files")
  5. In addition be sure to add "CoherentUI_Host.exe" with the same settings below.
  6. Select "High-performance Nvidia Processor" as the preferred graphic processor as above.

Solution 2: Forcing DirectX rendering mode

  1. Right click the game in your steam library and go to properties
  2. Click "Set launch options"
  3. Add "-force-d3d9" in this box (No quotation marks)
  4. If this fails and you have a DX11 compatible GPU then add "-force-d3d11" instead.


Solution 3: Disable AMD Crossfire

Users with two AMD graphics cards may find that they will have to disable AMD Crossfire.


I thought my GPU was already updated to the latest driver, but I went ahead and went to the AMD website and messed my computer up by downloading the wrong driver. Then I tried it again and my computer black screened on me upon start up. So I had to go into safe mode and do a system restore. Attempted to update drives once more, got black screen upon boot up and had to system restore.


When I left clicked on my desktop to go to AMD Catalyst Control Center, I could not find  "Power" -> "Switchable Graphics".


I added "-force-d3d9" to the launch options to the game and it worked! Horray! Thank you so much! It said that was for advanced users only. Does…does this mean I’m an advanced user now?

Joking aside, you got it to work. Thank you.

Completed - Resolved

Welcome to the 

ADVANCED USER CLUB


Access is granted by having a totally broken copy of the game ;)


Let us know if you have any further issues