Completed - Resolved

Blank Screen after splash

Paul 5 years ago updated by anonymous 5 years ago 23

Ok, so as the above mentions, I load the game the splash thing pops up, and then I'm staring at a blank screen.

Fixes tried -

1. changed compatibilty of both WFTO.exe and WFTOGame.exe to windows & (as im running windows 7) - nothing changed ...... (sad face)

2. Checked Output Log, WHAT???? OMG CoherentUI_Native.dll is missing?!?!?!
 Ok mild panic all i need to do is check the integrity of the game files ... check, File missing and will be redownloaded (or something to that effect)
... lets recheck, yep all files vaildated AWSOME!!!
... Splashie thingie thing check, owwww and now this time the computer is thinking (it didn't do that last time)

.. ok false alarm, sad face again, still blank screen.

3. Check step 2 again .....

WHAT THE F%$*&NG S^%T ... CoherentUI_Native.dll missing again!!!!!!!!!!!!!!!!!!
ok, so I revarify ... again ..... Oh look its missing a file again suprise, and its reacquiring through .... AGAIN.
recheck ... again, yep files all accounted for ..... lets recheck again just to be safe...... yep still there WOOHOO!!

Launch game .....

Guess what .... WHAT THE F%$*&NG S^%T'IN PI$%NG WA&K!NG STAIN IS THIS BLANK SCREEN AGAIN!!!!!!!!!!!!!!!!!!!!!
( mild lose of hair has started, mainly from me pulling it out, also appolgises for the mild langague, and any spelling errors ... eek)

4. Check step 2 again .... AGAIN.....

Ok lets save alot of read as you may have guessed it the file is missing again, i revarify like TEN TIMES, each one said the file is there, biut guess what ITS NOT!!!!!

However there is a CoherentUIGT_Native.dll just no CoherentUI_Native.dll
I have no idea if that means anything maybe someone can help ..... Please Help!!!!

Oh and i did manually check the file after it said the file had been reacquired and after it said all files validated ... but the file CoherentUI_Native.dll was never actually theredispite the varification said it was.

Also if it  help......

Windows 7 Ultimate
AMD FX - 6300 Six Core
8GB of RAM
AMD Radeon R7 200 Series - With 2GB Dedicated RAM
Running in 64 Bit

P.S i dont know how to attach files here, so if you want or need War for the Overworld Launcher Log or the output_log just let me know how I do that. Oh and i have no AV software installed other than Adblocker for firefox, as my gaming computer has nothing of worth on it.
Game Version:
Steam Public



We have found the issue in your case Peter. You need to install Windows 7 Service Pack 1. If you do so the game will launch correctly.

Please let us know if that works

I have the same issue.

Windows 8.1 pro

Output log is reporting problems with "CoherentUIGT_Native.dll". Library is not missing. Path:

'C:/Program Files (x86)/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/CoherentUIGT_Native.dll'

There were no probpems prior to latest patch.



The button to upload files is the rectangle with the pointing upwards at the top of the text editor. The default path for the log file is:

C:\Program Files (x86)\Steam\SteamApps\common\War For The Overworld\WFTOGame_Data\output_log.txt

As an aside, you'll have a much better chance of getting your report looked at if you strip all the creative writing from your post. Just think of the guy/gal on the other side having to parse the bits of (maybe, maybe not) relevant info from a piece of prose just to get an idea of what the problem even is so they can do their job.

Hi guys,

It looks like your PC isn't allowing the installation from Steam to work correctly:

DllNotFoundException: C:/Program Files (x86)/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/CoherentUIGT_Native.dll

Could you please confirm whether that file exists by browsing to that directory?

Hi Scott, Yes that file is there, its here,

C:/Program Files (x86)/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/CoherentUIGT_Native.dll

This is a jpeg of it the folder,

CoherentUIGT_Native.dll file.jpg

Yes, the file is in given directory. Maybe 32 vs 64 bit conflict? If the lib is 32bit it will not be loaded by 64bit application.

Sorry Jed i don't know, how can i find out?


when a dll file is present at the correct path, but still causes a DllNotFoundException, this usually means the library has a dependency which is not installed on the system.

For current patch we updated our UI middleware and this dll file is part of it.

It works as it is for the vast majority, but you must be missing a dependency which is usually installed on most systems.

Is everyone suffering this problem on Windows 7 or 8.1?

I analysed this dll with dependency walker and found the following dependencies:


Now the question is which one is missing on your system and which microsoft download you need to install to make it work?
If you can find this out, it will likely fix your problems.

Otherwise I have a few guesses:
First of all, please trigger a Windows Update which may install missing the missing dependency if you didn't update for a long time.

If it doesn't fix it, you may miss MSVCP140.DLL "Visual C++ Redistributable for Visual Studio 2015".
Please try if installing it from the Microsoft website fixes the problem:

Please let us know if it helped.

We may ask the provider of our UI middleware to either include all required dependencies into their software or at least to give us a list of these dependencies, so we can make sure they are installed correctly with the game in future.

Thanks for reporting this issue!

Kind regards,



I'm having the exact same issue, CoherentUIGT_Native.dll in place, and I use 64bit Windows 7 as well.

ps.: gonna do a mass windows update, see if that goes anywhere. Visual C++ Redistributable for Visual Studio 2015 is already installed, still black screen.

ps2.: update certainly didn't go anywhere, will try the DLLs next.

ps3.: Tried to:

a.) download the missing dll files, gotten their x64 variants and added it to system32 (I virtually have no experience with missing dll files, so correct me if i goofed up somewhere, for example getting x64 instead of x32). Only the ones starting with API were missing there. After reboot, the game still wont load.

War for the Overworld Launcher Log.txt


Also tried to manually register these dll files in command prompt, but this error message popped up every time:

b.) copied all the dependent dll files to the WTFO Plugins folder. Unsurprisingly that didn't work either. I can re-do this attempt, if logs are to be reproduced, although i'm pretty sure its gonna end up in the same dependency issue.

Also pretty sure its a fact at this point, but just to clarify, on [previousbuild], game works wonderfully.

War for the Overworld Launcher Log.txt


Pending Customer

Hey everyone,

Could you please uninstall all instances of "Microsoft Visual C++ 2015 Redistributable" in control panel.

Could you then all please try to navigate to the games install folder and then to "_CommonRedist/vcredist/2015" folder. Could you then please try to run both of the batch files in there 




After uninstall, then WTFO folder exe:

dd_vcredist_amd64_20180423142157 - error log.txt

dd_vcredist_x86_20180423142317 - error log.txt

edit1: running as admin worked.

edit2: Blackscreen still occurs.

War for the Overworld Launcher Log.txt

output_log.txt In case it's needed.

Can you please verify that you are on a 64 bit machine By going to system info. You can get there by right clicking "This PC" in file explorer and clicking "Properties"




Have you restarted your PC since installing the above packages?

Yes I did, and it still doesn't seem to launch properly.


We have found the issue in your case Peter. You need to install Windows 7 Service Pack 1. If you do so the game will launch correctly.

Please let us know if that works

That's extremely weird. I've just queued windows updates, including SP1, as we spoke, updated it successfully, and still didn't have any positive effect. This happened like 3 hrs ago. 

Tried it right now as well, still black screens.

edit1: Hold on. Now that I did the update, there's a Windows 7 compatibility mode available, unlike before. Most people had to enable that to kill blackscreens, I'll take a look at that.

edit2: alas, it didn't do the trick. Gotten excited too early it seems. :D


Windows update did the job for me. The game now works.

I've change windows update settings to update not only OS but other Microsoft products as well + optional updates.

I'm on windows 8.1. Not sure if it helps on windows 7.

Hey Peter,

Please dont use windows 7 compatibility mode.

Can you try and run every installer in the _CommonRedist folder, especially the DirectX installer

Hello, on it! Updating in a few minutes

So I Installed DX and CR for every release, gonna reset now. 

Okay, so the issue still persists. I'll log out of here for a while, Jed's advice may be of help but it'll take some time. I've been behind on windows updates like crazy, after I did all updates for SP1, now there are an additional 125 important ones popping up. I'll check what they do, and if all of them are finished, will retry launching the game. There are NET framework updates related, so it's probably the cause.

Not including optional updates... :D


Thanks a million for the help Cian and Jed, updates were the cause. Got everything installed, and the game runs perfectly. Sorry for the troubles. :)

Completed - Resolved

Glad to hear it Peter let us know if we have any more issues