0
Completed - Resolved

Critical Error during game start.

Voltoth 2 years ago updated by Cian Noonan (Graphics Plumber) 2 years ago 25

When attempting to load the game, I'm met with the following error:


Critical error during game start

"Sharing violation on path C:\Program Files (x86)\Steam\steamapps\common\War For The Overworld\WFTOGame_Data\GameData\Options.txt"

The game cannot start.


I have checked the file and cannot find any issues with the contents. In case I'm missing something though, it reads as follows;


FirstLaunchLanguageDetection=
Lang=0
HoGLaunched=True
DLC=HeartOfGold
Screen Width=1920
Screen Height=1080
Screen Refresh Rate=60
FullScreenMode=True
Gamma=20
V-Sync=True
Camera Zoom Max=30
Editor Camera Zoom Max=50
Needs Pixel Light Upgrade=False
Pixel Light Count=10


This is the same computer that I have used to play the game for many hours before with no issues. I'm at a loss of what could be the cause of this issue.

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Voltoth 2 years ago
Pending Customer

Hey Voltoth,


Can you please attempt to delete the file and try to open the game again?

That was the first thing I did, I have tried multiple times since then with no joy.

Could you please try the steps in our Startup Crashes guide

Tried every step and still have the same issue.

Have even tried uninstalling and reinstalling on a different drive. Same issue still persists.

Hello Voltoth,

could you trigger this problem again, quit the game and then save and upload your output_log file  in your reply before starting the game again

(Attach the file to your reply clicking the "File" button above the text area).

Here is described how to do that:

http://brightrockgames.userecho.com/forums/2-war-for-the-overworld-knowledge-base/topics/118-how-to-submit-a-bug-ticket/


A look into this file can help us to get a deeper insight where the problem occurs exactly and thus likely find out more about the cause.


Cheers!

output_log.txt


As requested, here is the output log file. I hope this helps, I miss playing this amazing game.

Under Review

Thanks a lot, we will take a look!

Hello Voltoth,


I am sorry for coming back to you late but I got delayed for personal reasons.

The log helped to find the code which is triggering the exception, but it looks correct and wouldn't fail under normal circumstances. 

(We got never any report of a similar issue before and it works fine for everyone I am aware about)

However it looks like the problem would be caused if any other program tries to read or write Options.txt while the game is trying to access this file as well.
The question is, why would another program do this?


Is there any chance you opened Options.txt in any viewer or any other program which locks the file entirely?

If you are aware about such program, please try to close / release this file before starting the game.


Another potential cause could be an anti virus software which has very agressive heuristic and finds the frequent writes the game does to the file suspicious and might thus lock the file away.

Please check if disabling your AV software does solve the problem and if so activate it again (anyway) and add an exception for WFTO.exe and WFTOGame.exe to avoid it doing so, or reduce the agressiveness of heuristic search.


I hope any of this helps!

Hi Stefan, it's quite alright, I know that life happens and of course, that must always come first.


I'm glad the issue has been identified however, I have tried with my local security programs turned off and disabled and I did not have the Options.txt open in any editor at the the time of launching the game. I have tried closing down everything but steam and the game but still encounter the same issue. I even went as far as to disable windows defender (Despite being nagged several times by the OS)


Nothing I have tried so far, has produced any different results.


Incase this helps, I have included my dxdiag log file for additional troubleshooting. Hopefully that would shed some light on the situation.

DxDiag.txt


We are really puzzled what could be causing this problem.
Fact is the Options.txt file is locked by someone when the game writes to it and more interesting it succeeds multiple times before the issue occurs.
Could you upload us another output_log, just to see if it always fails at the same write or if it varies?

Is there any possibility that two instances of the game would start simulataneously?

Since it works for other users, we highly suspect a local issue with your system, but it is hard to guess why this file could be locked by the OS when the game tries to write to it.

If you have any idea, try to find anything which could cause this and disable it.

I am sorry, that we do not have any better idea what the cause could be.
As said it is the first report of this kind of issue we ever encountered.

Options.txt


I'm really confused too. I have no idea at all what it could be. Even more confusing is that this problem is new. As I mentioned in my original post, the game ran fine for me before and I've only really updated my computer. No other services or programs have been added. I'm completely stumped but the Options.txt seems to be the same all the time. I just tried again to get a clean version while deleting the previous version as recommended before but still encounter the same issue. However, interestingly enough, the game did give me an achievement this time around. "New Year Goodness"


I have checked my task manager when launching and as the error occurred and noticed a spike in disk activity but only one instance of the game was running.

> Could you upload us another output_log, just to see if it always fails at the same write or if it varies?

Your system specs seem fine to run the game, so nothing that immediately points to any issue in your DxDiag.

As requested.output_log.txt


Looks identical to the previous one to me but maybe there are some subtle differences.

Yes it is exactly the same issue at the exact same place.

And the most mysterious thing is, that this is write access number 4 after 3 previously successful write accesses to the same file.

Like if something would only allow us to write the same file thrice in a sequence and then lock it away.
(This is why we suspected AV software but you already removed this potential cause)

When did the problem start to occur?
Did anything special happen in between it working and when it broke?
Did you change anything on your system in this time, or installed any new software?

Did it happen after a Patch of the game?

In case you didn't do it yet, can you verify your steam files, to make sure it is not Steam which is actually stuck updating the file during game start.
Here is how to do this: https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

I'm not sure exactly when the problem started as it has been quite some time since I actually played the game last, however, I noticed it when trying to start the game up last week. (The same date as this bug report)


Nothing special has happened to my system since the last time I played and now, aside from windows updates. The only software I have installed since is some other games already in my steam library. It was working fine with Heart of Gold, the last time I played it so I'm not sure what has changed since then and now.


I have attempted to verify all my files on steam and they all come back as fine. (According to that anyway)

Unfortunately we are running out of ideas what could potentially causing it.

A very technical note:

The only thing we found strange in code is that the writing stream was closed manually by code rather than wrapping it in a using-statement which calls Dispose, but both _should_ be sementically the same. (Only a programmer would understand this)
It might be that in Unitys Mono (C# runtime) version this is not the same, which would be against the C# standard but we are now fishing in the dark, this would be unlikely and why would it only impact just you?

However we changed it now to use the most standard way to make sure the file stream is correctly closed after each write and there is a tiny chance that this change has an impact on his problem.

We are releasing a new minor patch very soon (expect it some time next week).

I just hope this patch brings you back to play the game, but unfortunately it's not unlikely that nothing we changed has any impact on this particular issue.

However I would say give it a try and let us know if it works again, once this patch is out.


I am sorry that we are unable to help better in this case, but this seems to be a very rare system specific issue.

Thank you for trying so many things though.

I will give it a try and yeah, I didn't see any end of statement in the output_log either. While I'm not familiar with Unity coding, I do dabble with LUA and it seemed strange to me that the code was not purged before exiting.


As for why it flags as being closed manually, maybe because the error throws up a dialog box with only one option to exit the game? That would be my only guess as I haven't had to force close it at all.


Fingers crossed for the new patch being just the switch needed to turn the game back to a working state (for whatever reason). I will let you know either way though.


I'm sorry that we weren't able to figure it out but thanks for at least trying. Some things are just beyond our control with the interactions of various programs having unforeseen effects.

Just in case it was misleading, the game is closing correctly and the end of the log looks like a normal exit.

It is just the case that this exception occurs during loading which then causes the game to force quit with an error dialogue.

The problem I was mentioning is about closing file streams, because if I file stream to a file is not correctly closed before a new write attempt to the same file happens, then this error you encounter would occur.

But we double checked the the file streams are closed on our side correctly, but it might be an oddity of Unitys special custom version of the Mono runtime, which might break the standard here.

If this unlikely guess would be true, we could indeed have fixed it by using the standard way to close the file streams rather than calling "close()" manually even if both should do the exact same thing.

I not want to get even more technical but in with a small chance we did run into an odd Unity bug, which we might circumvent with the small change we did.

Fingers crossed, but the likelyhood for this is small and I just hope it helps to get you back to play.

Ah I see, my mistake then. I hope it works as the unexpected side effect you mentioned by fixing a Unity quirk. I really miss being able to play this game. The original dungeon keeper still has quite a pull on me, so much so that I'm actually starting to play it again however, something more ... recent is always nice. Especially the game you guys and gals masterfully crafted. It really gets it.


Also, Richard Ridings was so on point with the narration.

Thanks you for the kind words, we worked hard to make this game a reality.
But it's a shame to see someone who has all the required specs unable to play the game.

I hope we'll get this sorted soon but this issue looks extremely strange.

Just a really random update, after finishing up a windows update last night and seeing if I could play today, whatever issue I had seems to be completely gone. The game now runs buttery smooth and for no reason. It's very strange indeed.


I have included my log files to see if this could shed some light on the issue for other users but I have no idea. It doesn't make any sense to me but I'm not a programmer. Still, thanks for all of your efforts in trying to fix this. Hopefully the answers become clear from the logs.


output_log.txt

Options.txt


Just in case it's relevant, the Windows Update was (KB4051613)

Completed - Resolved

Thanks for keeping us updated.

I am very happy to see you back in the game!


This Windows update is for the Flash Player and the game does not use any Flash, so this _should_ be unrelated.

The issue you did run into seems to be very system sepcific and I doubt there are other users which run into this.

At least we got no related reports.


Even if you are programmer, you keep dealing with black boxes which allow no insight and only limitted control.

The Windows operating system is such a black box and we can not really know which screw got turned fixing this strange file stream sharing violation, but seems what ever locked Options.txt did finally stop doing so.
I highly supsect an internal Wwindows issue causing this problem.

I am just happy it stopped and I hope it will never come back so you can keep playing.

However let us know if you encounter any issues with the game in future.


I wish you fun playing!
Cheers