Completed - Resolved

Game crashes on Quit from main menu

kristian 6 years ago updated by Renok 5 years ago 24

Every time i exit the game through quit in the main menu the game crashes.

Windows 10 64 bit 

16 GB ram

AMD R9 280

Intel i5-4460

Both version 1.6.4 and 1.6.5

Game Version:
Steam Public
Pending Customer

Hello kristian,

to help on such issues we need a full report including your output_log and crash_log as described here:


Please upload these files using the "File" button on the top bar of the message editor.


Unfortunately this is a hard crash which does not leave a log in the steam folder.

There is a log in the event viewer though (although in danish)

Navn på program med fejl: WFTOGame.exe, version:, tidsstempel: 0x59947e0c
Navn på modul med fejl: ntdll.dll, version: 10.0.16299.15, tidsstempel: 0x493793ea
Undtagelseskode: 0xc0000005
Forskydning med fejl 0x000000000002669f
Proces-id 0x3278
Programmets starttidspunkt 0x01d350204eb1627d
Programsti: D:\SteamLibrary\steamapps\common\War For The Overworld\WFTOGame.exe
Modulsti: C:\WINDOWS\SYSTEM32\ntdll.dll
Rapport-id: d8a12bf2-c755-4f24-9df6-78bccbe097af
Fuldt navn på program med fejl: 
Relativt program-id for program med fejl: 

Unfortunately there is not much info available from that log. What does the crash look like?

It is a generic windows error, reply if you need translation

Can you check if this occurs on any other unity game that you own?

This list should help: https://en.wikipedia.org/wiki/List_of_Unity_games

I tried both Ori and the Blind Forest and Never Alone and none of those crashed on exit whereas WFTO does it every time.

Could you send us your output_log? It may contain some info. 

It's at:

C:\Program Files (x86)\Steam\SteamApps\common\War For The Overworld\WFTOGame_Data\output_log.txt

Cannot Replicate

Unfortunately the log doesn't point to the cause of the issue. All I can recommend is following our General Crash Troubleshooting guide.

Since i am a developer by trade, is there a way i can set up an environment to catch the error?

I managed to catch the exception in Visual Studio and here is the call stack at crash

It seems to be a problem with ATI drivers (i am using version 17.7.2, latest official driver from AMD):

I just updated AMD drivers to 17.11.1 (new latest official) and WFTO to 1.6.66, still the game crashes on exit.

The call stack is the same as above but now i also have the exception message:

Unhandled exception at 0x00007FFA59E287C0 (ntdll.dll) in WFTOGame.exe: 0xC0000005: Access violation reading location 0x0000000000000010. occurred

Pending Customer

Do you have any nvidea software on your machine? ntdll.dll looks to be a Nvidea process.

We will try to replicate on our AMD machine locally

Completed - Next Patch

My apologies I made an assumption based on an incorrect article. 

We are planning a patch in the next few days that will move us to the latest version of Unity that we can currently support due to aging middleware. 

5.4.5p5 -> 5.4.6f3

This may not seem like much but as the current version is a QA patch release instability like this is possible. If you could try to play the game later this week / early next week when that is live that would be much appreciated.

The reason I ask this is that Unity is a blackbox and errors that are this low level tend to be solely on them as on application quit all we are given is a single Application.Quit() call to close the program, Unity itself takes it from there.

Completed - Resolved

Please try now

The issue persists unfortunately.

Pending Third Party

Hey kristian,

I'm sorry to hear that it persists. Due to the fact that you're our only report of this issue there is not much we can do, especially as Unity is a black box so we have no control over anything this deep.

We will keep this ticket on record incase in crops up again but for now we will just have to accept that the game will crash due to some sort of system configuration 

I've got the same problem.

PC specs

Windows 10 Pro Edition 64-bit

CPU: AMD FX-8120 Eight-Core Processor 

GPU: AMD Radeon R9 270X Graphics card


Game is v1.6.66f6

As you can see my computer is powerful enough to run the game, however I keep getting program stopped working error when I quit from the main menu and sometimes when I even start the game.

I have the same problem: the game crashes on every exit.

PC specs:

Windows 10 Pro Edition 64-bit

CPU: i7 7700k

GPU: AMD Radeon RX 480 Graphics card (Radeon Software version: 18.3.4)


Game is v1.6.66f6

Log attached: output_log.txt

The problem has disappeared with patch 2.0

Indeed, the problem is solved with patch 2.0.

I am very happy!

Completed - Resolved

Cheers for the update. A significant amount of change has occurred with the 2.0 update.We will assume this fixed unless we get a new report