0
Not Fixable

Missing Menu Issue

bt132 2 years ago updated by Stefan Furcht (Programmer) 2 years ago 16

Greetings,


I have read the forums and have updated everything through the HP website, on the list, and am still having the issue of no menu on the main screen (will describe below). I will do my best to provide the info requested and describe my situation.


INFO:

System: Windows 7. I am including screen caps of the specs for this unit.




DESCRIPTION:

When loading the game, it takes quite some time for anything to happen other than a black screen. At some point the pointer changes to a hand and I find myself next to the dungeon heart. Clicking on anything either does nothing or transports me to another room where I can do nothing to get out of the room... clicking does not work on anything in the room, computer keys do not trigger anything, there is nothing to click on, etc.


I have read through the online forums and followed the instructions in the list provided on this topic. One thing I am not able to do, it to open the AMD program and choose the power option as listed. There is nothing I can chose from like this.



This is what my AMD screen looks like



Please let me know if there is anything further I can provide to help figure out how to fix the issue.


Other info: Purchased the game through GOG. I have the patch as well. I tried running it with the patch 1st, and then uninstalled everything and then tried it without the patch and same issue so I suspect it may have nothing to do with the patch and is solely a graphics issue.


Best Wishes,

BT132

Game Version:
GOG DRM-Free
Platform:
Windows
Pending Customer

Hi BT


Bear with me here, because i'm trying to remember from my own AMD control panel (on my old laptop) but if I remember right, one of the buttons (gaming I think) takes you to a screen that lists all of the games installed on the system (that AMD can tweak settings for anyway) and that's where you can set which graphics card is used, etc.


Can you give that a try and see if you can find it?


I'd also suggest trying Solution #2 from that article (as that usually has a better chance of fixing the issue than Solution 1)


Let me know how you get on, hopefully it'll solve it, but if not we'll try and assist further.

Greetings,


I was able to add the game but when I access it, I get the following screen and have no idea where to go from there.




I am guessing somewhere within these settings lies the answer but not sure.





Hey bt132,


PLease try to go to Radeon Settings > Preferences > Additional Settings > CCC Slim > Power > Switchable Graphics Application Settings. From this menu you can manually add applications to High Performance mode so they will use the Radeon GPU.

Greetings,


I got into the preferences tab, but when I click the Additional Settings tabs I get the following message:




Not sure what this means... If the Catalyst Control Center is running, why would it say it cannot be started?




I honestly have no idea what the issue is there, personally I use Nvidia hardware. 


Can you try to change your laptop power setting to "High Performance"

I have tried everything and no luck. Will wait and see if anything surfaces in next few days. Thank you for your help.

If thats the case you should try and reinstall AMD Radeon settings

Hello bt132,


make sure that you tried all solutions provided in this knowledge base article:

http://brightrockgames.userecho.com/topics/1096-missing-invisible-or-laggy-ui/


Does none of them fix your problem?

It seems like either your Catalyst Control Center is not installed correctly or your notebook vendor (HP) disallowed certain advanced settings for your CPU.

In this case HP should provide an alternative way to configure switchable graphics, so that the game runs on your dedicated GPU.

It would be good to know which dedicated GPU do you have next to your onboard Intel HD graphics chip?
The above system screenshot doesn't mention it at all.


Cheers

Greetings,


So far none of the options work in my case. I am guessing it may have something to do with the Catalyst Control Center but not sure how to uninstall it, and if I were to uninstall it, would it affect the computer in a negative way..? As to the GPU next to onboard Intel HD graphics chip, where would I go to to see it or find it? I can definitely include a screen shot if I knew where to look.

Reinstalling should be safe, once you have you can use the software to check the model of your AMD GPU

Hi BT, if you're struggling to find out your second graphics card you could run DxDiag.exe which tells you (and also generates an log you can save too)


To run a DxDiag report follow the steps below:

  1. If you are running Windows 7 or higher, go to your TaskBar.
  2. Click on, "Start Button".
  3. Click on, "Run".
  4. In the pop-up window enter DxDiag and hit ok.
  5. The DirectX Diagnostic Tool pop-up window should appear.
  6. Click on, "Save all information".
  7. "Save As" window should be present.
  8. Click on, "Save" (The file should be saved to your desktop as DxDiag.txt)
  9. Exit the DirectX Diagnostic Tool.


Hope that helps.


(@Cian, don't worry i'm butting out again)

Thank you for the info. I ran the program and it created a txt file log that is very long. Is it listed here by any chance?



Hello bt132,

this log just shows your onboard Intel HD Graphics which wouldn't be supported by the game.

Do you even have a dedicated ATI Graphics card and if so which model?

Greetings,


I do have the following:



Other than that, I don't think anything is on the system. Please let me know what you think.
Not Fixable

Oh I see,

the Radeon HD 7500M/7600M series has an average G3D Mark score of 550:

https://www.videocardbenchmark.net/gpu.php?gpu=Radeon+HD+7600G

The minimum requirements to play War for the Overworld require a GPU which scores at least 1500 at G3D Mark

http://brightrockgames.userecho.com/forums/2-war-for-the-overworld-knowledge-base/topics/1099-system-requirements/


Unfortunately your GPU is too weak and not supported, but you _may_ be able to get it to work with lowest graphics settings and your AMD Card would still run the game better than you onboard Intel HD Graphics.

But the treiber software seems to be not correctly installed, if you can not assign the game to run on your dedicated Radeon 7500M.


Did you already try to reinstall your graphics driver?

The issue is that the early notebook with switchable graphics are a mess and every vender did brew it's own solution.

You can try to replace their stuff with official AMD drivers:

http://support.amd.com/en-us/download/desktop/legacy?product=legacy3&os=Windows%207%20-%2064

(Select full reinstall or uninstall old drivers to make sure it updates)

Otherwie you are stuck with HP Support for your device, this seems like a good thread to look at for reinstalling your switchable graphics drivers:

https://h30434.www3.hp.com/t5/Notebook-Video-Display-and-Touch/Switchable-Graphics-AMD-Radeon-HD-7670-Problem-in-Hp/td-p/3357047


Only if you can get your switchable graphics to work, so you can assign the game to your dedicated Radeon Card there is a chance that the menu will actually show up.

But as said it is not sure because even your dedicated GPU is below the minimum requirements.


I am sorry for inconvenience and hope any of this helps!


Cheers

Thank you for all your help. Would NEVER have figured that out probably within the next 100 years or so without help. Will try and see what happens!