Completed - Resolved

When I try to load a level, the loading bar stops moving and it never finishes.

Greg D. 5 years ago updated by anonymous 5 years ago 28

The game doesn't crash or freeze, and the game is capable of loading the title screen and cutscenes. When I try to start a level (main campaign, My Pet Dungeon, or Heart of Gold) the loading bar goes up to about 80% and then stops moving. The game doesn't crash or freeze.

Game Version:
Steam Public



Please also try to install all of the VisualC++ versions from the _CommonRedist/vcredist folder 

Whoops, accidentally repeated myself. Also, I have uninstalled and reinstalled the game multiple times. It does not help.

Pending Customer

Hey DivaythFyr,

Sorry to hear you cannot play the game, could you please send me your output log and system specs so I can look into this further for you?

Windows 10 

AMD A10-7800 Radeon R7, 12 compute cores 4C +8G 3.50 GHz


64 bit

I have no idea how to do that. All I know was that before the recent update update, I was fully capable of playing the game (though it was a bit laggy sometimes).

Is this the information you need?:

Windows 10 

AMD A10-7800 Radeon R7, 12 compute cores 4C +8G 3.50 GHz


64 bit

For a little more information on the bug, the loading bar goes up to about 90%, then jumps back a bit and stays there while the ambient noise of the level can be heard.

Hi Greg,

Sorry for the delay in response over the weekend, we'd really love to help you get to the bottom of this issue. You can find information on locating your output log in this article: How to: Submit a Bug Ticket

Also can you confirm that you've tried the steps provided in these articles:

General Crash Troubleshooting

Startup Crashes

Hope we can get you in the game soon,


I have tried the steps provided in those articles, and nothing changed. I also found the  output log, but am unsure how to post it here. I tried to use the "file" button at the top of the comment box, but am unsure if it did not work or if it is just very bad at showing that I uploaded a file. If it did work, I just uploaded several copies of the same file.

I don't think it worked. I'm going to try again

Very strange indeed, when you click file once you've selected the file in question it should simply add a link to your post to that file. As such: output_log.txt

I have no idea why it isn't working. I click on file, I select the output log, s blue bar appears at the top of the screen, and nothing happens. Clicking on the file button again just brings up the prompt to choose a file again. I'm either missing something obvious, or it just isn't working. 

I'm going to try uploading it from a different computer.

Bizarre indeed, if you continue to have difficulties you might find it easier to upload it to a cloud storage platforms such as GDrive or Dropbox and linking it to us. 

I'm not using Dropbox because that costs money, so how would I link something from Google Drive to you? (Also, I apologize for the inconvenience.)

Oh, I actually found out how to make a shareable link from Drive.


Nope. Uploading from another computer (or browser) still doesn't work.

Hey Greg,

Sorry for the slow response, I've been on holiday. Can you please verify that you have the GalaxyCSharpGlue.dll at this directory: 

C:/Program Files (x86)/Steam/steamapps/common/War For The Overworld/WFTOGame_Data/Plugins/GalaxyCSharpGlue.dll

If not, grab the file here and place it at that directory: GalaxyCSharpGlue.dll

I do indeed have that file.

I had this problem, and I was able to solve it by installing the Microsoft Visual C++ 2013 redistributable.

How did you do that?

first go to add/remove programs and, if you already have it installed, uninstall it. Then download new versions here:


I assume you'll want both the x64 and x86 version if you have a 64 bit system.

That did not help. Thanks for the advice though.

Please double check that you have C++ 2010,2012,2013,2015. If you do not then you can delete and reinstall the game, when the game has been reinstalled Steam will start to install the packages. Let that fully complete and then you should be able to play.

I already have all of those.

odd, I didn't have 2013, and reinstalling the game did not install it for me.


Please also try to install all of the VisualC++ versions from the _CommonRedist/vcredist folder 

Completed - Resolved

We just made a change on our backend, please try again and you should get them all.