Completed - Resolved

interface problems / UI Freeze

iainconway 6 years ago updated by anonymous 5 years ago 35 1 duplicate

hi just brought the game, and when i play through the campaign about half way through the mission the interface disappears. its still there cos if i click in the right place the option to cast a spell, build a room etc still works, but it looks like its just the rooms tab. so i basically have to guess the right place to click which is more or less impossible . also if i press escape i cant see the the main menu.

so i tried this fix https://brightrockgames.userecho.com/topics/1096-missing-invisible-or-laggy-ui/. but now i dont even get a menu when i start the game, but the dude says "welcome etc" and the background is there just no menu.

i run on laptop

win 10 64 bit

intel core i5 6300hq @2.3ghz

12gb ram

hope u can help cheers

Game Version:
Steam Public
Duplicates 1

any reply to this cos im gonna ask for a refund soon

Pending Customer

Hi Iain, the majority of the dev team are currently away for the christmas holidays (i'm a volunteer member of the QA team, not one of the core dev team) which is why this has taken so long to get a reply (sorry about that)

Looking at your system specs (which seem more than good enough to run the game as far as I can see) my first guess would be that you are suffering from one of the issues which are usually fixed using the knowledge base article you've already tried.

But since none of those solutions have worked we'll need an output log to take a look at. This article should help you locate and upload your output log then we should be in a better position to help you.

Thanks (and sorry again it took so long to recieve a reply)


This is a very unusual issue I've never seen one that matches the behaviour you described and we'd love to help as Nutter quite rightly said an Output log from a session where this occured would be very helpful. Generally I'm expecting this to be a CoherentUI issue though which we might have to escalate to them.

Just to check how much time is left on your refund for steam? We may have to careful not to overrun the two hour timer.

The majority of the team is back from leave tomorrow so I'm sure we'll be able to investigate this further. In the meantime please do attach an output log from a session where this occured!

Also a screenshot of the issue(s) would be fantastic. Particularly the in-game one where the UI has disappeared or frozen.

hi thx for reply, weirdly and embarrassmently i just fired up the game to take the screenshot and it seems to work perfectly now, i tried it not five hours ago and had all the problems i was talking about and since then i have not changed anything yet the game works now... i dont know why. sorry about that

No problem, if the issue re-occurs then please grab an output log and upload it in this ticket. In the mean time i'll leave this one as Accepted as I know we have other members of the community with similar issues. Thanks

Hi Kaos, thanks for this. I located this on our general helpdesk so I'm going to move it to the forum and merge it with the current lead ticket. Thanks a bunch. If possible can you please also include your System Specs. Thanks!

Please let me know if anything changes.


UI Freezing

Steven Lloyd 2 hours ago • updated by Lee "Noontide" Moon (Community & QA Manager) 1 minute ago • 1

As requested on Steam discussion:

Kaos 21 hours ago
I am getting the same UI problem. I have completed a game with the UI frozen, all buttons are functional but you cannot see what your clicking on. mouse popups still work but not anything that changes the Ui screen. It is still in place when on the campaign map. Next mission caused same problem.


Just started out playing again. Tried the Heart of Gold and Crucible. Not sure what it is but I adjusted the cam quite often in Rotation and angle of view. A few minutes after playing the game the interface was stuck and not responsive anymore. But the game seems to be still functional when i try to hit the right place but is not updatet graphical. Pressing ESC gave me no menu but the game was paused.

Specify your platform

  • OS Windows 10
  • 64bit
    • 8 gb DDR3 Ram
    • AMD 965 BE
    • Radeon HD 7800, 2 gb DDR5

Hello to everyone affected by this problem,
the issue seems to be related to an issue with our UI middleware (CoherentUI) which runs into an error.
However this seems to only happen on certain systems and might be related to the GPU and/or its drivers.

This is the full error:

  • [Coherent Browser] (Warning) PID: 524 | 2520 11:02:51.778612 [524:2520:ERROR:(0)] GLES2DecoderImpl: Context lost during MakeCurrent.
  • [Coherent Browser] (Warning) PID: 524 | 2520 11:02:51.778612 [524:2520:ERROR:(0)] Exiting GPU process because some drivers cannot reset a D3D device in the Chrome GPU process sandbox.
  • [Coherent Browser] (Warning) PID: 524 | 2520 11:02:52.488703 [524:2520:ERROR:(0)] [.Compositor-085E0100]GL ERROR :GL_INVALID_OPERATION : glConsumeTextureCHROMIUM: invalid mailbox name
  • [Coherent Browser] (Warning) PID: 524 | 2520 11:02:52.516706 [524:2520:ERROR:(0)] [.Compositor-085E0100]RENDER WARNING: texture bound to texture unit 0 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering or is not 'texture complete'
  • ...
  • [Coherent Browser] (Warning) PID: 524 | 2520 11:02:52.566712 [524:2520:ERROR:(0)] Too many GL errors, not reporting any more for this context. use --disable-gl-error-limit to see all errors

We did contact Coherent Labs to take a look into this issue.

As always with third party issues: this could take a bit.

We are sorry for inconvenience and thank you for your patience in advance.

We are hoping to get this sorted out soon for you.

Thanks for that update from yesterday. Works fine now.

Completed - Next Patch
Completed - Resolved

Was this ever solved? I am having the same problem :( A couple of minutes in the UI will freeze up. How long it lasts varies, but eventually it happens; no matter if it is campaign, pet dungeon or crucible. Haven't tried others as the problem prevents me from finishing whatever I start.
Can see that I have couple of dump files in the ...CoherentUI_Host\windows folder, but the are not clear text so can't see what they say.

Hey Svend, 

Have you tried following our Missing, Invisible or Laggy UI knowledge Base article? 

Follow those steps and report back. 

I am on a laptop with onboard intel card, so case 1 doesn't really apply. Step 2 sorta works. Even though I'm on a win10 version  with DirectX12, the -force-d3d12option  only results in black screen.

-force-d3d11 didn't seem to do anything

-force-d3d9 is the one sorta workoing. The UI will freeze up every now and again, but after a few seconds it works again.As long as you are just messing about and getting stuff ready it works fine. But it is annoying when you are in a fight, and you can't get to the right spell

Pending Customer

Can you post your system specs Svend?

Turns out my laptop did indeed have an nvidia card installed. I never would have thought that a laptop would have dual graphic cards installed. There is no Nvidia software installed, and every time I go to settings it just shows the Intel card.

But since you asked for the specs I figured I might as well give them as detailed as possible, and when checking under devices a nvidia Quadro K620 card showed up. And after updating the driver for it, the game has run as well as can be expected on a laptop :)

Completed - Resolved

Wow that's unexpected, I'm glad to hear that you've got everything running well. 

It's quite common to have 2 GPU's a low power and high power one, this is to help the battery life when you're not doing high power tasks like gaming ;)

I'm also getting the same thing after returning to the game.  I came back to finally start playing through the extra content added since the original campaign, but am having this issue happen to me, frequently.

Full desktop system, 1080 Ti, most recent drivers. dxdiag: https://pastebin.com/8itxuBjb

The UI just breaks and ceases to update anymore.

Whatever this Coherent UI thing is, it's just awful.  I've seen a few other games using it and all it seems to do is suck up an inordinate amount of system resources (ram hog, sometimes hogs CPU too).  And now it's causing this issue in this game.

What happened?

I'd rather not switch the game to rendering in a worse mode (dx9) when it worked just fine previously, though I'll test it.

Edit: Switching to DX9 made the UI update a lot more slowly.. and didn't fix the issue either.

Edit2: Well, workaround discovered.  Since hotkeys still work, I can quicksave the game while it's messed up, then reload it and continue playing since that seems to fix the UI.  Not great, but at least I don't have to lose my progress and restart the game every time.

..and now I can't edit my post anymore?  I was in the middle of editing it too.

I wanted to add: 

Edit3: Okay, the workaround doesn't work all the time.. just had it re-load the level without any loading screen, so I saw some weird stuff and the UI stayed broken.  *sigh*

Pending Customer

Hey Ace,

We are aware of this issue affecting a number of our users. If you followed the Missing, Invisible or Laggy UI guide in full then there's not much we can do right now. We are currently upgrading the UI to CoherentGT which is much more stable and should resolve this for you. This will be avalible soon via the Public Test Builds.

In the meantime if you could link me an output log from a session where you experienced this issue that would be great. The location of the file is explained in our How to: Submit a Bug Ticket guide.

Thanks for taking the time to report this issue, I hope we can straighten this out for you ASAP

I thought I did, but the fact that the ability to edit our posts is disabled after a period of time resulted in me forgetting I updated it.


The issue is happening a bit too frequently to play with the workaround (huge annoyance), so I'll be waiting for that test build before I try the game again.

It looks like the log has been cut off before the end, can you upload the full file here so I can see the end?

That was the end afaik; I had to alt+f4 because there was no other way to exit the game.  My recent log is way shorter than that (2,000 lines vs 12,000).

I'll have to wait until I can play around with the 1.6.2 build, then if I experience the issue again I'll attach the log file here (didn't even know I could).


Hey Ace, 

Have you had any luck with 1.6.2?

Completed - Resolved

Hey Ace,

Due to a lack of response we are going to close the ticket as we cannot follow this further. If you post back here we can reopen the ticket.


Sorry for the delayed response, but I hadn't played the game all this time.

Finally got back around to it, and it looks like the issue was resolved with the 1.6.2 patch (or later).  Played for a good 6 hours and it never happened.

Still got some performance degradation/hitching issues (especially with revealing more and more of the dungeon, like with the prophecy spell), but that's for another thread.

Still reproducible:

  • Windows
  • 10 Professional
  • 64 bit
    • 8 Gb
    • Intel Core i7-6500U
    • nVidia GeForce 940M
  • v1.6.3 (Steam version, installed yesterday)
  • main Campaign level 2, in a total of 5/5 attempts.
  • 3 output logs, numbered as following:
    • 0 - out of the box
    • 1 - after following "Missing, Invisible or Lagging UI" case 1
    • 2 - after following "Missing, Invisible or Lagging UI" case 2 and reducing graphic options to minimum
    • Each game has been cancelled via Alt+F4 as soon as the bug was noticed.
    • Each game there was UI - only UI - lag visible as much as 1 minute before the bug occured.
    • The game itself runs smoothly and even somewhat too fast (judging by animation speed).
    • Save files were not generated. Each game was started from the Campaign menu.
    • the logs on DropBox

For reference: My machine is an unmodified Asus X555U laptop.

Interestingly, I was unable to reproduce this effect in Campaign level 1.

... Also reproducible in My Pet Dungeon level 1. Seems to consistently happen soon after the 10 minute mark.

... Sadly reloading a save game seems to postpone the occurence of the bug. It might be possible to restart the game every ten minutes to stave it of indefinitely - of course, this does not allow to actually enjoy playing it.

Pending Customer

Hey Zsar,

Unfortunately the logs dont seem to be shining too much light on the cause of the issue, could I get the debug.log from GameInstallPath\War For The Overworld\WFTOGame_Data\CoherentUI_Host\windows that may be more useful

I figured as much. Will try to produce a matching triple of both logs and a save file on thursday.

For now, on my current attempt I have noticed that the issue seems to be linked to screen resolution.

I played the previous games on:

  • fullscreen 1920x1080
  • fullscreen 1920x1080
  • fullscreen 1920x1080
  • windowed 1600x900

The first three games exhibited the bug earlier than the fourth one, but at that time I had put that down to random chance.

Today I played My Pet Dungeon level 1 on

  • fullscreen 1280x720

and was unable to reproduce the bug within the ~two hours it took me to beat the level.

Completed - Resolved

Hey Zsar,

I hate to be the bearer of bad news but I've just had a closer look at your GPU and it looks like it falls far below minimum spec. As you can see here https://www.videocardbenchmark.net/gpu.php?gpu=GeForce+940M&id=3155 your GPU scores on average 953points on the PassMark benchmark. 

Unfortunately War For the Overworld requires a minimum score of 1500 on the PassMark benchmark to run the game, as stated in our System Requirements. There's nothing we can really do to fix it other than recommending that you attempt to run in the absolute lowest video settings. I hope that you can find some way to enjoy the game, or an alternative machine to play on.

It's likely that the game scene gets a bit intense and needs more processing power, which it steals from the UI layer. This'll cause the UI to crash causing the issue you're seeing. If you play on a lower resolution it will prevent this from happening.