Menu - Stuck on Beast den

  • Views 10,255
  • updated
  • Completed - Resolved

This may be linked to my previous ticket, I am not sure:

Operating System

Windows 7 Ultimate 64-bit SP1
Intel Core i7 4800MQ @ 2.70GHz 64 °C
Haswell 22nm Technology
32.0GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)
Alienware 041W46 (U3E1)
Generic PnP Monitor (1920x1080@60Hz)
Intel (Dell)
3071MB NVIDIA GeForce GTX 770M (Dell) 49 °C
ForceWare version: 372.70
SLI Disabled
698GB WDC WD7500BPKX- SCSI Disk Device (RAID)
Optical Drives
Realtek High Definition Audio

Shortly after leaving a skirmish game I had set up, the menu was stuck on the beast den screen. I have attached a video of this below. Effectively, I cannot access crucible/skirmish mode, and the campaign mode is also bugged.

2016-12-18 18-09-47.mp4


I think this may be caused by leaving a skirmish game shortly after creating it. I shall see if I can find some replication steps.

Shortly after writing this ticket, I opened the game up again (it was still running). This time, the screen was largely black:

2016-12-18 18-21-59.mp4

In case anything changed, I have attached the new log:


Game Version:
Steam Public

How would you rate the customer service you received?

Satisfaction mark by Webbernever1 7 years ago

Add a comment about quality of support you received (optional):

Stefan Furcht
  • Accepted
Stefan Furcht

Something extremely weird must have happened with the networking components of the game.
I have never seen such errors. It looks like all units lost their network view ID.
I can only assume this is a seldom issue of our networking framework called uLink.

How often did you encounter this issue so far?
I hope only once.


This is the only time this particular error has occurred. However, I have seen, perhaps, related errors twice before:

In this ticket, the dungeon core menu stopped spinning and the campaign mode acted the same way as it did this time:

In this ticket, the menu jammed when the host left mid-conversation:

In both instances, the menus and the interface seemed to be jammed.

I do not know if either are related. I have tried to reproduce the error but have not succeeded. Effectively, what I did last time was just play one skirmish game, start another one but leave before it started up, and it got stuck. If it helps, I was trying to play on the same map as last time.

Stefan Furcht

We are using an outdated Networking framework for multiplayer and it would be quite a big afford to integrate to a different one.
It works good most of the time but seems like when you play multiple hours of multiplayer sometimes the uLink framework bugs out.
When the game is restarted from time to time that should not happen.
I know that is not ideal and I hope we get in future time to switch to a new solution.


Well, the bug in this ticket occurred following a single-player game rather than multiplayer. Admittedly, when I tend to encounter multiplayer bugs, such as the desync bug, it occurs after playing two games in a row (my games tend to end before the half an hour mark). Similarly, I had played the skirmish game in this ticket for less than an hour.


Hey webbernever1,

How frequently does this occur? Has it happened since the last patch?


Hello. I am afraid that I have had computer troubles for the past few weeks, so I have not really been able to play or test to see whether it has been patched.

It happened only the one time, so I am afraid that I do not know what effect, if any, the latest patch has had on the bug. I tried to reproduce it shortly after it occurred by entering/exiting a skirmish game repeatedly, but without success.

I shall see over the coming week if it occurs again, though I may not have much time to test it too often.

Personally, though, I see no reason why it should relate exclusively to the skirmish mode/beast den screen. I think that whatever caused it must have been menu-based.

  • Cannot Replicate

Ok please do!

Yeah I do agree that it will be related to the menu rather than just the skirmish mode.

However I am going to mark this as cannot reproduce, if you do work out how to trigger it then post here again and we'll reopen the ticket.


Sure, will do. Would you rather me post only if I find replication steps, or post if I encounter it again?


If you encounter it again please do post, as if it's a common occurrence then I can do some further investigation.

However it's unlikely that I will reopen the ticket unless we have something more concreate.