Not Fixable

Freeze on final level when entering the forge

Shaolin Funk 6 years ago updated by anonymous 5 years ago 26

As in title. I had no problems raiding the area to the west with the matriarchs (crypt? necropolis?) but when I head east to take out the forge, the game locks up as soon as my army attempts to enter. It doesn't even get as far as breaking the doors down; as soon as they start bashing it immediately freezes and doesn't recover. Output log attached.


Game Version:
Steam Public
Satisfaction mark by Shaolin Funk 5 years ago

Also my system info is as follows:

OS: Windows 10 x64


CPU: Intel Core i7 6700-k

GPU: Geforce GTX 970 x2 (SLI)

WFTO build: 1.5.0f10

Pending Customer

Hello Shaolin,
I can not find any obvious harmful errors in the log you uploaded.
However we had reports about crashes from people using SLI or Crossfire solutions.
The game is not fully compatible with either yet and can crash for some people.
I would suggest trying to run the game on one card exclusively or temporary disable SLI while playing.

Let us know if this resloves the crash.


Thanks for getting back to me so quickly.

I tried forcing it to single GPU rendering in NVIDIA Control Panel, but the outcome was the same - it still froze at the same point. However with a bit of experimenting I did find a way around the problem - by setting the rally point outside the doors instead of inside. There was a bit of slowdown, however after breaking the doors I was then able to get inside and set about breaking all the AI's stuff. My army is quite large as I have been converting all the incoming waves so I have well over 100 creatures at this point. I suspect it might be an issue with pathfinding so many entities at once. As I said it didn't happen when I went into the crypt area, however I have taken on a few more recruits since then so perhaps I've gone over a critical number. I can't think of any other explanation.

Hrm there is not articifal limitation to pathfinding.
All you'd get is more lag when you have more units.
So it's still a bit of a strange issue for us.

I tried to replicate it by sending the same army into the main fort in the center by clicking behind the door and it didn't freeze, so I agree with you, it doesn't seem to be that. As you say, very strange.

I'd like to attach save files so you could try it yourself, but after I managed to get past that section I got overexcited and stupidly overwrote the save. Maybe tomorrow I'll try playing the level again from the start and see if I can replicate the bug.

Pending Customer

Let us know how it goes :)

Well I replayed the level and wasn't able to reproduce the bug. My army is much smaller this time as I decided to only convert the level 10 enemies and use the rest for spirits to level up my own creatures (love that mechanic btw!) and later as vampire food.

Hrm I would really like to know what went wrong but it's hard if we do not know how to trigger the issue.
I will let this report open for a while, please add further information when you get something like this again.
If not we may Decline the report after some time tagged as "Can not reproduce".

OK I tried again and was able to reproduce it! And this time I've kept the save file so you can try it too. It seems to be related to having a large army and - strangely - destroying the bombards outside the entrance.

Steps to reproduce:

  1. Move the rally point to take out the 6 bombards - mining the sand opposite them makes this easier.
  2. Move the rally point behind the gates as shown in the screenshot.
  3. As soon as your units start bashing the gates, the game freezes.

If you skip step 1 and rush straight in, there's no problem. It only triggers if you kill the cannons first. That seems really strange and I suspect it's a red herring - probably it's because doing this causes your units to bunch up so that when you attack the gates so they all hit at once. Without knowing how your code is structured, my best guess is that a large number of creatures attacking a gate at the same time causes some kind of race condition or deadlock. It's possible that this only occurs with portcullises as I wasn't able to trigger this bug with either the wooden doors in the east or the wide metal doors in the center, however it's more likely that in both of those cases the attackers just weren't bunched up enough.

Actually forget the previous paragraph - while I was reading back what I wrote I had an idea to do an experiment, so I tried having my Archon take out the bombards while the rest of my army waited at the rally point, then had them rush in. The bug triggered even though they weren't bunched up, so it does look like it has a problem with the missing bombards. The last few lines of the output log seem to support that. I then tried a different experiment - I had only my beasts attack, taking out the bombards and then breaking down the gate and entering the forge. It was fine up to that point. Then I had the rest of my army run in and it froze. So it has nothing to do with attacking the gates, it happens when a large number of units try to enter the area after the bombards have been destroyed.

It's really weird that two seemingly unrelated conditions are required to trigger the bug. If it were one or the other I could guess at the cause, but for it to only happen when the bombards are destroyed and a large army enters the area - I have no idea. Good luck with this one.


13 equilibrium_20161218214029

13 equilibrium_20161218214029.meta

We will take a deeper look tomorrow.
Thanks for the saves, logs and detailed description how to reproduce.
This can make finding the root cause way easier for us.


I tried the same but couldn't trigger a freeze this way. I got a slight hick up on cancelling the rally flag though.

But it could well be that the pure amount of minions and the attempt to reach the bombards surrounded with lava (which is not walkable by majority of your minions) caused a path finding spike and a short freeze.
I think this is one for the list of general optimizations we need to look at.
But since we are trying to get the current release free of any major issues I push this ticket back to the next performance optimization pass (before Patch 1.6).

I actually didn't notice any performance drop when trying to path to the bombards (beyond the general low framerate from having so many units on screen anyway), it was only when entering the enemy's area that it froze.

It's a shame you weren't able to replicate it. That suggests it only occurs on certain system configurations - those are the worst bugs to track down!

Yea it's a pity. I have one guess.
We have the game running here on SSD, maybe it's loading any asset which is too big.
How fast is your HDD?

Interesting idea. I'm not sure how to check how fast my HDD is, but obviously it will be a lot slower than an SSD. Tomorrow I'll try moving the game over to my SSD and see if anything changes.

Ok that wasn't it, I tried running it from my SSD and the behaviour was exactly the same. I think I'll leave it on my SSD though, the faster loading times are nice!

I realised what you meant in your earlier post about pathfinding over lava. When I tried setting a rally on the bombards there was a brief slowdown followed by most of my army turning around and going home, which was quite amusing. The way I've been doing it is to set the rally on the closest accessible tile to each bombard, causing the units to gather next to the lava and the ranged units would then attack automatically. Maybe this is why it didn't replicate for you, if most of your units had wandered off due to not being able to pathfind? Try using either a beast rally or a titan rally to take out the bombards before selling a main rally inside the base, see if it triggers then.

Holy... now I tried it with minions going on the nearest point to lava to take out bombards using Archon directly on it and once done I rallied into the forge and as early they attacked the door I got exactly this weird freeze.
I have absolutely no clue what this is.
Normally it would cause a stack overflow if something is calling itself recursively.
So there must be an endless loop somewhere and I do not know where to start hunting it.
I realized that it always happens when Archon and other minions attack the two portcullis doors together, but only if the Archon attacked something else before and then he spawns a large army and it freezes.
So I suspect one of Archons raise abilities to trigger the issue.

It's rather hard to isolate this. It seems to be an issue which requires multiple conditions to be satisfied at once.
We would like to get an hotfix out and thus I need to put this one back for now to have a look at some urgent issues.
Since this one is not easy to reproduce I suspect the amount of people encountering this to be low.
But we will have to take a look into this one at a later point.

Yay! I'm glad you were able to reproduce it.

Cian Noonan Please find a smaller isolated reproduction case and assign it back to me.

So we have looked into this and determined that the cause is likely due to performance issues caused by the path finding system.

We will be looking to fix this in a future patch

Not Fixable

Hey Shaolin Funk,

Unfortunately we will not be able to fix this bug. We are both unable to track down the root cause and must dedicate our increasingly limited resources on the development of the upcoming 2.0 patch. We all want to apologise for not being able to correct this, you have definitely found a gem here, but as well known as your ticket is around the office we want to improve the general experience of WFTO with new animations, art, aspects, gamemodes, campaigns and QOL improvements. In order to do this we have to abandon the harder to replicate bugs such as this, hopefully the content that we have prioritised will make up for this.

Again we are sorry to disappoint with this issue.

Cheers on behalf of the Brightrock Team


I don't blame you for not wanting to spend any more time on such an obscure bug! I'm not disappointed at all. Looking forward to 2.0, sounds like it's going to be a lot of fun.