0
Not a Bug

Mouse and UI lag

Raúl Sin Más 3 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 3 years ago 11

Hello


- Windows 10 Home edition. 64bit.

- Intel Core i7-3770 CPU @ 3,40GHz

- Nvidia GeForce GT 620

- 8GB Ram

Options.txt

output_log.txt


The game runs fine, but interacting with the main menu is very laggy, and interacting with the UI in game. It'll hang for a bit when I mouse over, and a second later the click will register.

I've been experiencing this bug for months. I've seen other people complain about the bug, and solutions get given that don't seem to work.


I have tried the suggestions in this Knowledgebase article Missing, Invisible or Laggy UI, but nothing works.


Can you help me?


Thanks.

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Raúl Sin Más 3 years ago
Under Review

Hello Raul,
normally everyone finds a working solution in the Knowledgebase article and if you tried them without success it is rather unusual.
However your GPU seems to be on the lower end of those we support and this can mean that you are limitted in certain things.
I am sure lowering the screen resolution you play in would greately speed up the UI performance, but not sure if this is feasable solution for you?
Also lowering the texture resolution can help to free resources for the UI rendering thread.


Just to be sure are you on a Desktop PC or a Notebook with switchable graphics?

Hello Stefan,

I tried lowering graphics resolution and the texture resolution, but I have already lag at the main menu (more or less I can play OK the game).

I'm playing in a Desktop PC, and maybe with switchable graphics, because I have the GeForce GT620 and the own Intel's graphics card, buy I think the Intel's is switched off... but I'm not sure :-(


Edit: now I'm sure my PC does't have switchable graphics, only has the Nvidia GeForce.

The latter would be important, since it happens often that the UI process gets assigned to the Intel GPU.
Did you try this step:
(from http://brightrockgames.userecho.com/topics/1096-missing-invisible-or-laggy-ui/)
"Forcing WFTO to use your Nvidia GPU


  1. Open Nvidia control panel as above
  2. Select 3D Settings and reset your settings to default
  3. Select "Program Settings" tab from the 3D Settings menu
  4. Add WFTOGame.exe from your WFTO Directory (You can find this by rightcliking the game in steam, going to properties and clicking "Browse local files")
  5. In addition be sure to add "CoherentUI_Host.exe" with the same settings below.
  6. Select "High-performance Nvidia Processor" as the preferred graphic processor as above."

?

Normally doing so fixes UI lag issues on rigs with switchable graphics.

"CoherentUI_Host.exe" is the UI process which does lag for you.

Thanks. I've did that, but doesn't work to the 100%.

First of all, I did the above step, and after I added "-force-d3d12".

Now, the main menu has improved a bit, but I still have laggy mouse, more or less 0,5 seconds.

Do you have more ideas to do? Thanks! :-)

Hey Raul,
I am sorry but I do not know much else what we can do about.
Lowering resolution is the only other thing I hoped would improve a lot.
The issue is that your GPU is on the lowest end the game supports.
If you compare the recommended reference GPU according to steam system requirements:
http://www.videocardbenchmark.net/gpu.php?gpu=GeForce+GTS+450&id=1
and your GPUs performance:
http://www.videocardbenchmark.net/gpu.php?gpu=GeForce+GT+620&id=1429
then it is likely not strong enough to perform well with this game.

Maybe you could try to assign "CoherentUI_Host.exe" to your onboard Intel GPU while "WFTOGame.exe" runs on your GT 620.
If this works than each CPU has less load than when both run on the same.
But I am unsure if the Intel GPU can handle the UI process, but the other way around it would be worse.

If this does not work then you would need a stronger GPU to play this game.

Ok, then I will have to ask for a new graphics card to Santa Claus... Thanks!

Not a Bug

Sorry we couldn't help, best of luck!

Finally, I bought a GeForce GTX660 and a new power supply ... and now the game works perfect!! =D

Great to hear that Raul. If you have any issues let us know! :)