+2
Completed - Resolved

BUG: Lv7 Heart Attack: all enemies slain but map is still not won

Heimdall 3 years ago updated by Cian Noonan (Graphics Plumber) 3 years ago 10

Bug

I have erased all remaining enemy forces, even incarcerated the three priestesses in the target room and claimed all tiles in reach, but the game won't let me win the map.


First time my imps took over the gate, second time I let my dwarves bring down the gate. Both times I slew the remaining dwarven lord and the lv10 priests with ease but the map is still running.


Guess I did not trigger the end sequence, what's gone wrong?


Did read on the net: I have to loose the map to progress further. Although it's an easy map, I managed to get overrun by dwarven-zergling-rush; but it was assessed as a common defeat, so I guess I still have to trigger the forementioned sequence before losing.



Core Information

Win 10 64bit

RAM 8 GB

CPU Intel 4770 3.4 GHz

GPU NVIDIA GeForce GTX 770


Save (after the Bug)

7 heart attack_20161215180418.meta 7 heart attack_20161215180418



Game Version:
Steam Public
Platform:
Windows
+1
Accepted

We tried to replicate this internally but we couldn't reproduce the problem.
When you run into such trouble please always grab and update the output_log as it shows us if any error did occur and often helps to track problems down.
Here is explained how:
http://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/

We will have a look at your save games though.

+1

Thx for the promt response.

Thought the alpha-bugs were purged from the game. Would be splendid if you could fix it.


Here is the log:

output_log.txt


The 2nd time I did run the map, I didn't use ghosts and imps to invade, only battle units (Thought a peaceful approach might prevent the cutscene).


This time the game at least tried to trigger the sequence; the cursor/ evil-hand vanished, but the battle went on, I still did win the fight but not the map. So it's still the same, just without cursor.


I am stuck. Is there a console cmd to auto win a map?

> Thought the alpha-bugs were purged from the game. Would be splendid if you could fix it.
Believe me it worked fine since ages and we never got any report like this again.
So either we recently broke something or you found a unique new way to break it ;)

> I am stuck. Is there a console cmd to auto win a map?
No unfortunately either try an earlier save or it would be a redo.
However I am well disposed if you redo it it would work fine as it did always work and also worked when we tried to replicate your issue.



+1
Completed - Next Patch

I have this bug as well.

output & Savefile & 7 heart attack_20161216063107.meta

I'm on attempt 5, thought maybe having cannons kill the monks did it... someone else on reddit suggested maybe loading/saving broke script, tried it twice without a load or save directly, tried killing and claiming EVERYTHING, and tried just killing up middle this time and this attempt failed too.

Edit: and see someone posted it's fixed next patch as i was posting this, yay. :)

I added tons of securities for this level so it finish, I couldn't save the save files however :^(

I'm well disposed to say if you beat the level again you won't have the issue again. As my colleague pointed out, we ironed out C7 before and your play style must be rather rare ;) Nonetheless I'm terribly sorry that you encountered this issue, twice ^^' I personally never like to replay a mission more than once, but if you give it another go I'm sure it will work, and in the worst of the worst case scenario, if you end up in the same situation, a save/load at the end would make the level finish.


I fixed this issue before your play through though. Having this issue on a clean play without save/load is really not a good sign.

Can you do the following please ?:

Also, do you have a save file before attacking the Dwarf ? If so it would be perfect if you could upload it = )

Completed - Resolved

This map has received some major improvements, so I will close this ticket. If you feel it is not solved, then it's possible to reopen.