Completed - Resolved

OSX crashes on startup - bug report

jjjflanagan 6 years ago updated by anonymous 5 years ago 24 5 duplicates

Hello, this is crashing upon startup for me. About one minute in, or when dialogue first starts: 'Welcome...' *crash*. I'm opting to post this now because the other resolved issues seem to be due to taking out a second monitor, which I don't have.

I've put some of the bug info below.

OSX, Sierra, 27-inch (2560x1440)

NVIDIA GeForce GTX 660M 512 MB

2.9 GHz Intel Core i5

16 GB 1600 MHz DDR3

NVIDIA GeForce GTX 660M 512 MB


Game Version:
Steam Public


Completed - Next Patch

Hey all, 

We will be pushing an update in the next few days which has fixed this issue. Please get back to us once you have updated if you still experience the crash

Duplicates 5

Thanks for the report. I can see a potential bug in the log there. Unfortunately it may be with a third party piece of software we use. I'll contact their support today and try to turn this around quickly.

In the mean-time - It looks like the root cause is that it thinks part of the game is running on your inbuilt Intel GPU, and not your more powerful Nvidia GPU. Try closely following this guide here: http://brightrockgames.userecho.com/topics/1096-missing-invisible-or-laggy-ui/


Edit: Added log file.

I'm having the same issue. Identical screen, looping sound. War for the Underworld 1.5/Underlord Edition via Steam.

MacBook Pro Retina, Mid 2012

macOS Sierra 10.12.2

Model Name: MacBook Pro

Model Identifier: MacBookPro10,1

Processor Name: Intel Core i7

Processor Speed: 2.3 GHz

Number of Processors: 1

Total Number of Cores: 4

L2 Cache (per Core): 256 KB

L3 Cache: 6 MB

Memory: 8 GB

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M

Type: GPU

Bus: PCIe

PCIe Lane Width: x8

VRAM (Total): 1024 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0fd5

Revision ID: 0x00a2

ROM Revision: 3688

Automatic Graphics Switching: Supported

gMux Version: 3.2.19 [3.2.8]

Metal: Supported

I remember someone had a similar issue on OSX
[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
( https://github.com/Homebrew/homebrew-core/issues/2869 )
Also on OSX 10.12.1 Sierra, but it fixed itself after an OS Update.
Maybe an update to 10.12.2 (newest), could help?

Pending Third Party

Hello guys,
I merged some duplicates into this report as all show the same characteristic:
- Crashes caused by a bug of chromium engine (used by our UI middleware CoherentUI) on OSX Sierra 10.12.1 and 10.12.2
([warn] kq_init: detected broken kqueue; not using.: Undefined error: 0)

We raised a bug report at our middleware vendor and hope to get support on this issue soon.
So we need to wait for a third party support.
Sorry for all inconvenience and thank you in advance for your patience.


Thanks for getting back to me. I'm actually away from my computer for a month but will do this when I get back.


Thanks for letting me know. Will you post updates somewhere?



You should get updates via email automatically as we progress this ticket. :)

Pending Third Party

Hello Paulevans,
we are sorry for such inconvenience and you are not the only one with this issue.
We are waiting for third party support from our UI middleware vendor.
However if you not want to wait for a fix and you just got the game it is possible to refund it on steam store if you played less than 2 hours.
A fix will come for sure but might take a while as it depends on a third party.
I am merging your report into the existing thread.


ok thanks for the quick reply, I'm happy to wait for a fix, as the game looks so good & reminds me of an old fav dungeon keeper & dungeon keeper II .... these were epic games in their time.

I just realize that some of you get this crash when starting the camapign.
We suspect it is caused by the video cutscene trying to play.
We have added am option to disable video cutscenes in a recent hotfix to bypass this problem:

In case the game crashes when you start either campaign, can you try if disabling cutscenes allows you to play the campaigns?
Activate this checkbox: http://imgur.com/a/DylI6

It is no perfect solution and swe still need to find the root cause with thrid party help,
but would at least help you to keep going for now.


Can confirm, was able to start the first mission in the campaign after disabling the cutscenes!

Thank you for the hotfix, I look forward to seeing the cutscenes, but I greatly appreciate being able to start in on some of the missions.


Glad to hear and thanks for reporting back!

You are only missing 4 cutscenes of this kind: a start and an ending cutscene of each of both campaigns.
All other scenes are in-game or in-campaign-menu I don't like to spoil but can say most things are done in a way that should work for you which are not disabled by this option.

Enjoy :)


Can everyone else confirm or deny that their issue is quick fixed / the game does not crash when cutscenes are disabled?
Or is anyone having still a crash issue when they are disabled?

Has there been any update on this?

BTW I tried the fix, but I don't even get to a menu at the minute, it crashes as soon after the first loading screen and I get some sound (sort-of wind howling).


@Stefan - I think so.

Just ran the game for the first time on my mac. After initially crashing so hard it took down the Steam Client too, it managed to run until entering a campaign. Tried a few times, no success.

Disabled cut-scenes and tried again - made it into the campaigns, and through the first one with no issues.

I won't be able to tell until I get home, sorry.

@Niels This sounds like some good news at least. I hope it keeps working now.
It will likely take a while to get the root cause fixed.

I got to a skirmish game, but you lost the menu screen when you pressed esc, every now n then , pressed esc again and it returned. I didn't try campaign games. sorry

@Stefan I just tried again - the game crashed hard again during the initial loading, but when it passes that, it's able to run OK and let me progress in the campaign.

Tomorrow will try a few things again.

Note: I suspect the early crashing I'm experiencing is then unrelated to whatever causes the game to stall at cutscenes.

I suspect similar problems.
The cutscenes are an hard crash issue on most OS X systems, while the other issue comes with our UI middleware and the version of the Chromium engine it uses which may or may not lead to a crash on certain OSX 10.12 Sierra systems.
However some systems seem to be not impacted by the latter (eg. our managing director has no issues on his Mac).
So we got actually two separate issues as it looks.
We may find a way to resolve the cutscenes problem, but we need third party help for the Chromium engine problem.

I am just glad that you can still play even though with major difficulties.

Completed - Next Patch

Hey all, 

We will be pushing an update in the next few days which has fixed this issue. Please get back to us once you have updated if you still experience the crash

Completed - Resolved
Completed - Resolved