0
Completed - Resolved

Problem with Community translation

BlackBeard San 3 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 3 years ago 11

once you select the community translation, When restart the game the community translation It is not loaded.

when you restart the game, the text on the loading screen is in English(standard translation) and once loaded the menu you have to remove the selection (community translation) and reselect it again.


example: I access the game menu, I select community translation. (base language: EN and community translation: IT). When you restart the game and I log on the game menu text is in English, while the menu in Italian.



To view the IT translation must still clear the translation and reselect it.

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED

happy that the problem was solved :)

Satisfaction mark by BlackBeard San 3 years ago

Hello BlackBeard = ) I'm afraid I can't replicate your problem.

If you're talking about the very first loading page, this one isn't translated because it is during this loading process that we load the settings, and discover the community language.

So this very first loading page won't ever be translated ^^' The rest of the game however, and any further loading page will be translated.

I downloaded your translation file and confirmed everything works perfectly ^_^

Ah and also, I need Lee to update his tutorial on how to upload translation, but you can already set the default image by putting an image file (under 1MB) in the Translation/Community folder alongside your community file, with the same name. Something like that:

Thanks for the info.


here is a video demonstration



the text remains in English.

This is the translation file

Wfto GameText Traduzione IT.csv

Ah ! That's a different bug, the translation is not even working, can you upload a log ?

I'm highly suspecting that the CSV must have something wrong, preventing the game from loading it.

You will find output_log.txt in Steam\steamapps\common\War For The Overworld\WFTOGame_Data

the file work correctly


I have understand where the problem is.


the downloaded file from the steam workshop is saved in the path (on my PC)



D: \ Program Files (x86) \ steamapps \ workshop \ content \ 230190 \ 817612925



while my translation is on
D: \ Program Files (x86) \ steamapps \ common \ War For The Overworld \ WFTOGame_Data \ Translation \ Community



for some strange reason the file appears the same.


War for the Overworld Launcher Log.txt

output_log.txt

Completed - Resolved

Should be fixed now :)

+1

i love u guys :) <3