0
Completed - Released

Unit Tab / List Disappeared (1.5+)

Karrok 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 22 1 duplicate

I've created a custom skirmish map with a lot of 'good-guy' spawns in the center, these are there to be converted by players, giving an incentive to rush to the center.


When testing this map I found a problem while saving -> loading, the creature list is totally absent.


re-loading the game did not work.

quiting the game and restarting -> load did not work.


game version: 1.4.3f5

windows 10


Logs and Savegame


map without creature list


DX diag for system info


Game Version:
Steam Public
Platform:
Windows

Duplicates 1

Accepted

Discussed via Discord. This is not a repeat of the previous issue where a high scaled UI could cause the element to drop off the screen edge.

MinionList.png
I have loaded the save game, which took long because this map is massive but as you can see I got the minion list on screen.
So maybe we fixed it meanwhile unknowingly or we might do something different than you do.
Does changing HUD-Scale in Options->Gameplay fix the problem for you?
Otherwise maybe wait for then newest patch and confirm it is still a problem..

I will put it to done for now as in our internal version the minion list is clearly working in your save game.
However let us know immediately if there is still an issue once the new patch 1.5 is out.
Cheers

Completed - Next Patch

Just a headsup, Loading the pre-1.4 savefile in 1.5 and still don't have a creature list. But from the tag I guess it will be for post-1.5 ?

Can you check if changing HUD-Scale in Options->Gameplay fix the problem for you?
Which resolution do you have setup for your screen? Does it match what you have set in the game options?
Does changing either fix it for you?

Odd update, I started a new game on my self-made map, and after converting a (lot of) 'good' guys, my creature tab just plain out dissapeared, so without loading/saving.


output_log.txt


remote15.rar


UPDATE: Setting the UI scale from 80% to 100% popped in the unit bar again :o (for now, lets see if that survives a save/load)


Trying various HUD scalings ( in %):

50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60: shown

61, 62, 63, 64, 65, 66, 67, 68, 69, 70: gone

71, 72, 73, 74, 75, 76, 77, 78, 79,80: gone

81, 82, 83, 84, 85, 86, 87, 88, 89: gone

90: shown

91, 92, 93: gone

94, 95: shown

96, 97: gone

98, 99: shown

100-120: shown


Which might be related to screen resolution or HUD-Scaling option.
Please check what I said above.
And let us know in which resolution you are playing the game?
4K resolutions are not supported by our UI middleware yet.

desktop: 1920x1080 60Hz; virtual: 1920x1080 at 0,0

OK, so it is related to HUD-Scaling, thanks for the detailed tests.
Might be an rounding issue which sometimes causes it to exceed the available space by one pixel and gets cut off.
We will have to look into that.
For now try to play with a scaling where it shows correctly.

Thanks for the report.

Should be fixed in hotfix 1.5.0f9

Completed - Next Patch
Under Review

Try to change HUD-Scale in Gameplay options to bring it back.
It's on our list and will be fixed.

Merged with related topic & reopened lead topic.

Completed - Next Patch