0
Completed - Resolved

Cant dismiss rally flag via interface in multiplayer

Cron 3 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 3 years ago 22

When playing in multiplayer rally flag can't be dismissed by clicking on small red flag above minimap, the red flag is simply not there. Its kind of big annoynace because minions are usually all over your flag so I have to move flag somewhere else first and then right click to dismiss it.


I'm pretty sure its only related to clients and not host but I'm going to verify it later today.

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Cron 3 years ago
Accepted

Unlikely to affect hosts. Passing through for review thanks for the report! :)

Hey I just tested this with two PCs in our office and it works fine for all flags for both client and server.
Here a screenshot when I play client:
http://imgur.com/a/SLLYL

But you not even got the red cancel icons?
Maybe we fixed this issue internally but we did not put the fix into a new public hotfix or patch yet.
However this one seems utterly important so I would wonder if we wouldn't.
All I can see it works from my end, so we may try to get this hotfixed soon.
Can you confirm the issue still persists in current public version?

Yes it's still missing. I dont get any red flag icon when I use rally flag as client in multiplayer.

We must have fixed that internally meanwhile but not pushed a new build containing this fix.

I know that we had this bug before 1.4 release, but I will look at it on this WE.
AFAIK every match I played as Client it worked fine.

Perhaps it's OS related?

I use windows 10 64 bit without anniversary update if that matters.


Honestly, I get alot of bugs playing as client in multiplayer. Most of them dont appear until 15 minutes+ into the game when there is alot going on already so trying to replicate them at beginning of the game can be tricky.


I also ecounter bugs that are supposed to be fixed already (bugs that were mentioned in patch notes). Stefan suggested that my game might be corrupted so I am going to reinstall it and let you know later if that changed anything.




At least the cancel rally bug is an old one we had some months ago and it should really be fixed.
Now I wonder if you are maybe checked into an old beta branch? (Properties -> Betas)

Can you attach your output_log.txt after triggering the problem? (Before restarting the game)
See: http://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/
So we can see two things:
1) Which game version you have.
2) If any error occured causing the UI issue.

I reinstalled the game right now but I checked earlier output logs I posted in previous bug reports and I think they confirm I was on the last version of the game


engine version: 5.4.0f3 (a6d8d714de6f)

WFTO Version: 'v1.4.2f9

Tested it on version 1.4.2f9
Can't reproduce, will test that in a real match then

Pending Customer

We still need you to upload your output log please Cron.

I asked friend of mine to play today after work and will do my best to reproduce these bugs and post whatever is needed

Yea this one is the only big remaining riddle from all your reports,
because it should be clearly fixed in public version
and none of us can reproduce a problem with this feature right now.

We only had time only for 1 game today and to be honest I tried to reproduce it and couldnt, the thing is - I didnt even play multiplayer before heart of gold release so it couldnt be any version before 1.4.


The only thing that changed since we last played was that my friend purchased and updated to heart of gold aswell (he was hosting without HoG before), not sure if that changes anything though.


Not sure what to tell you guys, because I dont want to waste your time If I am somehow wrong about this. I will get back to you when we play more and get some proof

Hey Cron,
It does (or should) not matter if your friend has HoG and we intend that owning a DLCs can only make visual differences but never mechanical differences in multiplayer games.
> I didnt even play multiplayer before heart of gold release so it couldnt be any version before 1.4.
The cancel flag icons were temporarily broken in 1.4.0 and this was fixed I think in any 1.4.1fx version, if I remember correctly.

If you really encounter an annoying bug, then you can not "waste" our time better than reporting it, so we can get a rid of it and no one needs to suffer it again.
Thank you for any clear steps to reproduce issues, because when we can reproduce an issue, then we got already more than the half way of fixing it.
Most of the time we get lost in trying to reproduce issues, but most of the time there is a clear way to reproduce.
But I know it's sometimes not easy to find.

Anyway, thanks for helping to improve the game :)

The thing is that we can not reproduce this one.
Did you found any way to get this issue again?
Otherwise we might need to decline this report because it is not replicatable.

I believe it is happening alongside desynchronization issue: http://brightrockgames.userecho.com/topics/1410-second-playthrough-of-the-same-map-during-mp-without-reboot-causes-numerous-problemserrors/ and http://brightrockgames.userecho.com/topics/1432-multiplayer-1v1-client-side-messed-up/


I'm 100% sure it was happening in my matches that were desynchronized, I just didnt think these issues were connected. That explains why I wasnt able to reproduce it, because I started restarting game client every multiplayer match and red flag seems to work fine since that time.

Completed - Next Patch

Hrm we did address quite many MP issues recently, so I hope it will be fixed either.
Also it seems we might be able to reduce lag issues quite a lot with major Patch 1.5 but this will still take some time.
Before that we will release a minor Patch with many issues fixed.
So I will put this one to complete, but please let us know if you encounter it again after next Patch is out.

Bohser suggested that I should report on here a similar problem I had last game. Instead of the rally flags not being dismissable, no titan rally flag appeared (I summoned the colossus but there was no option to place a rally flag). Bohser suggests that this may be because he used console commands.


output_log.zip

That is quite a long log of many multiplayer games in a row.
I guess the issue was in the last game?
It contains quite some unusual errors which I not have seen before, but the debug commands can easily break single player games, but in a multiplayer game it is surely way more easy to break things.
So I can not tell if it was caused by using them but it is rather likely, all I can say for sure this log looks terrible :D