0
Declined

Game not working in fullscreen mode (OS X)

Tomasz Janusz 4 years sedan uppdaterad av Stefan Furcht (Programmer) 4 years sedan 14

War of the Overworld can't run in fullscreen mode on OSX 10.11.2. Right after start game seams to trying run in fullscreen mode, but window blinks several times and runs in windowed mode. Using CMD + F or using window controls to go to fullscreen doesn't work. Game working in windowed mode very well.


Logs from system console (game is running in main menu and I trying to run fullscreen):


04/01/16 18:53:48,142 kernel[0]: process WFTO[1037] thread 128304 caught burning CPU!; EXC_RESOURCE supressed due to audio playback


04/01/16 18:53:48,423 launchservicesd[75]: SecTaskLoadEntitlements failed error=22

04/01/16 18:53:48,522 WindowServer[160]: Display 0x2b282bcd captured by conn 0x27c97
04/01/16 18:53:48,526 WindowServer[160]: Display 0x335c4143 captured by conn 0x27c97
04/01/16 18:53:48,920 launchservicesd[75]: SecTaskLoadEntitlements failed error=22
04/01/16 18:53:49,483 WindowServer[160]: Display 0x2b282bcd released by conn 0x27c97
04/01/16 18:53:49,746 WindowServer[160]: Display 0x335c4143 released by conn 0x27c97


Game Version:
Steam Public
Platform:
OS X
Under Review

Hello Tomasz,


I will inform our OSX testers, it may take a bit to get a response.

Hi, mac os X tester here, what resolution are yo running at? I am running in fullscreen at 1980x1020 on 10.9.5 and it is working fine for me.

Well... I have MacBook Pro with 4K monitor connected to. And I have OS X 10.11

Hello Tomasz Janusz,
4K resolution can not be suported yet due to our UI middleware "Coherent UI" doesn't support it yet.
If you play on full HD resolution everything should work fine.
Cheers

I don't use full 4K resolution. Well - i use, but Mac has enabled option to scale UI to 2560x1440. In game menu i have options to chose resolution between 640x480@75Hz to 3840x2160@60Hz, so you enabled resolutions higher than full hd. And when I set 1920x1080 bug still exist - I can go to fullscreen mode.

Oh I was almost sure you would just suffer from the issue Coherent UI has with 4K resolutions.
1920x1080 should work for sure! However sometimes Unity engine has system specific issues on OSX.
We do not have too much control about this on our end. We just use the API provided by the Unity engine.
Do you have other Unity3d based games which do not suffer from the issue?

Also can you hold shift before clicking on "Play" in Steam and keep it hold until a little configuration window pops.
In this window you can chose your resolution and uncheck a checkbox "Windowed".
Does it help to get the game into fullscreen?

Hm. Cities: Skylines is based on Unity. And it's working on 2560x1440, but does not offer to go above that when display settings is set 4K as 2560x1440. When I switch to native monitor resolution Skylines also works, and in settings there are option to play in 4K. But I don't think is "4k" thing. I connected Mac to FullHD monitor and stil problem exists.

Well - nope :) It's not help. After start game (and game process fail to set fullscreen mode) this option is set to fullscreen. When I switch to windowed nothing is happen, and then switch to fullscreen - same effect. Game turns to windowed mode after 2-3 seconds of screen blinking

I just ask to be sure:
And in the in-game Display Options you have set it to fullscreen?

This sounds really odd and so far I have no clue why it doesn't work for you.
Can you start the game just trigger the issue and close it, then grab the Player.log and upload it here?
(As specified here https://forum.subterraneangames.com/threads/please-read-how-to-report-a-bug.4689/ )
Maybe this gives us pointers what is going wrong on your end.

Thanks