the game wont'launch osx

Avatar
  • Views 9,321
  • updated
  • Completed - Resolved

*Snip* - Noontide


log.txt

Game Version:
Steam Public
Platform:
OS X

How would you rate the customer service you received?

Satisfaction mark by notacode 8 years ago

:)

Add a comment about quality of support you received (optional):

Avatar
Lee "Noontide" Moon Designer & Community Manager
  • Pending Customer

Hi Notacode,


Thanks for the report and sorry to hear about the trouble's you're facing.


I'd like to gather a few more details from you please can you answer these questions:


  • What version of OS X are you running
  • How long have you owned WFTO has it worked previously?
  • What happens when the crash occurs?


Just to let you know I've also put your log into a file and uploaded it to make the opening post easier to read.


Please give the following threads a read:


How to: Submit a Bug Ticket - See if there's anything more you can provide that you think might assist us in diagnosing this issue.


OS X Crash on Startup (v1.4.0+) - We had an OS X crash previously which was fixed in 1.4.2f5 but just in case check this thread to see if the crash is similar, if so give the workaround a try.


Cheers,


Lee

Avatar
notacode

1) macOS Sierra 10.12


2) i've buyed 20 mar 2015 play 2 months then stop for a bug in 5 level and new stuck


3) steam>play> wtfo configurations> crash after 0.1 sec and ask for reopen ( tried with every settings )


Avatar
Lee "Noontide" Moon Designer & Community Manager
  • Accepted
Quote from notacode

1) macOS Sierra 10.12


2) i've buyed 20 mar 2015 play 2 months then stop for a bug in 5 level and new stuck


3) steam>play> wtfo configurations> crash after 0.1 sec and ask for reopen ( tried with every settings )


If you receive an error message can you provide a screenshot of that as well? Give the workaround a try and let us know how you get on in the meantime I'll forward this for review by our coders.

Avatar
notacode

it's enough? it's correct? thanks

Avatar
Lee "Noontide" Moon Designer & Community Manager

Hi Notacode,


The screenshot you provided is an screenshot of the error log. What I'd like to see is if when you crash you receive an output from the game or engine, though I confess my knowledge of Mac is not extensive I would expect to see some sort of popup box with a message in it.


Still I've forwarded this onto our code team for review one of whom is familiar with OS X related issues. We'll look into the log provided and see what might be happening.


Cheers,


Lee

Avatar
notacode

no output at all, ask for reopening of atto config and error log

Avatar
Lee "Noontide" Moon Designer & Community Manager
Quote from notacode

no output at all, ask for reopening of atto config and error log

Forgive my ignorance but might be important. What is atto config?

Avatar
notacode

wtfo configurations sorry for the typo

Avatar
Stefan Furcht Programmer
  • Under Review

This means that not even Unity3d engine can start at all.
Now there could be various reasons why this is the case.
The log shows it is crashing when trying to initialize your graphics device.

  • 12 dyld 0x000000010be1dd5b ImageLoaderMachOCompressed::doBindFastLazySymbol(unsigned int, ImageLoader::LinkContext const&, void (*)(), void (*)()) + 363
  • 13 unity.Subterranean Games.War For The Overworld 0x0000000101153970 GfxDisplayGL_Init(dynamic_array<GfxDisplayGL, 8ul>&) + 240
  • 14 unity.Subterranean Games.War For The Overworld 0x00000001011909b7 CreateGLGfxDevice() + 135
  • 15 unity.Subterranean Games.War For The Overworld 0x0000000100a87e20 CreateRealGfxDevice(GfxDeviceRenderer, bool) + 48
  • 16 unity.Subterranean Games.War For The Overworld 0x00000001011df9b9 GfxDeviceWorker::Startup(GfxDeviceRenderer, bool, bool) + 25
  • 17 unity.Subterranean Games.War For The Overworld 0x00000001011cefbc CreateClientGfxDevice(GfxDeviceRenderer, unsigned int) + 172
  • 18 unity.Subterranean Games.War For The Overworld 0x0000000100a88620 InitializeGfxDevice(unsigned int) + 432
  • 19 unity.Subterranean Games.War For The Overworld 0x0000000100b6b345 InitializeEngineGraphics(bool) + 69
  • 20 unity.Subterranean Games.War For The Overworld 0x0000000100b4d298 PlayerInitEngineGraphics(bool) + 24
  • 21 unity.Subterranean Games.War For The Overworld 0x0000000101154372 SetupUnityPlayer(bool, int, char**) + 7

So chances are there is something wrong in the setup of your GPU.
Do you have other Unity3d based games that work for you?
Are your GPU drivers up to date and have no misconfiguration?

Can you share your full system specs with us to see which hardware is involved?

Cheers