0
Completed - Resolved

The spell "Annex" is not working.

Windows 8.1 64 bit, 8 Gm RAM, Intel(R) Core(TM) I7-4500 CPU1.80 GHz 2.40GHz GPU: AMD Radeon R7 M265, Intel(R) HD Graphics Family. Version game 1.4.1f1

Played this map.



At the beginning of the game, the spell "Annex" worked. But then it stopped working. I can't attach the dirt, or to break the ground (neutral or my).
Attach the save, which the spell does not work.


War for the Overworld Launcher Log.txt

output_log.txt


The spell Annex is not working. 23.07.16.rar

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Галиев Рустем 3 years ago
Accepted

I see a couple of Nullrefs in the output log, but I don't think there's anything related to Annex. I've not been able to replicate but I've also not been able to load your save game. Passing on to code for further investigation.

Assuming you are red, you can only Annex tiles right next to your own tiles. The specific tile you are hoovering over, does not meet this prerequisite.

I'm trying to break MY wall spell "Annex", do not consider me an idiot.


If you first looked closely at the screenshot before you accuse me of idiocy (and only an idiot would put the problem with an error when it tries to break a spell someone else's wall), you would see the following:


The hand pointed at the wall, and that wall I'm trying to break. And the wall is perfectly visible that the owner is marked in green! And the green is indicated by only their own stuff in the game!

-1

First of all, If you break down your own fortified wall, it becomes an unclaimed tile. As such, I do not believe that wall necessarily counts as your tile. Understand that a wall does not count as a tile.


Secondly, I said adjacent to your tile. That wall is technically NOT adjacent to one of your tiles, even if you have it fortified. You could say its an oversight that you cannot break your own walls, but that's about it really.


Finally, you suggest the spell stopped working entirely, so have you tried to Annex the square below of it that is adjacent to the forge or not?

I ask not to continue to write in my themes. You're talking nonsense. Almost all map of my , the wall on the screenshot are mine, and the cells next to it. What cells are shown in gray is a visual bug, often on large maps.

I couldn't on this map, after some time, apply the spell "Annex" anywhere, not just on my walls. It's just a screenshot for visual explanation.

It is not necessary to go into someone else's topic and unfounded to blame the lack of understanding of elementary things. In addition, you can download the fucking save game (attached to topicstart), to check and to stop clowning!

Hi Guys,


Please try to remain civil. Understand that we're all here to try and help one and other and I appreciate that sometimes it can get a bit heated.


@Галиев Рустем Xelights raised a valid point and was simply trying to help, the points he raised would have been very easy to overlook. Try not to take it as a personal attack on you as I'm sure it was not intended that way.


@Xelights, Thanks for pointing those out, we had already identified that the wall was in fact correctly owned by him and he's indeed correct that the tiles above which are white is a visual bug, it would not be possible for him to own that wall without at least one friendly tile nearby.


Either way this ticket is now with code to review. Personally I suspect that whatever is causing the visual glitch is also affecting the way Annex works.

Hello Rustam,
I did load your save game and was able to reproduce the issue.
The reason this was happening is that you own so many mana shrines,
that the cost for applying annex gets down to almost zero.
However someone decided to not remove mana and return false in this case,
so the Annex spell thought it can not perform, while it can indeed.
So this was a corner case happening with many mana shrines on spells with low mana cost.

This issue will be fixed next patch.
Thanks for reporting!

Completed - Next Patch