0
Completed - Resolved

Game crashes computer on new campaign

Connor 3 years ago • updated by Stefan Furcht (Programmer) 3 years ago 11

I bought WFTO on launch and played it without any major issues, however I decided to wait until the game had been patched to do a proper playthrough. After the most recent update I decided to try again, I can launch the game just fine, navigate the menus and all that. I reset my campaign progress and then started the first mission. The cutscene works just fine, the game starts to load, and then my entire computer shuts off.


I have verified the integrity of the cache and while some files were initially missing, this continued to occur after they were re-acquired. This problem is exclusive to WFTO as I have played a wide range of games for hours on end over the past months (Overwatch, nearly all the Call of Duty's, Ryse: Son of Rome, GTA V, CIV V etc.) with no issues. The only other game that experienced similar symptoms was Enemy Front, which I refunded after it caused these hard crashes.


Any help would be greatly appreciated. Specs:

Windows 10 Pro 64bit

16 GB of DDR3 RAM

GTX 980ti (slight OC)

Intel i5 3570k @ 4.2 ghz

WFTO running on a 7200 rpm HDD

Nvidia driver 368.69 and it's predecessor (I have tried to play the game a few times over the course of the last month)

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Connor 3 years ago

Upon reviewing the event log for my system there are many errors about corruption on one of my hard drives. I will attempt to reinstall WFTO and see if it was possibly reading data from a bad sector

I did a fresh install and the problem persists, the event log shows no disk error this time however the game still hard crashes as soon as the loading screen appears for the first mission.

" and then my entire computer shuts off."
This can not be caused by just running the game.
Such behaviour often indicates that there is either an overheating issue or a power supply issue.
These problems only occur when the device is under full load for some time.
Did you check if CPU and GPU temperatures stay in normal ranges while playing?
Does disabling the OC help?
Often the interior of a PC gets dusty over time which can render the cooling much less effective.
Opening the case and vacuum cleaning especially on the cooler fans can help to fix.

I understand that such an issue is usually a computer issue but I play many games and this is the only one that presents the issue.


I launched the game again, this time with monitoring software to confirm that nothing strange was going on. The only difference was this time, when the loading screen appeared, I simply closed the window that asked to allow WFTO through the Firewall, and everything was fine. Seems the issue is more related to Windows Firewall than it is WFTO, I'll investigate further

Very bizzare, if the issue was as ubiquitous as Windows Firewall we'd see it appear more often. Sounding like an usual combination of the firewall and your own software? Do you have a specific AV or Internet security software in addition to Windows Firewall?

Yeah it isn't just the firewall, accepting it when I launched Call of Duty World at War posed no issues.


I run Bitdefender Antivirus but other than that there is no extenuating software.

I take that back. I started up the game, watched the opening cutscene, no firewall message this time (I added the exceptions myself.) Everything seemed to work just fine, I flipped over to the options menu to change some settings and bam, computer lost power and reset.


So, I opened up all my monitoring software and tried again. This time I skipped the opening cutscene and the game crashed instantly, temperatures were well within normal ranges (60 degrees C on both the CPU and GPU) and again this is the only game this happens on. I have dozens of other games installed on this hard drive, I've played half a dozen other games over this week, and this is the only game that causes this issue.


Nothing unusual seemed to happen before just before the crash, everything was working as intended, it's like someone yanked the power cord out from my PC. The event logs still show nothing unusual other than the computer losing power. I'm at a loss here. I'm going to try and replicate the issue in the skirmish mode and see if it's exclusive to just the campaign

So, hard as this is to believe, the issue is somehow related to the first mission of the campaign. I loaded up a skirmish map and was able to play a game with zero issues for 20 minutes. I quit to the main menu and then tried to launch the first mission of the campaign and my computer restarted at the loading screen again.


EDIT: I took a break and reinstalled WFTO to my SSD instead of my mechanical "Games Drive." Note that during this break I was playing Call of Duty with no issues off the same drive, but I digress. WFTO once again loaded and I was able to make it to the game. I went to the options menu and turned textures to ultra, possession FOV to 91, vsync off, and anti aliasing and SSAO on. I then went to the sounds tab and disabled subtitles, I hit escape to close the menu and my computer turned off, and restarted itself. This is the second time that I have had this crash upon leaving the menu from the first mission and about the 10th time I've had the "computer shuts off" crash in WFTO in general.


I also, in the interim, had a hard computer reset whilist playing Company of Heroes 2, so I think I've ruled out WFTO as the sole offender, however, I can confirm it is not thermal related, as temperatures are not even close to questionable levels during these times (and in games like Overwatch where temperatures are much higher I have no issues). It could be a PSU problem, but then I would expect to see this issue manifest itself in any activity, not just playing one or two different games, or more to the point one or two specific moments in one or two games.


I assume that some software somewhere is not playing nice, however, I can't determine what it is. Any ideas would be appreciated.

Quad post! I know, bad forum behavior, I apologize. I seem to have resolved the issue, in a last ditch effort to fix the game I reinstalled it onto my SSD and (and I believe this is what actually fixed the problem) did a clean install/upgrade of my graphics card drivers. I didn't try this earlier as I had this issue on two different versions of my GPU drivers but a clean install (from Geforce experience even, so not a full reboot/uninstall/reboot install type deal) seems to have fixed the issue, I was able to play the first to missions of the campaign and change options with zero issues.

Completed - Resolved

Yea this was an odd issue for sure.
But I am glad you got it fixed and can play now.
Enjoy! :)