Completed - Resolved

Weird homerealm behaviour

Thulium 6 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 6 years ago 14

Hi Guys,

There is some weird behaviour in this save file of my home realm:

- Glacial doors at the dungeon core appear opened, but locked

- Beds of minions are missing (but that one is known afaik)

- The fight in the arena (a bit east when loading this save) has bugged (i've tried loading this save twice, same results)

o Beasts kill each other (they aren't being moved out and healed)

o When the beasts are picked up and put down outside the arena, they are hostile to all my creatures (and each other)

Please find a log and the save file attached




Game Version:
Steam Public

Feedback on this (and other issues I've been involved in) was amazing!

I will test the changes as soon as I can :-)

Satisfaction mark by Thulium 6 years ago

Oh, I also forgot to mention. Does the treasury have a max size? As I have more then 1mil gold on it, but it doesn't show in the room stats. Also it seems my imps don't store more gold in it.

Under Review

Thanks for the save. I'll take a look at it when I'm in the office during the week.


Passing this on to code to review.

Hmm, for some reason I can't see the last comment:

McMurphey wrote:

The vault only shows up to 1024000 gold (I've reported that a year ago). But only the tooltip is wrong. It doesn't affect the gameplay.

I don't agree, it does affect gameplay. If you load the savegame I've attached to the post, you'll see that my Imps don't deposit the mounds of gold that are sitting in the taverns.

Strange. I've deleted that post. You shouldn't be able to recover it. I felt it doesn't add useful information and might be outdated since I did not investigated it in the recent build. Please ignore what I said earlier. I'm not a dev or official anyway. Just a random customer.


Hello Thulium,
please report one issue per bug report in future as it makes it easier for us to keep track of different issues and fix them separately.

I have found the issue occurring with the Arena, which did run multiplayer code which should not run in single player mode and this caused issues when units were put in the Arena.
This explains at least the Arena issues part of the report.
I did now make sure that this is not causing trouble in single player.

Will also have a look into the other issues.

Hi Stefan,

Thanks for checking them out! If you want I can register some new issues to split them up :-)

Cheers and happy bughunting!

Completed - Next Patch

No worries, that's our job :D

I have loaded your home realm and Arena fights work correctly again after fixing the error found in your log.

The glacial doors also work like intended, so they are closed while locked and if I unlock them they open gates when units want to pass as intended.
What I see should be correct:

Maybe we silently fixed this one already?

For the bed issue, it is purely visual. Which means all units have logical beds and will use them to sleep.
They are just invisible for some strange reason.
When I sell the lairs and rebuild them, all beds get created correctly and are visible.
So it is a visual save & load issue, which is not quite my realm.
My programming mate fixed it now multiple times and for some reason it can still break some times.
I told him it is happening again.
(more I can not do without learning different things I am used to do)

"The vault only shows up to 1024000 gold ..."
This might in fact be the case, because the gold amount is sometimes converted to floating point numbers and back to integers and we might hit here the accuracy limits of 4 Byte float numbers converted to integers.
I still consider it as a minor issue, as such big gold reserves are not accomplished due to normal game play and if they are, then the player has enough gold for all purposes and can cope with not more gold being stored.
But I agree it is an issue, even if minor.

Have a nice day :)

Thanks for fixing! I agree the gold issue is minor, just look at the sheer size of the vault required to store it in ;-)

But it seems that you aren't seeing the same issue with the doors as I did (and in all my wisdom I forgot to take screenshots..)

Basically, I kept those glacial doors locked throughout the game. So they should appear as you've shown in the screenshot. However, when I loaded the game it showed the doors as locked,indicated by the keypad and chains, but opened. Some Unity knowledge I acquired very recently ( ^^ ) tells me that it seems that the Animator Controller (the state machine thingey) thinks the door should be animated as opened. And because it's locked, will not allow for further movements of the door. It's still blocking access though.

I could fix the visuals by:

1. unlocking the door

2. drop a minion next to it

3. pick the minion up again

4. door will close

5 lock door

I will try to reproduce the issue with the doors when I get home.


I am pretty sure that this problem will be fixed for you with next update (as it is for me when loading your Home Realm save),
because we did quite some other fixes around doors and I am sure this one was just one more unwanted side effect we had before we fixed some essential issues with doors.

But in case you still get any door issue in v1.4.2 please let us know.


Ah, cool! Thanks!

Can't wait! ^^