+1
Declined

Unable to claim empire tiles

Julianb3000 3 years ago • updated by Jan - Eric Merzel 3 years ago 16

I've had this a few times, but it's just happened in a place that breaks a game, so it's inspired a bug-post.

Symptom - workers refuse to claim enemy tiles.

I was playing a workshop map, named The Vault (http://steamcommunity.com/profiles/76561198031969859/myworkshopfiles/?appid=230190&browsefilter=mysubscriptions&p=2)

The map has a bridge, then a chamber with lots of portcullis and traps, and empire units. This then leads into a corridor. Once I'd cleared the room out, the imps converted maybe 4/5ths of the first room, but refused to convert any of the corridor.

I used the imp rally flag, and they'd stand idle beside the empire tile.

I dropped them on the edge of the tile, and they just wandered off.


Nothing was attacking them, and they were just idle (so no higher priority tasks in the way).


It was as if the tile had been flagged as 'empire non-claimable'.


I've had this in smaller doses in other workshop maps, but not had so many tiles in one place blocked out.

I was under 25mins into the game, and it was a fresh game (not saved it & reloaded). It was also the first map I've tried to play since starting WTFO.

I'm on a 64bit machine with 16g ram on Win10.

This is version 1.3.1f5.

Julian.

Game Version:
Steam Public
Platform:
Windows

Hello Julianb3000,
we got a similar report recently, which we fixed already:
https://forum.subterraneangames.com/threads/unclaimable-neutral-tiles.9864/

However when the old bug forums was locked, I continued the thread with the reports in a private conversation on forum.
We figured out this is a map editor bug which creates invalid claimed tiles which are "fortified" (which is only meant for walls) when you paint claimed tiles over fortified walls.
Since these claimed tiles have the fortified flag (you can identify those when tooltip shows "[Fortified]" http://imgur.com/8732oYj) some game machanics considers them as walls.

Now there is a game mechanic that makes sure:

When ever you claim a new tile all adjacenting walls which do not have

at least one claimed tile of their owner in 8 neighbors around is automatically unfortified.

(you might have already seen that enemy walls are unfortified when you claim around them)

So when you claim any neighbor of of such "fake fortified wall" the game

will in this process "unfortify" the claimed tile, which does simply remove ownership.

What remains is a claimed tile without an owner, something which should never exist.

Workers who try to unclaim can't do it and will get stuck.


We fixed the issue on both two ends.

- Fixed that the map editor can create such tiles

- Made sure that a tile having the issue is automatically fixed on map loading


I guess you have the same issue and it is fixed already.

A patch will be coming quite soon.

Hint:
Until patched, you should be able to fix affected tiles simply by applying the Annex spell on them.

Please let me know if you think it is not this bug we have fixed.

Cheers

PS. I was not able to open your link as it points to "myworkshopfiles" which something you can only access private


+1

Thanks for a quick and thorough response.


Shame about the link - I was trying to help you reproduce it. :(


The symptom is very similar to the one I'm reporting, and may well have the same cause.


I think you're describing one where a tile becomes 'neutral unclaimable', and that can be resolved with annex or other tricks.

The problem I had is tiles that stay 'empire unclaimable', and those methods don't work to claim it. I can't annex someone else's territory, or build walls on it. For the moment, I don't think there is a way I can get around this problem.


However, the description of the cause and fix both sound like they'll match this, so I'll await the patch eagerly.


Cheers,


Julian.

P.S. I did search for any existing report in this forum, but there wasn't a post in here at that point - I didn't think to search the 'legacy' forum. :)

Hi,


Sorry to report that at least part of this fix isn't working.


I'm trying again with this map: http://steamcommunity.com/sharedfiles/filedetails/?id=578326103


I'm again finding that my imps won't remove the "Claimed Tile (Owner Empire)" from the tiles in the central corridor. There are no enemies nearby, and imps will stand "idle" next to these tiles - even though the tile next to it is mine. The tiles I'm having trouble with are ones in between the workshops on either side of the corridor.


Julian.

Edit: Come to think of it, this map is the main (only?) place I've seen this issue.

Hello Julianb3000,
any chance that the tiles in the center have hidden Blade Loti on them?
This makes workers avoiding these tiles, until you rally units on that tile which makes the Blate Lotus pop out.
I might take a look at this map as well.

Cheers

So I even played the map my self to the point where I claimed the "central corridor".
Despite this map being almost unplayable because of too many objects placed causing lag,
I was able to claim the center without any issues.



Or isn't this the "central corridor" you were talking about?



@V0id, I didn't get very far down that corridor. When you go over the first bridge, there's an area with a bunch of traps. The problem was just after those traps.


There might be hidden blade lotii, but I've pushed battles past that point without them triggering. Maybe I somehow had everyone walk around the hidden lotus tiles, and need to rally onto the tile to force it. I'll give it another go sometime and let you know. (After two games failed on that map, I've been avoiding going back!)


Cheers,


Julian.

So was it caused by the hidden Blate Loti there?
We still didn't encounter any issues (other than that) with claiming empire tiles during recent testing.

I've just tried again, and unless the blade lotii are determined not to attack anything (units as well as imps), I don't think so.


I've rallied many units over those tiles, and imps still refuse to claim them. An example.

Note the two "idle" imps standing near the pointer. This is despite the three nearby empire tiles that should be claimable. The units that have gone through that area include a behemoth, 5 ember demons and a number of ground troops. We fought a fair sized battle in that corridor. Surely something would have set off the lotii, if there's one there.


I noticed that it took several drop-ins before that imp who is claiming a tile would deign to do it - that's about my 4th attempt to claim that tile. (I wonder if that means that whatever causes the "idle" is the problem, and that it's not a tile-claiming problem but a lazy-imp problem?)



Well your screenshot looks a bit messy, because there is units and flags everywhere around the tile you are talking about and so it is hard to see what is going on.
Are you sure you know what you are doing with all these flags?
You have placed quite many flags there, I can see some are Worker Rally but some could be Impasse (it's hard to see).
You know that workers won't claim tiles which are in the area of an Impasse flag?
Also if you put Worker Rally at a place workers will prioritise tasks in range over all other tasks on the map.
So as long there are any open tasks in range of a Worker Rally flag workers will never do any task elsewhere until directly assigned by drop.
However Impasse is stronger than Worker Rally, meaning if both areas overlap the Impasse will deny all tasks in its range.

Can you remove all these worker flags (right click the icons) and rally units a bit away to make a screenshot which makes it easier to see what is going on.
Maybe you just had an Impasse around the tile not claimed and it does fix it for you.
But if not then please make a new screenshot and hover the tile supposed to be claimed, so we can see the tooltip of it.





Hi,


Yes, I'm sure I know what I'm doing with the flags, thanks.

1. I am not using impasse flags.

2. Most of the flags are worker-rally flags - specifically to get them to focus on those tiles.

3. There are also unit-rally flags - to get the units to walk over those tiles, to trigger any lotii that might be on the tiles.


Still - nevermind. We've been talking about this for 3 weeks. It seems I'm the only one with this problem, and just on this map. It's probably not worth your time from here. (Plenty of other maps I can play.)


Julian.

Hrm... what I guess then there is still a lag issue which can break worker tasking.
You might only encounter it, when a map is literally too big and bloated with stuff for your pc.
So while this map lagged quite heavily for me, my rig was maybe still strong enough to not run into that issue.
However if you encounter this issue again, without having utter lags, please let us know.
Thanks for provided info so far and reporting anyway.