+10
Completed - Resolved

OSX Crash on startup (After Patch 1.4)

Lostlogic 3 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 3 years ago 66 4 duplicates

Crashes no matter what I do. Even tried turning off graphics switching as per other threads. Also did a validate.


OP Dump.txt

Game Version:
Steam Public
Platform:
OS X
Pending Third Party

Answer

+2
Answer

This is working now for me. (It started working before the 1.4.2 patch was released). The only thing that changed, that I can think of, is that I may have had an external monitor plugged in to my MacBook Pro before, and I don't now.

Duplicates 4

Hello Vexual,
please do not post the text of a log file directly, it makes bug reports unreadable.
Please use the "Insert File" button (paper clip symbol) to upload logs.
The crash log you uploaded is not the "Player.log" we were looking for.
It's just a system crash log which does not give us enough specifics.
Can you find and upload your "Player.log" as described here:
https://forum.subterraneangames.com/threads/please-read-how-to-report-a-bug.4689/

Or does it crash even before any Player.log gets created?
In this case, is at least a Launcher log file generated? Can you upload it as well?

So far it looks a bit like there is an issue with Unity engine on your specific system but with logs we might know better.
Do you have other Unity based games which do load for you?

Hey Team,


So what happens is:

1 i open game,

2 it doesn't lost

3 i get an error file


Where will i find the other bits?

Screen Shot 2016-06-23 at 12.25.16 PM.png Screen Shot 2016-06-23 at 12.25.19 PM.png Screen Shot 2016-06-23 at 12.25.23 PM.png

In the link I posted in my last reply it explains how to find the "Player.log" file (read below the "OS X" header), which contains logs written by the game while running.
Please find the file and upload it to this thread using the "Insert File" (paper clip) button.
These logs can tell us when a problem occurs and what causes it, but without these logs we can not know what happened.

ahhh now i get it, here it is.

Player.log

I'm seeing a similar thing. The boot screen loads in the bottom left corner for a few seconds, I get some flashing GPU garbage on the other 3/4 of the screen, then the app quits. I tried reinstalling, removing any external mice/keyboards/monitors...still nothing.


Might be a duplicate of:

https://brightrockgames.userecho.com/topics/1067-mac-crash-on-launch-from-steam/


Specs:

  • OSX 10.11.5
  • MBP Retina 15-inch mid 2015
  • 2.5 GHz Intel i7
  • 16G RAM 1600 MHz DDR3
  • Graphics - Intel Iris Pro 1536 MB

Abridged Error Dump (I can include the whole thing on request)

===========================================================


Process: WFTO [1026]

Path: /Users/USER/Library/Application Support/Steam/*/WFTO.app/Contents/MacOS/WFTOIdentifier: unity.Subterranean Games.War For The Overworld

Version: Unity Player version 5.3.5p4 (5.3.5p4)

Code Type: X86-64 (Native)

Parent Process: ??? [1]

Responsible: WFTO [1026]

User ID: 501

Date/Time: 2016-06-25 10:38:55.481 -0700

OS Version: Mac OS X 10.11.5 (15F34)

Report Version: 11

Anonymous UUID: 06225266-7B8E-0754-252B-9972B856171B

Sleep/Wake UUID: 08D09271-2D7B-4BD7-A25F-DD5D903FC0DD

Time Awake Since Boot: 13000 seconds

Time Since Wake: 380 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGABRT)

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000020

Exception Note: EXC_CORPSE_NOTIFY

I believe this is actually fixed. When Patch 1.4.1 was released there was an issue that prevented WFTO from launching. We had it hotfixed within an hour.

thank you Lee, I guess there is another issue, as the game is up to date, has been reinstalled twice now, and still doesn't work.

Any assistance would be welcome, cause I really wanna relax with some minions

how we doing lads and ladies?

Under Review

Thanks for the report guys. Could you please take a look at this article and attach the listed log files for us to review? https://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/

Not too good unfortunately,
The log does not even hit a single line of our own code.
The Unity Engine crashes before any normal game log has a chance to report anything and the entire stack trace only contains internal Unity components.
So this is clearly an issue with the game engine we use on your particular system and not an issue with the game code it self.
Thus we will need to get support from Unity Labs for this.
Stay tuned.

In fact this issue looks very similar to https://brightrockgames.userecho.com/topics/1067-mac-crash-on-launch-from-steam/
Seems we need to contact Unity Labs about this problem.

Including the player.log for sake of completeness

player.log


Thanks for looking into it guys, let me know if I can do anything else to help

+1
Accepted

Thanks. We've forwarded the bug report to Unity 3D for review.

Hi Vexual,


We've seen a few more reports similar to this since. Unfortunately what I can say is that this problem appears to be caused by Unity failing to initialize the graphics device and we are unable to resolve it at the current time. We have submitted a bug report to them and are pending their action.


I am merging your report to other related reports.

Hey Lee,

that makes me sad. So sad that i'm thinking of buying another laptop/rig just to play this game.

Truly sorry for that, it's always a pain when an issue turns up with the underlying engine and specific hardware configurations. Hopefully it won't be too long until we receive a response from Unity, although sometimes depending on their priorities it can take a little while.

not as of yet, im sorry for the inconvenience

I am having the same issue on my Mac. Just bought the game and it won't start. Same error log.


I have the 2011 Mac Mini with 8GB Ram i7 and AMD graphics

hurry up unity

Here is my player log. I am facing the same problem.


MBP 13.3 inch Late 2013
2.8 GHz Intel Core i7
Intel Iris 1536 MB
16 GB 1600 MHz DDR3
OSX 10.11.5


Player.log

Can some admin update the bug description to remove all the text. It makes this report unreadable.

No news yet I'm afraid friends. Cleaned up the OP as requested above.

I dont know what happened on my Mac but the game works just fine now.

Pending Third Party

Hello Judy2k,
it is very likely you suffer from the same issue some OSX users encounter, eg.
http://brightrockgames.userecho.com/topics/1086-osx-crash-on-startup/
As said in the above thread, we have forwarded a support request / bug report to Unity Labs and do need to wait now for a response.

Yup. It does sound like that.


I just tried running the game again (with graphics switching turned off, just to see), and I'm getting the same immediate failure :(

+1

Player.log MacReport.rtf

Looks like I've got the same problem, I've attached my log and mac report. Any news on a fix yet? Been waiting to play this game for years!


iMac (21.5-inch, Mid 2010)

OSX 10.11.5

3.2 GHz Intel Core i3

8 GB 1333 MHz DDR3

ATI Radeon HD 5670 512 MB

Hey guys, we just released patch v1.4.2 on steam! Please verify cache and let us know if the OSX crashes still persist for you.

+1

She no work still. I'm so many sads. Please fix this game, it's just taking so long and is completely unplayable

Thanks for the update Vexual, we'll keep pushing Unity for a hasty fix.

+2
Answer

This is working now for me. (It started working before the 1.4.2 patch was released). The only thing that changed, that I can think of, is that I may have had an external monitor plugged in to my MacBook Pro before, and I don't now.

+1

Top man! I have a 2nd monitor plugged into my iMac, disconnected the monitor and the game works perfectly!

That's very interesting info Mark Smith, Vexual do you by chance also have a monitor attached to your Mac? If so we may have found a missing link that we can pass straight on to Unity! We'll have to test this with our Mac tomorrow as well.

For testing purposes I plugged my 2nd monitor back in, tried starting the game and it wouldn't work again. Un-plugged it and I was back playing the game

hey team, I wish I had a monitor plugged in, alas, I do not.

This suggests there is additional causes for this issue. We've yet to be able to test internally with our Mac. Sorry to hear the workaround thus far is not working for you.

I can second the testing. I have a second monitor and Unplugged it works. Plugged in it doesn't work.

Interesting enough if you start the game unplugged from the second monitor then plug it in it does work.

Thanks for the feedback guys, we'll make sure this info makes it's way to Unity. It can't be a coincidence that for the majority of you unplugging a second monitor seems to assist.


I'll also be deploying a knowledgebase article with this issue and workaround tomorrow.

I can second Vexual's issue. I have an external monitor, when it's plugged in I don't even get to see a loading screen. When it's unplugged, the game tries to load for a bit, gives some flashing non-intelligible video card garbage, then crashes.

+1
Under Review

Hi Anthonypmarino,


I've merged your thread into a related thread. To catch you up, we've identified a fault in the underlying Unity engine that is causing these issues. We've contacted Unity for their assistance in resolving this matter.


There's a potential workaround that might help you if you have a second monitor attached some users have reported that detaching this from their Mac has allowed the game to run. I'd advise giving this a go while we wait for a response from Unity.


We're also expecting the next patch (likely a hotfix) will be using a new Unity version and if things go well we may roll that onto a seperate public test branch to see if it also solves the mac issue. I'll keep you posted.

Thanks for the info, sadly I do not have a second monitor, will sit tight till the hot fix comes out. thanks

Hi Guys,


Just so you're aware there's a hotfix on the Public Test Branch that might fix this issue. Please can you give it a go and let us know if it works.


Cheers,


Lee

Lee,

I've downloaded the publictestbranch beta, and I get a more promising loading sequence, but the app still crashes before the game totally loads. Strangely enough the crash does not prompt an alert window asking to download the error report. Which I have to imagine is frustrating from a debugging perspective. Let me know if I can help in any other way, I've been wanting to play this game for the last 3 months.

can confirm that it don't work.

So just to make it even stranger, it's crashes my steam also

Very dissapointing. We're back to waiting on Unity I'm afraid. I'll have our code lead try and pressure them some more. Really sorry that this has continued for so long guys :(

No change for me - Followed all tips/help for resolving issue/verified everything via Steam/uninstalled and reinstalled game - Still crashed after initial start up window.

I'm on a Macbook Air and have no idea what anyone means by "unplugging a secondary monitor"??

Just want this fixed now please :(

as of today. We have lift off!!! No idea what you did, but I'm in deep and loving it!!! Thanks for your hard work. If I can figure out what you've done, I'll emails.

That's great to hear Vexual, we actually made some fixes that seemed entirely unrelated but perhaps they've had a knock on effect for you guys as well. If anyone else sees improvement please let us know! :)

Can confirm the fix, I've got to go command some minions now.

Thanks for the support all.


Completed - Resolved

Great news guys, looks like the issue has been addressed for all affected OS X users. Let us know if anyone continues to have problems but for now I'll close this down as complete.