0
Accepted

Unable to start game, crashing directly after splashscreen

Grant 8 months ago in Crash updated by Lee "Noontide" Moon (Designer & Community Manager) 2 months ago 13

Fresh install, finally wanted to get around to playing this game but it's crashing right after the splashscreen appears (no error message or notification, the process just ends). I've followed troubleshooting guides but haven't had any luck. I've attached my logs (there is no zip file). output_log.txt

Game Version:
Steam Public
Platform:
Windows
10th-Gen Mobile Intel CPU - Splash Screen Crash
Pending Customer

Hi Grant,

Sorry to hear you're facing an issue with the game crashing immediately after the splash screen. Can I confirm the nature of the issue is as follows:

  1. You launch the game via Steam. The Splash Screen appears.
  2. The Splash Screen disappears, the game does not appear. No program is visible on the taskbar, no screen take over. The process is no longer listed in task manager.

Can you also drop a dxdiag file in for me (How to: Submit a Bug Ticket) and confirm if you're running any antivirus or other such programs which may be able to kill processes. If so can you try adding the WFTO folder to your AV's exceptions?

Hope we can figure this out,

Lee

Hi Lee,

You are almost correct! After the splashscreen the program is visible in the taskbar for a split second before disappearing.

Here is mydxdiag file as requested:

DxDiag.txt

I'm using MalwareBytes which would alert me if it closed a program. I tried adding WFTO to it's exceptions list and it hasn't helped.

*EDIT* I've also grabbed a recording of my screen to show you: https://puu.sh/FyIuU/9ae39cab18.mp4

Thanks

Hi Grant,

Thanks for the reply. That's truly quite odd, you're not the only one who's seen this issue recently but we've as yet not been able to isolate the cause. Currently operating on the belief that it's some specific hardware or software configuration. Perhaps systems which also feature Intel Iris GPUs (there's a known issue with our Unity Engine version on OSX with those particular GPUs) However your game seems to boot on the correct one.

Sadly the output log simply ends, there's no indication of a crash. It just stops, as if the process was terminated by something external. As a matter of interest in your video we noted something appeared in the bottom right hand corner of the screen saying "Restoring 19 items". Do you have any idea what that might have been?

Can I also ask you to try launching the game directly via wftogame.exe from the steam folder? Perhaps also try launching it with administrative privileges just in case something strange is happening. 

Finally I'd like to ask if you can check Windows Event Viewer under the Windows > Application tab to see if there's any Application Errors pinged over at that time?

Thanks,

Lee

Hey Lee,

That's the Razer Cortex software (optimises RAM when gaming). I just tried exiting all Razer apps and it didn't make a difference. When I run wftogame.exe (with admin privileges) it looks like nothing happens at all. When I run wfto.exe directly, it's the same as if I launched it through Steam.

Unfortunately there are no error logs to report of either.

Here's a video showcasing all of this: https://puu.sh/FzY15/68a1adb57a.mp4

Cheers

Hi Grant,

Thanks for that. Unfortunately I'm still at a loss on how to proceed, there's been a few more reports and the only common factor that I can see continues to be Intel Iris. You actually have an exceptional case as your system actually has a Nvidia GPU as well and the game does try to boot with that. However the end-result is still the same as those users who only have Intel Iris graphics, leading me to believe the issue still lies somewhere around that.

For the moment there is no clear solution though we are still trying to troubleshoot. With nothing generating a report as to what is actually happening however that's proving to be troublesome.

Can I ask you to try the following for me:

  1. Install all the programs contained in the "_CommonRedist" folder in the WFTO folder. And try launching again.
  2. Ensure your Intel graphics drivers are up to date using Intel's program.
  3. Ensure the Nvidia drivers are up to date using Geforce Experience.
  4. Attempt to run the game in D3D9 mode, D3D10 mode or D3D11 mode by using the launch options for "-force-d3d9", "-force-d3d10" and "-force-d3d11" as detailed here. Do these one at a time and see if anything changes.

I have a meeting with the code team next week to see if we can work out a way forward. So if you can let me know if any of the above work in the meantime that would be excellent.

As before sincere apologies that you're suffering from this issue and thank you for your patience.

Lee

Hi Grant,

I think I forgot to mention 1 more troubleshooting step for you specifcially. Please ensure that any options which allow you to set the Nvidia GPU as your primary are set for WFTO's executables. See How to: Force Dedicated GPU.

Please let us know how you get on. I'd be really interested to know if any of the above help towards resolving the issue at all.

Lee

Hi Lee,

Don't worry, I'm a game developer myself so I understand how these things go. I'll address your suggestions 1 by 1:

  1. That sub-folder isn't present for me (files validated through Steam - nothing's missing)
  2. My graphics driver can't be updated through Intel as it's a custom OEM driver apparently!
  3. They're up to date
  4. None of these worked for me
  5. This didn't work for me (note that 'CoherentUI_Host.exe' isn't present in the install directory for me (ran a search to double-check!)

Hopefully this helps!

Thanks for that Grant,


Frustrating that none of those options are driving us any closer. For the _CommonRedist folder I'm not sure why that might be missing but in that case I can link you the files you need. Just try to give these an install.


Microsoft .Net Framework 4.5.2 Runtime

Direct X Runtimes (June 2010)

Visual C++ Redist 2010

Visual C++ Redist 2012

Visual C++ Redist 2013

Visual C++ Redist 2015

Try installing all of these and then as a last ditch hail mary just try temporarily disabling malware bytes entirely. Just in case the exception didn't cover everything we needed. Beyond that I'm absolutely stumped. For the Intel Drivers I can only imagine your manufacturer may have some of their own drivers that could be updated? But I'm not holding out much hope on that front.

I'm talking to the code team today to see what we can do. So far our conclusion is that we're a bit stuck, this isn't an issue directly with any of our code it's something that happens before any of that starts. Most concerning if this issue is indeed related to Intel Iris graphics and occurs even if you have a dedicated GPU (as in your case) it could mean serious compatibility issues with 10th Generation Intel CPUs.


It may be some time if ever before a fix can be deployed and we may simply have to advise you seek a refund in the meantime. I'll try to have a concrete answer for you by the latest on Wednesday.

Fingers Crossed,

Lee

Hi Grant,

One more thing occurred to me as a potential workaround overnight though I can't say how feasible it is as the tech behind the 10th gen Intels are new to me. If our suspicions are correct that it is indeed related to the integrated graphics we could try disabling that in one of two ways.

  1. We could try disabling the Intel Iris display adaptor in device manager (if present). Then try launching the game again.
  2. If that doesn't seem to make any difference. There'll probably be a bios option to disable integrated graphics entirely.

I have no idea if those options would make a difference. But it seems worth a shot, naturally I'd have to advise you're careful when fiddling with these settings as they can yield some pretty undesirable results.

Thanks,

Lee

P.S. Could I ask you to drop your launcher.log and a new version of the output_log in here for us to see if there's been any changes at all.

Hey Lee,

Apologies for the delay, life just became busier! I've upgraded to an eGPU (ROG Station XG 2 & RTX 2070) so wanted to try again but am still having the same issue - just wanted to let you know in case it helps!

I don't really feel comfortable disabling the display adaptor I'm afraid as I haven't had issues with anything else and don't want to rock the boat.

Just checked and still no launcher or output logs present in the expected places.

Cheers

Accepted

Hi Grant,

Apologies that I didn't get back to you! I was sure that I did but as usual it has been madness here so perhaps I never clicked the post button!

Thanks for keeping us informed, I hadn't considered rolling out an eGPU and it's a shame that it yielded no improvements. On our side we've yet to have opportunity to investigate further as I mentioned previously our code team are all occupied on our main project. I have kept them informed on developments from users and so I am continuing to compile further updates and reports for when we can get another spin on WFTO.

Sorry once more that there's no positive news I can share on this.

Lee

Hey Grant,

I hope you have been keeping well. I wanted to drop in a message as another user has recently reported a similar issue with the same hardware profile. Interestingly this user was able to reach the game on the affected system while it was in Airplane mode. I've yet to confirm this works for other affected users so I thought you might like to give it a go. It's truly a peculiar one as we wouldn't have anticipated a networking issue.

Here's a few steps you can try:

  1. Try launching the game while Steam is in offline mode, on the off-chance it's a steam authentication issue.
  2. If your laptop has an airplane mode try enabling this and launching the game
  3. Try disabling the the network adapter via Windows. First in the networking adapter menu and if that doesn't work then via the device manager. Instructions.

Let us know if any of these work!

Cheers,

Lee