0
Accepted

MyPet Dungeon Progress removed

Darelius 3 years ago updated by Darelius Xurax 6 months ago 12

Like noted here, i will post the bug now (or i try)

https://steamcommunity.com/app/230190/discussions/0/1643169167150982455/

First i estart the game, select Singleplayer, then "Mein Hobby Dungeon" (I have the german version).

Now i will start the first Mission (Deepwater i guess)(easy mode to make the game fast wih 150%)

No Godmode, Mutators standard (never used that, by the way)

Random Theme and workers.

(Picture 1)

Now i finish the game easy with points

(Picture 2)

And there i "could" go to next level

(Picture 3)

Now i close the game and start new, the progress is lost.

(Picture 4)

My Datas:

System: Windows 7 Ultimate 64 Bit

RAM: 16GB

CPU: i5-3570K 3,4GHz

GPU: NVidia Gforce GTX 980

Build: 2.0.7f1

Log-File: Log-File

If the Information is Neccesary, i have 2 HDD and 2 SSD in my PC.

SSD1 - System, HDD1 - Games, SSD2 -Big games (like WftO), HDD2-Backup

Any more information needed?

...DX

Game Version:
Steam Public
Platform:
Windows

Ah, one "wrong" information:

Game restarts, Progress there, after Computer Shutdown - Progress lost!

New Logfile:output_log.txt

That is even more weird!

Under Review

Hi Darelius,

Thanks for submitting the info to us. Looks like one of the images you include is repeated? The final two images appear to be identical.

I'll have a chat with the programmer who knows the most about how MPD handles its saving to see where this could possibly be falling down. Unfortunately, he's on vacation until next week so I'll try to get back to you then.


Cheers,


Lee

As i said, after PC restart its lost not after game restart...

All other Progress (Campaign untold depth or so) is saved.

Pending Customer

Hi Darelius,

Alright I've had a chat with the code team and they're as stumped as I am. The behaviour described doesn't really make sense it sounds like some time between a windows reset the save file is becoming inaccessible or being deleted entirely.

There are a few questions I'd like to ask for our confirmation:

  • Are you playing the game on Steam? This is not a DRM-Free version I.e. GOG?
  • Do you play the game in offline mode or while logged into Steam. WFTO's save games sync to the Steam Cloud so there's one possibility of something happening there but unlikely without it notifying you. And shouldn't trigger on a computer restart rather it always syncs when a game is stopped and started.

With regards to investigating further and assuming you are on Steam can you try the following:

  1. Navigate to WFTOs save folder your Steam User folder (I.e. C:\Program Files\Steam\Userdata\(Your UserID)\230190\remote
  2. Locate the WFTO_Progress file. Right click it and open properties check when it was last modified. (This file saves MPD Progress, Ungergames Progress and Custom Campaign Progress)
  3. Play the game and complete progress for MPD and a Custom Campaign or Undergames Campaign
  4. Check the file's modified date has updated
  5. Copy and Paste the file elsewhere in your PC, multiple places and a different drive minimum ideally. Make sure you leave a copy in the remote folder.
  6. Restart the game and check progress is still present
  7. Restart your PC and check progress. If no longer there, check the modified date on the file again see if it has reverted
  8. Move the copied file back into the remote folder and try again to see if progress is present again.

Let us know how you get on.

Cheers,

Lee

Hello, sorry for taking 3 years. I got work, changed hiome etc and "forgot" that issue and game so far.

I have now Windows 10 and the problem still appears.

1. I have the game on steam,

but installed on another Drive d:\steam

2. I dont play in offline mode and the game "should" save in the steam cloud (i will try to deactivate that and see, if it change anytthing)

So i tersted the path and file, but even after repolacing the file, nothing changes.

Now i try to play without steam cloud saves and will answer then again

...DX

Okay, no change, when steam cloud deactivated :(

Still ewvery new gamestart i have to start on deepwater. The "achievements" of all levels are still there, but the "progress" lost, even if i copy the file.

So, any idea?

So the WFTO_Progress file. Has that been modified since you last launched the game? I.e. Has the game tried to update it?

Can you send me images of your properties for the file. Please black out any personally identifiable information. I'm primarily interested in the Attributes of the file and the permissions your user account has for the file.

I'd also like to ask if your have an Antivirus running and whether there are any reports showing prevented access. Essentially the only reason I can understand why you wouldn't be getting progress is that the game isn't able to access the file. Whether it doesn't have permissions, it's read-only, or it's being blocked by a third-party such as an Anti-virus.

The only other possibility is that Steam is constantly refreshing a broken file from the cloud, but that seems unlikely with it disabled. You could try removing the file entirely and letting the game generate a new file.

WFTO-01-Vor Spielstart.png
WFTO-02-Rechte.png
WFTO-03-Tiefwasser fertig, spiel offen.png
WFTO-04-Tiefwasser fertig, spiel geschlossen.png
WFTO-05-Tiefwasser fertig, spiel neu gestar....png

So, here the screenshots:

First, i deleted and reinstalled the game - all Progress (except MyPetDungeon) are still there.

01 - Before Game Start

02 - File rights

03 - Deepwater ready in summary screen

04 - Game closed

05 - Game started new, deepwater "gone"

The "weird" so far (for me): It writes something in the progress file nearly direct, as i was ready with the dungeon and dont change it later.

I also put the oprogress file in.

WFTO_Progress

By the way, i got the last achievement some days before *happy*

...DX

P.S.

Now i remove the file, delete the cloud save and look, what happens...



...DX

Hell Yea - i found the reasonable files!

In Steam\appcache\stats

I deleted the 2 bin-files

UserGameStats_[steamid]_230190.bin

and

UserGameStatsSchema_[steamid]_230190.bin

Then played deepwater completed, restarted PC new - and it is still there!

So one of those files seems to be corrupted or so and there is the Progress for the "myPetDungeon" ;)

Thanks for help and i hope, this information helps you, too ;;)

...DX

Accepted

That's brilliant I'm happy to hear you found the problem.


We'll make this a KB article at some point in the future to help anyone else who runs into this issue, but it seems quite rare indeed. I think you might have been the only user affected so far :)


Cheers,


Lee

One ofthe file removed the progress of my undergames - i have to play all 28 missions again... *sniff* but now it works fine!

Still showing the MyPetDungeon Progress ;)

...DX

By the way - what is "KB"

Specially following file is for the "Undergames":

UserGameStats_[steamid]_230190.bin

And this file for mypetdungeion:

UserGameStatsSchema_[steamid]_230190.bin


I didnt delete it, i "pascked" it and tested a bin around with them.


So the UserGameStatsSchema_[steamid]_230190.bin file was broken...



...DX