Completed - Resolved

Dig hand active while clicking on UI

walgleaf 4 years ago updated by anonymous 4 years ago 32 1 duplicate

Core information:

OS: Windows

Version: 7

64 Bit

Ram: 4.00 GB

CPU: Intel core i5 CPU @2.27 Gh

GPU: ATI Mobility Radeon HD 5470

WFTO Build: v2.0f9

You know how you can dig out walls? It happens for me even when I'm clicking on the mini map or unit tabs, or room buttons, or anything concerned with the UI.

I have the sneaking suspicion it's because I had to set the launch options under steam -> properties -> Set Launch option and type in "-force-d3d9" I tried "-force-d3d11 but that just black screens after launch, so i'm sticking with -force-d3d9. 

The reason I had to Set Launch Options to "-force-d3d9" was because my screen would black screen after launching WFTO (Which I appreciate for fixing by the way!)

Game Version:
Steam Public

Duplicates 1

I'm a buffoon. here is the out log.


Can you try removing ALL launch options?

I realize I did not reply to this, but when I remove all launch options, I get black screen after the splash screen.

I am having exactly the same problem. This is on a fresh install. Made no changes to any launch options.

Windows 7
4x Intel i706600U @ 2.6Ghz

Build v2.0f9

Any feedback or fix to this issue?

Could you please provide an output log?

Pending Customer

Can you try the steps in this guide please.

Missing, Invisible or Laggy UI

I have applied this. Still does not solve the problem.

I have done a fresh install.

I am using Intel HD graphics 520, if that helps

I ran it initially without launch options. I changed them tested and changed it back. Still same issue. The game runs fine fps wise just this ui glitch . As I stated in my post the 1.6 build GOG worked 100%.

Sorry for posting on some one else's ticket

Pending Customer

Can you both try the steps in this guide Missing, Invisible or Laggy UI

I have tried those steps prior to making my game work. Right now, I've had to set the launch options to -force-d3d9 to help a black screen problem. When I tried downloading the latest drivers my computer would do weird stuff like black screen, or strange resolution that are stretched.

Marked for Review

Hi Walgleaf,

Can you ensure you have the latest Windows version as outlined in this topic: Black Screen on Startup on Linux & Windows (Post 2.0 Update)

I'm marking this topic to receive further review from Cian. :)



There were some new updates, so I went ahead and downloaded those, and restarted computer. Before I launched WFTO, I ran the game without launch options, and was met with a black screen after the splash screen for 15 minutes. Killed the game afterwards.

After that, I ran the game with the launch options “-force-d3d9”. The game proceeded as normal after the splash screen and I was able to get in game where I was actually playing, but digging behind the UI still persisted.

Then, I attempted to start the game with the launch options “-force-d3d11”, with the game going black screen after the splash screen. No response for 15 minutes, so I killed the game.

Oddly enough, every time I attempt to verify the game files, It will try to download a missing file, I believe, but it never does. When I go to verify the game files again, it will try to gather the missing files, again.

An extra note, updating the drives do weird things like stretched resolution or black screen upon starting computer. In that event, I had to start in safe mode and do a system restore. I hope I won’t have to do that, but I can try again if need be.

Pending Customer

What happens if you do a fresh install of both WFTO and Steam

Okay, so I uninstalled WFTO and Steam. I reinstalled them and started the game without launch options. I got a black screen for 15 minutes, so I killed the application. Here is the Outlog for that.


Next I started the game with the launch options "-force-d3d9". It started up normally as it should, but when I get into a map I can still dig walls and earth tiles behind the UI. Here is the outlog for that.


I was not aware at the time, but when I uninstalled steam, all games I had from steam stopped working/could not install in it's original path. If for future reference, this could be a big pester for those that have to re download every game they had. I am a sad walgleaf now :(

Please double check that you have C++ redist 2010,2012,2013,2015. 2015 is the most important one. You can see which ones are installed in Control Panel -> Programs and Features.  You will find all installed Visual C++ Redistributable in your system.

If you are missing any then please go to the "_CommonRedist/vcredist" folder in the game's install directory and install the missing versions.

Yes, I have those. here is a screen shot.

Could you please verify that there is absolutely nothing in your start parameters and then delete your Options.txt file found at C:\Program Files (x86)\Steam\steamapps\common\War For The Overworld\WFTOGame_Data\GameData

By start parameters you mean set launch options? I double checked that, it was clear, and checked the properties of the launch exe, in the install folder, could not find anything that would change parameters, I think.

I did the above, deleted the Options.txt file, and started the game. I was met with a black screen after the splash screen for 20 minutes, so I killed the application.

I'm going on a vacation soon, and I will not have access to a computer. I won't be able to reply for about a week or more, but I will respond back to any help you have to offer for my problem. Thank you.

Under Review

Honestly we are pretty perplexed as to what is causing this issue. We have a similar machine in house, so we will try and find the cause and get back to you.

Enjoy your holiday!

I'm back, had a nice time picking ticks off me. Anyways, I'm ready to try any solutions you have.

Completed - Next Patch

We'll be releasing a big patch very likely next week. I'm going to set this to resolved pending patch release - Please do post back here after the patch if you're still having issues!

Okay, thank you very much. this made me and my niece very happy to hear, since she just loves this dungeon game almost as much as I do.

I hate to be the bearer of bad news, but my situation has not changed. I updated the game to the latest patch, and without launch options my game black screened for an hour after the splash screen.

With the launch options "-force-d3d9" It went as normal loading the game, but I can still dig out earth tiles and walls behind the UI. I also noticed I can pick up units, gold, etc. 

Marked for Review

Hi Walgleaf,

I've marked this for review again as the issue sounds like it's not resolved.



Not Fixable

Hey walgleaf,

I'm really sorry to say that we have run out of options here. Our inhouse machine with similar specs to you ( iGPU only ) is working fine and we cannot replicate the issue. We have also had no other reports of this issue and must assume that it is something very specific on your configuration. 

They only thing that I can think of is to reinstall Windows and install just the latest GPU drivers and WFTO to see if that resolves it. This however has no guarantee of working and is definitely the nuclear option.

I'm terribly sorry that you cannot play WFTO and would strongly recommend that you seek a refund from Steam citing the incompatibility of the game and your system. Alternatively you could attempt to find a different system to play on.

Thank you for all your help, and putting up with my issue. My laptop it 8 years old, it's about time I get it replaced anyway. Thanks again for the continuing support.

Good news everyone! I finally got the game to work as intended, without using "-force-d3d9". Long story short, I used Display Driver Uninstaller (DDU), to clear and clean the driver I had, cleaning all the registries and what not. Reinstalled my old driver, and boom! it works! I figured I'd come back and tell you all just in case you ever have someone with a problem like mine. Noting this, I messed up my computer a lot with that program before fixing it, things like being stuck in safemode, black screening, and other times I messed up and had to system restore after fiddling with DDU.

So thank you for your support, I know you all were pulling your hair out trying to solve my problem.

Completed - Resolved

I'm really happy that you managed to find a solution, hopefully you enjoy the game!