+1
Completed - Resolved

no Audio on Linux (Debian Stable)

Auricularius 4 years ago updated by Lee "Noontide" Moon (Designer & Community Manager) 3 years ago 9

When the game starts it has no Audio at all. Campaign Missions are selectable but when starting those, they are stuck in the first narrative event, as are the Subtitles. Bug occurred after installing HoG. Reinstalling the game did not fix the error. Other games in my Steam-Debian-Library - like Dungeons II - work still normally, so an Audioerror on the OS-side seems unlikely.

Player.log

Game Version:
Steam Public
Platform:
Linux
Under Review

Hello Auricularius,


im sorry to hear of your troubles, sadly we currently do not have a linux tester in our team currently so i will give this straight to the coders. Im sorry for the inconvenience

Pending Customer

Hello Auricularius,
your Player.log does not look good at all.
It seems multiple libraries are missing and thus fail to load (at least for User Interface and Game Logic).
Did you already try to "Verify your Steam Cache" as explained here:
https://brightrockgames.userecho.com/topics/1094-general-crash-troubleshooting/
I hope does make sure the missing libraries are present in the game folder.
Let us know if it worked


Good morning Mr. Fear,

when the Error first came up, after installing HoG, I assumed it might have been because the Patch corrupted the Game Data and therefore did not bother to check for the integrity of the local Data but instead uninstalled and reinstalled the Game as a hole.

After your Reply I did as suggested in the Troubleshooting Section: I verified my Steam Cache; one File was found to be faulty and was replaced, afterwards I started the Game and there was no Audio.

In Accordance with the Toubleshootingguide I continued to once again delete the local Game Data and reinstalled the Game -- just to be sure I verified my Steam Cache directly afterwards, and guess what, one File was found to be faulty and was replaced -- and after I started the Game there was no Audio.

So I went on Checking the Player.log and the same Libraries, which could not be found beforehand, still cannot be found.

After I navigated into the respective Folder "~.local/share/Steam/SteamApps/common/War For The Overworld/WFTO_Data/" I found out why; the only two Files being there are: Hotkeys.ini & libudev.so.0.

So for some Reason, even after a full Newinstallation, neither the DLL's nor the the Share-Object-Files are to be found there, yet the Game-GUI seems to work fine, as does the Rest of the Game -- Audioissue aside.


-- I do have a Passion for Compoundwords --

Can you provide an up to date Player.log for review?

To create you an up to Date Player.log, I went and deleted the old one and then started WFTO, just to realize, that it does not create a Player.log anymore under the Path of: "~/.config/unity3d/Subterranean Games/War For The Overworld/" or any of its Subfolders.

The only Log I was able to determine to still be created was the WFTO-Debug-Log forced by the Standard-Startingparameter: "-logfile ${HOME}/wfto-debug.log"

And here it is. wfto-debug.log

I started WFTO several Times, started Steam new in between and but no Player.log was wirtten. Before Patch 1.4 this definitely worked as I remember deleting the Player.log several times to watch what had changed after each Patch.

There are quite a few abnormal errors in the log, however none pertaining to audio. Unfortunately that means I cannot provide much further assistance - The 3D engine we're using is Unity3D and whilst its Linux support is okay, it also isn't the best.


The only advice I can offer at this point is to try a few different audio driver versions and having a google on any users who have had similar issues with the Unity3D engine.


Sorry. :/

Completed - Resolved

I'm going to close this down, but please let us know if you had any luck finding a solution. If you came across anything specific then it'd be good to hear about it and perhaps add it to our database of workarounds for other affected Linux users!