0
Completed - Resolved

Shifting blood ritual in level 5 still stays 0% after patch 1.3

amirfoox 5 years ago updated by Cian Noonan (Graphics Plumber) 3 years ago 38

As the title says: casting the blood ritual in the sanctuary in level 5 doesn't move and remains at 0%. Restarting the game doesn't help. Old bugs that persists even after patch 1.3.


Thank you.

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by amirfoox 5 years ago

Build: 1.3.2f3 (also attempted installing version 1.2 - still no luck)

RAM: 16GB DDR4

CPU: i7-5820K

GPU: GeForce GTX 980

Windows 10, fully updated.


Drivers are regularly updated as well.


I have tried restarting the level, following advice on old forum threads about handling the first wave of dwarves first and made sure my cultists have all their needs fulfilled and all geared for worship, still stuck at 0%.


My dxdiag.txt file is attached. dxdiag


I actually tried to replicate this on the internal build, but the issue does not occur for me here.


Interestingly, there actually seem to be two "first waves" - the first one (two sappers, one templar) when the mentor urges you to use the Quickfreeze potion on them, and a second one (two sappers, one templar) after the Crackpot is introduced.

I tried handling the first wave, the second wave, went over everything I could think of - the issue persists. I wonder what's so different between my version and yours, it's frustrating.

At this point I would settle for a simple savegame that starts at level 6 and be done with it.

Declined

im sorry we cannot provide you with save games.


i will have to decline this issue as we cannot reproduce it. Sorry

Then this means that I bought a malfunctioning product and I demand a refund. I expect someone to deal this, I will not just vanish quietly about this

No, it means that you've bought a product which functions fine for everyone else and have found a way to make it to break it which we cannot reproduce. Unless you can give us clear instructions on how we can reproduce the issue we can't fix it.


We've even gone as far as playing the level with Fog of War disabled in order to check that no enemies are getting lost or anything. Since we're able to play and complete the level just fine (by following the objectives and killing the enemies as intended), my personal guess is that you didn't follow the objective chain correctly, or that an enemy got lost somewhere meaning the next objective which starts the ritual's progressing is never activated.


I'd suggest you try and fresh start of the level, (not loading a save game) and play through, following the objectives to the letter and seeing if that gets you through, if not then see if you can find us some reproduction steps to re-create the issue.


But without something more concrete than guesswork there isn't anything we can do to help i'm afraid.


Right, because my version is somehow different than everyone else's? Look, this isn't a crash or a graphical glitch which might indicate an issue with my OS or PC. This is not due to any sort of corrupted file either, thanks to Steam's consistency verification check for games installations.


This is a clear gameplay bug.


Which oh-so-complicated objective chain didn't I follow, the "kill the dwarves", followed by the the "activate the ritual by clicking the icon" one, or vice versa?


I already tried restarting the level. Multiple times. With the exact same results each time.


Please at least try to find ways to help, other than blaming it on the stupid user and closing the bug as a 'DECLINED' in my face.


Thanks.


+1

No, that's my point your version is exactly the same as everyone elses and it's working fine for everyone else. Which means it must be an outside factor, namely the input actions of the user causing the issue. I'm not saying that you don't know how to follow the objectives, but maybe something else you're doing at the same time is causing problems.


As an example:


Perhaps you're putting up a replacement wall or a defense or something and that's blocking the Dwarves from all pathing to your dungeon correctly and leaving one lost somewhere and therefore never letting you proceed to the next objective?


We don't know and we can't tell, and without that kind of information there is very little (if anything we can do). It's not that we don't have to help you, there just isn't anything we can actually do to help without more info and a way to reproduce the issue.


It does appear however that Klaus (Bohser) is willing to spend some time trying to resolve the issue with you 1 on 1, so my suggestion is that you take up his kind offer and he might be able to figure out what's going wrong.

+1

I also tired to replicate this bug in patch 1.3.2 and in the internal (multible times)
Still we are thankfull that you reported that bug.

I can offer you my personal help, to "guide" you through and look what you do, perhaps I see something what you missed to mention.
You could stream it via Twitch or Steam, I can take a look at it, if you want? Just add me via Steam: Pofil

Thank you, that is exactly the type of help I was talking about.


If you would just offer something like that, or even a video upload from me show the issue, ANYTHING other than the: "Can't reproduce, too bad, BYE!!" I received, I would have never posted those kind of replies.


I apologize.


Thanks Klaus, I will add you as soon as I get home from work today and hopefully you might help me figure this out.

+2

No need to apologise, I can understand why you're frustrated I really can.


And I really hope that a video of the problem will resolve it, that's what we were really asking for when asking for reproduction steps, somewhere that clearly shows what you're doing compared to everyone else (assuming you are doing something differently) so we can identify the problem. We can't solve this by guesswork, we already tried. Which is pretty frustrating for us, knowing you're not happy and there seems to not really bw anything we can do about it if we can't see the same issue ourselves.


Hopefully between the two of you and Klaus, it'll get figured out, but with the QA Team being so small, we have to split our limited time as efficiently as possible, and we have to chose between a bug which we can reproduce and fix, and one we can't reproduce (and therefore can't do anything about), it's gotta be the first bug. It's not that won't don't want to help you, we do.. we want to help everyone with issues, but when those issues are something the QA team can't do anything about.. well that's just the way it is...


Anyway I hope you and Klaus manage to get it sorted :)

@QA Team This should be marked again as "Under Review"

For what it's worth I've just tried to replicate this 8 times, I'm not sure where the cause could be.

ok, I'm available now to test this. I'll restart the level again and see if the issue persists.

But of course - as soon as you go to the mechanic, the car works flawlessly... :p


Once Klaus witnessed the game, the blood ritual worked just fine. Thank you so much for your efforts, patience and time! Keep up the good work :D

So I spent a few more hours on this today. Here are my findings:


Saving and Loading can cause Mightyquest to fall over on C5 for as yet undiscovered reasons. I created 3 saves at different points of the game which each had different effects on the Mightyquest progression when loaded.


1. Save 2 & 3 - Created post-crackpot introduction - Second wave spawns as normal but upon death the ritual does not progress despite the normal VO playing.

2. Save 1 - Created before first wave - All waves spawn as normal but results are as above, ritual does not progress, VO plays as normal.

3. Save 4 - Created immediately after level start - Upn capturing Rhaskos' core his Dungeon does not change ownership, however all other Mightyquest events progress as normal including the ritual.


I was not able to restart the level via the pause menu after the ritual progress was broken. Restarting the level from the campaign menu fixed the issue.


In addition, depending on certain positions of units in the world it can cause delays to the attack waves. E.g. One time after wave 2 spawned they met an oculus in the river at the centre, after killing the oculus the Templar continued on into the Dungeon but the sappers decided to go and mine out 2 random walls in the Empire Dungeon.


Interestingly after mining out that wall they returned to their normal path but on death did not trigger the VO or the ritual progression.


This suggests there is something else that cause this issue but I couldn't replicate that reliably.


Save files were reliable to replicate.


@Amirfoox - When you were suffering from this issue did you load any save games at all?

Accepted

while we certainly would love to get an answer from you Amirfoox the issue clearly exists and has been reproduced. im going to export it

The issue indeed exists and I was able to just reproduce it again:


I think the main issue is when the game asked me to start the ritual, I immediately grabbed the single cultist I had and dropped it on the sanctuary before the dwarves even appear. This caused the spell to get stuck at 0%.


Lee, it happens regardless of loading a saved game or starting the level from scratch.

I'm going to be leaving the office in a moment. But I'll ask the QA team to look into whether doing what you did causes the same issue. I'll also look into it personally tomorrow.


If you can provide exact details on what you do on the level as you progress that might be helpful, one of the issues is that it might be something very specific that you wouldn't consider unusual but not many other players do.


I tried a couple of unique ones that I could think of:

  • Killing enemies only with spells
  • Delaying enemies with Quick Freeze c onstantly
  • Possession kills

I suspected it might be the case that you were suffering from it regardless of starting fresh or loading. Just wanted to confirm.

When it first happened and I tried to fix it to get over this level I didn't do anything at all and just waited for the imps to finish, closed the dungeon gaps with 'replacement earth' as instructed, activated the spell and dropped the cultist on the sanctuary, nothing else.


I did it just now and reproduced it a second time in a row.

really strange, it took a few minutes (i had 3 cultists by then) and obey unitl i reached 1% of the progress for the ritual. can you try again, and use the speed settings and set them to 150% ? this should cut down the time.


im sorry that you have to help out so much, but how you describe it its still not reproducable on our side

No problem at all :)


Just reproduced it a third time. Klas is still in my Steam friends' list (I think), so I can show it to him again now.

+1

OK, Klas pointed out that the ritual starts after 6:30-7:00 minutes, and I could not reproduce this bug with him, but I loaded up a previous save game, and it was reproduced. Cancelling the ritual and starting back again didn't help as well.


However, Klas pointed out that the issue was most likely triggered this time by loading up the savegame, but I could indeed reproduce it all the time to a point where I could not progress at all after about 5-6 attempts (I once cleared the entire level, which definitely took more than 7 minutes and the ritual remained at 0%.)


However, now it doesn't reproduce so often, if at all, which is weird.

I just bought this game today, and had this exact bug reported in 2015 happen. Cannot finish this level as the spell is stuck at 0%. Very dissapointing.

Pending Customer

Hey Mike,


I'm really sorry that you are experiencing this issue.


Call you recall anything specific that happened while you were playing related to the ritual?


Did you have Cultists working in the Sanctuary?


Did you save the game before starting to channel the ritual?

Bought this game about a week ago and ran into the same problem (patch 1.5). Started the level and didn't pay much attention to the ritual. I destroyed all the gates and cleared the level of all enemies. Now I need to finish the ritual to complete the level and it's stuck at 0%. This is really frustrating since it took me a lot of time to clear the level.


I managed to reproduce the bug 2 times by saving and loading before the ritual gained 1%.


  • One cultist was channeling.
  • I didn't use the freeze potion.
  • The cutscene with the Crakckpot entering the dungeon hasn't played yet (I think). It plays after load when a second crackpot enters (one Crackpot is already present).
  • From the group that spawns after the ritual is initiated, some enemies were killed by a cannon and some were zapped.
  • Seems to work fine if there is no save/load.

Is there a workaround or do I need to restart?


If the save/load is causing the bug, then it is very easy to stumble upon it, since it's a good place to save when the player gets his/her control back.

Sounds like you broke the game's scripting by not using the freeze potion, to me atleast. If the game script has broken then it will require a restart (and properly completing objectives in order) to get past it without the same problem.

Just checking to confirm, have either of you been able to progress past this level?

After restarting the level, I was able to finish it. I didn't reload from a save.

Completed - Resolved

After testing on the latest build of the game I am unable to replicate the issue. We made significant changes to the scripting on this map that should prevent this from happening.


I will mark this as complete for now, if anyone experiences this same issue again then reply here and we can look further.

I just ran into this issue. No idea what triggered it, but all other objectives are complete. In the sanctuary it says the ritual is channeling, cultists are present but is stays at 0%


Would a save game of the broken state help?

Pending Customer

Hey ZeroPointEnergy,


I'm sorry you're having this issue, we aren't really sure of the cause. A broken save game would be great.

On the second attempt it all worked but I notices it started right after I used the grouping feature, which I know I ignored in the first attempt because he started to talk about it during an attack with me being completely busy fortifying the dungeon. Will try to verify that.


Here is the savegame. Not sure if something else is needed:

5 the rear guard_20170604013922
5 the rear guard_20170604013922.meta

Completed - Resolved

So we aren't exactly sure what's causing this at the moment but we have some solutions for you, first of all I have linked a copy of your save file with the ritual complete, simply load it and you should be able to finish the level. 


5 the rear guard_20170605170823.meta 

5 the rear guard_20170605170823


Alternatively load C5 and open the debug console by pressing "Scroll Lock" and then type "winlevel".


Let us know if neither of those work for you, and sorry again that you experienced this.