0
Cannot Replicate

mission after tutorial mission softlocked at the start.

Steve Bunn 1 year ago updated by Lee "Noontide" Moon (Designer & Community Manager) 1 year ago 3

System/Version/Bit: Windows 10 64 bit

Ram: 12.0 GB

CPU: Intel Core i7-5500U @ 2.40 GHz 

GPU:Intel Graphics 5500/Geforce 840m

Output Log: output_log.txt

I restarted the campaign and completed the tutorial mission. After that I entered the second mission, but when loaded the UI did not appear,nor did any workers spawn. However I still could control my cursor and move the camera with said cursor ( I didn't test moving the camera with the hotkeys or tagging earth blocks to mine.)

Game Version:
Steam Public
Platform:
Windows
Pending Customer

Hi Steve,

Thanks for dropping in your log it does certainly seem to be pointing to something quite peculiar happening. There's a massive number of null references which looks like for some reason a game object has gone missing. 

I tried to duplicate the issue following your instructions but the level worked as intended for me. That leaves it a little difficult to debug. My guess is the UI exploded and this caused a whole bunch of things to break in sequence.

There's a few questions I'd like to ask:

  1. Have you played the game before on prior versions?
  2. When was the last time before this that you played?
  3. Did the UI disappear prior to loading the level? Presumably it was visible on the campaign map.
  4. Did you see a load screen at all?
  5. Did you try restarting the level or the game and then trying again to play the level?

A few steps you can take:

  1. If you've not done 5, just try launching the level now, see if the same issue occurs
  2. If it does occur consistently, try refreshing the Steam cache and try again
  3. If the problem persists try reinstalling the game and try again.

Let me know if any of these work.

Cheers,

Lee

Thank you for the reply.As for the questions:

1. I have only played the latest version.

2.I think 3, maybe 4 days ago.

3.The UI was fine on the campaign map.

4.I can't recall if I saw the loading screen or not.Sorry!

5.I couldn't restart or exit cause of the lack of UI and unusable hotkeys. I was forced to close via Alt + F4.

As a update I tried playing the mission this morning and everything ran without issue, so I think this may be a uncommon thing. If I run into it again I shall let you know.

Cannot Replicate

Alright, pleased to hear the game ran fine on your second attempt. Definitely possible that there's a intermittent issue that you triggered.

If you ever have any more info for us on what was happening prior to the issue it'd be great to hear. I'll close the ticket for now. :)