0
Backlog

unidentified artifact

jirisimek18 3 måneder siden opdateret af Lee "Noontide" Moon (Designer & Community Manager) 2 måneder siden 5

Hello,  
trying to create a map with random artifact spawning in regular intervals,
but they remain unidentified even after all the process in the archive.
In the god mode, if I put unidentified artifact in the game, it gets identified as normal.

Hope this can get resolved

Jiri Simek

Game Version:
Steam Public
Platform:
Windows
Pending Customer

Hi Jiri,

In the Map Editor there are two versions of Unidentified Artefacts. One which is used as a script trigger and one which is a regular unidentified and randomly weighted artefact.

Can you confirm for me that you are spawning the right version of the artefact? Try spawning both versions and seeing if there is a difference between their behaviours.


Otherwise can you please provide screenshots for your script so I can see how to replicate the behaviour.


Cheers,


Lee

Hello Lee "Noontide" Moon, 
yes, I am pretty sure. Tried it once more just to be 100% sure.


Tried to make more screenshots in every variant I could

Screenshots

1 in Editor What I am using (greens)

2 as in script editor

3 spawned in god mode (greens)

4 via god mod after process

5 these are spawned via script with a timer

6 scrip spawned after process

7 script spawned orange artefacts

8 god mode spawned orange ones

these were taken in Editor (export and test), but on normal playthrough, it works the same.

Also, If I put for example Artifact of workers to the script, it also works as it should.

Backlog

Thanks for the comprehensive input. I'll put this into our queue to review next time we do a maintenance pass on WFTO.

Kundesupport af UserEcho