0
Backlog

Crash on save file load

FlyingWizard 3 ай бұрын updated by Lee "Noontide" Moon (Designer & Community Manager) 1 апта бұрын 7

This all started when the game started being really choppy.  I started the campaign mission Lambs to the Slaughter, and I started using Prophecy to scout the map.  About 3 minutes in the game became unplayably laggy, and so I saved the game and tried to load, hoping that would fix it.  Upon load, the game crashed.  Before it crashed, the game caused both of my monitors to flicker off upon which it resized itself big enough to fill my second monitor (the game is supposed to be set to windowed mode at 1920x1080 resolution, and my second monitor's resolution is set to 2560x1440). After I clicked okay on the crash report hidden behind the game, I waited for steam to finish closing the game, then tried to start it again.  When it was loading, it was again filling the screen of my second monitor.  After waiting for a while, the game still was a white screen, so I gave up and closed it. Again, when I tried to start it again, it was filling my second monitor, then after a short time it shrinked back to the normal size.  However, the choppiness still won't go away while the game is focused (it shows fine when it is not the focused window), and whenever I try to load the save file I made, the previous things I mentioned about the expanding game window and crashing repeat themselves.

Game Version:
Platform:

crash.dmp

error.log

output_log.txt

Here are the files for the first crash.

I'm running on latest game and windows 10 build, i7-4790 CPU, Nvidia 970M, and 16GB of RAM

Oh, and I said the game is supposed to be windowed mode at 1920x1080, but it doesn't seem to be that large of a resolution (I tried adjusting it and it reacted normally so either I'm losing it or they're all a bit smaller than advertised)
Edit: here's the save files in case they matter, but I don't suspect it has anything to do with the file itself ....9 belmorne's pass lambs to the slaughter_20190820193444
9 belmorne's pass lambs to the slaughter....meta


+1
Pending Customer

Hi FlyingWizard,

Sorry to hear you've had problems with the game. I've had a quick glance over the log you've included and it looks quite interesting indeed.The report is filled with a number of D3D errors which confirm some level of graphical error. The experience you describe with your monitor sounds like it might have caused a GPU Driver crash and a device reset by the Nvidia software.

Unfortunately our team is extremely busy at the moment and I don't think we'll be able to investigate the save file itself until next week. But in the meantime can you confirm your graphics drivers are fully updated?

Cheers,

Lee

Greetings Lee!

Yes, my drivers were and are up to date.  I had this problem several days before where the game would stutter, but by fiddling around with the window I was able to snap it out of it.  Now, if you also use Nvidia, you might notice that soon after I posted this, a new graphics driver became available, which I installed.  After restarting my computer post-update, I was able to load the file properly and haven't had any more issues.  However, given the intermittency of the issue I rather doubt this new driver is the cause of the fix and that it may happen again with some variation thereof in the future. I can't say that with any certainty though--just a bad hunch.

Thanks for the error log interpretation.  Now this laptop is several years old, but as you'll notice the specs are still decent, so my money is either on my laptop's interaction with my external monitor (I have it setup to use g-sync, but supposedly my laptop's model is incapable of using g-sync.  Despite this, after looking around, I'm told that if I can find the g-sync option to turn it on in my driver settings that I am able to use it if I decide to try and turn it on--that it wouldn't show up if I couldn't), or the game has some sort of quirk with my rig or the last driver I was on.  Hopefully it's just option #3... I'll continue to play and see if anything like this happens again and will post more logs if it does.

Under review

Please keep us informed FlyingWizard. I'm glad to hear the new driver seemingly resolved the issue but if you encounter another crash then please upload a new log and save files here.

I'll put this into our triage queue to review with our next pass for WFTO. As the crash is no longer occurring and there have been no other reports this issue is no longer considered urgent.

Cheers,

Lee

I started the game one day (today) and it took a while to start loading (as usual), and windows thought it was frozen for a while (as usual) and then it finally woke up and showed me the loading bar which slowly and sporadically filled some (as usual), then it hung for a while and then the graphics driver crash happened again.  Here's a new set of logs for you.
I'm still hoping this is an easy fix, like "don't try and move the window while it's loading" or "don't repeatedly alt-tab back and forth to it while it's loading" or something stupid like that. It seems like after it crashes once, it will keep crashing until I restart my PC (note that I actually haven't restarted it yet, but I'm assuming it'll work fine after a reboot).   I also wonder if not performing a warm or cold boot for a while makes this (more likely to) trigger.

crash.dmp
output_log.txt
error.log

Thanks for the report FlyingWizard and sorry to hear you're still suffering from the issue. Unfortunately as far as we can tell this is still isolated to your system which suggests there may be a hardware or software issue at play.

That said I can certainly advise that not interacting with the game while it is loading is generally a good idea. WFTO is pretty hefty at load time as you're aware and it can easily be disrupted. I'll be keeping this ticket open and in our backlog for review in the next triage pass to see if there's any way we can make this more robust.