+2
Completed - Resolved

Game will not start level, just revolves around dungeon core (or 1st objective), no speech, no UI, no nothing.

Pete 3 years ago updated 3 years ago 12

I hate to repeat myself, so please look here:

http://steamcommunity.com/app/230190/discussions/0/357284767252204035/

Fix is included after the angry ramblings.

Game Version:
Steam Public
Platform:
Windows
Pending Customer

Hello Pete


i have some trouble understanding your issue in the thread, did you solve it now or not?


With regards to the bug report if you can submit as much detail as you can to User Echo that would help us greatly. (Even if it's copy paste) Upload any files as well (such as the output log).


you can easily post a new message with these details after this as you can not edit your message, thanks.

+1

Hello - every time I visit this page, it seems to use a different profile. I find no way to log back in as my previous ID.
At lunchtime, it was my vk.com profile and now it is G+ - last night was gravatar. Idk what that's about.

Replying quickly, as I have just received email notification:

If you would please be patient, I have been working today and will probably be working for another 14-16 hours, joy of life (pls kill me) and will find time to submit a "proper" bug report, attach files req. files, and maybe able to attach video of the bug - along with whatever else you require - when I am back at home, fed and rested.

Short reply - yes, I've found a workaround solution (restarting the game).
No, it's not fixed (it can be reproduced on my system).
C) there's apparently some other issue that is causing the logfile to fill with 17 pages of the same error message, that gets worse the longer I play the game.

I was very tired when writing that thread, and I am very tired now. Probably will be when I make the next post. Lots of incoherent typing.
I will update with all those files and things and a structured, coherent response when I am able (within next 24 hours) - thanks for your reply, Jan-Eric - it is not possible to prioritise higher at this moment, my apologies.

Thanks again,
Regards,
Pete

hah oh boy, indeed Joy of life.


dw. Peter Austin we also know that one joy pretty well, take your time with the responses i will try to prioritise it on my end at least as soon as i have enough data :)

New Bug Report
WFTO v1.3.2f3
04/05/16



Reading time, sans links: ~3-4mins
Video time: ~16mins



//Attachment won't upload (8.33mb) - I'll keep trying but I have no patience right now.
output_log.txt

Ah, there it is.

;-----



Please find attached the output_log.txt, and in appendix: a link to an older output_log.txt (hosted at dropbox, from the 2nd/3rd time this happened), a link to my system specs (verified at cpu-Z) and a link to a youtube video of me reproducing the bug (boring, I know... but a picture tells a thousand words and that's 30 pictures a second for roughly 16 minutes, which would equate to around 28800ish words - it saves a lot of words to just show you, as this report is about 800 words in total).



//Don't judge the playstyle - usually I like to spend hours on each mission, savouring every moment and doing as much as possible, leading my own warbands in 1st person, etc... - lately I have been trying to get the speed achievements without cheating or speeding up the gameplay past 101% (which I assume must be the default, as the game is a new install).

// Unrelated Btw - El "Mira mi poder" logro ("look at my power", bueno - nice pun, take cookie, achievement writer) "lvl 11 in 10 mins" & "don't lose more than 3 minions" achievement is very difficult to attain.

//I'm assuming "Mondrian" is a clue to use straight lines / division to destroy Mira... Or perhaps the clue is more cryptic, and lies with the formation of "De Stijl" during Belgium's isolation during WW1, whereby you must build an impenetrable wall around your own territory and sequester yourself until the time is right to unleash your army, composed of only the most basic units in the most solid quantities you can muster..? Hardly makes sense, considering you have only 10 mins to do this... Therefore, I'm more likely to believe the achievement is called "Mondrian" due to his "art of destruction" vis. abstraction in art, or the straight line, layman's interpretation.

//My apologies, I digress - with typing speed 94wpm - "those that don't ramble rarely go further than they need", is my defence (quote, Peter Austin, 2016) - I put all this first because it's customary to have a bit of small talk before getting to the business, no? I'm a self-indulgent soul and, now you've paid the piper with your wasted time, let's dance our merry way into the crux, then:




;------



Issue:



Completing mission 3 without following all quest goals except those required to complete level (ie, unlock Foundry, but ignore "place impasse", thereby never triggering, "place traps here", etc...) will cause any new level loaded that contains Quest to not start correctly. The result is that the camera pans around and around the Dungeon Core or first camera waypoint or wherever, with no UI, cursor or activity.



Pressing Esc will bring up menu, allowing save and load, quit, etc...
Saving the game and reloading does not allow any further "great progress underlord!".
Additional info and my "Workaround" is listed further down the page.



//Considering that there are two achievements that encourage celeritous play on this level, one for time (impatience is a virtue) and one for defeating the level before the 3rd wave of enemies is spawned (burned face man), I'm surprised no-one has run into it before. Perhaps it is specific to my system. Oh, burned face man is for level 2. Well - that level has no problems. You can see my "great progress, underlord" is halted after level 3 [in the linked video].




;-----



Additional:



Sandbox, "my homerealm" and skirmish all work fine - anything without a quest will work fine after the bug is triggered, suggesting it is the quest-giving that goes FUBAR.



Since first triggering this bug - the longer any game continues, the more and more UI / game lag is experienced (yes, I have tried the workarounds listed from the game's main page and steam forums).



Game has been freshly install since encountering bug. Campaign progress has been reset (bug can be reproduced), save files deleted. I've not removed game and then scoured registry and filesystem for trace, due to inclination and constraint of time.
Graphics options have been changed up and down and back again.



I believe the problem lies in the way that the play, avoiding completion of "required tutorial objectives" that do not impede progress, such as "unlock the foundy" does, has broken the quest-giving completely for current game instance.
Perhaps the game wasn't expecting me to do what I did, and so isn't prepared to handle it.




;-----



Workaround:



The only way to "fix" this bug is to restart the game after a level.
The "exit to desktop", however does not exit the game and merely crashes it, requiring task manager process [del] and/or patience until windows decides the programme is no longer responding.
However, as previously mentioned, since encountering this bug, UI lag will increase exponentially the longer the game is played, even after restart.



You can see this in the video, whenever the cursor/hand shakes side-to-side violently, or flies off-screen, suddenly dragging the view away from intended position.




;-----



External links:



1. Old "output_log.txt": https://www.dropbox.com/s/mscc0tqvrd837ig/output_log.txt?dl=0
2. System Spec: http://valid.x86.fr/b55uuv
3. Youtube video of recreating bug (annotated, with time-points, in youtube description if you can be bothered to click the button to watch there):

dials up to 720, bug starts around 10 mins, rest of it is just getting there and showing what can and can't be done after it happens.


;-----



Thanks for the time and for reading all the crust caked in with the meat - if you require any more information, please ask and I will do my best to reply and provide it, if and when I am able.



Kind regards,



Pete

+2
Accepted

incredibly well done report, i did not expect this detail.

this part would have been sufficient:


"Completing mission 3 without following all quest goals except those required to complete level (ie, unlock Foundry, but ignore "place impasse", thereby never triggering, "place traps here", etc...) will cause any new level loaded that contains Quest to not start correctly. The result is that the camera pans around and around the Dungeon Core or first camera waypoint or wherever, with no UI, cursor or activity.


well, this means i can easily send this further without any qualms.

thank you for your report and time.


im gathering from your posts that you are a hard working man, but with a report like this i can see that you would be perfect for QA work.

Just to tip my head my head in respect.

I understand that the meat of the matter was all that was needed but - I was bored...

Thanks for the kind words - I'll reference them in the event I ever end up over there.

You're welcome, and thanks again.


As an update, If you unlock, but do not build a foundry, and simply use a lot of Gnarlings - the game does not break BUT - the dev console reports that, even though it took me over 20 mins (because I'm into mining out all the dirt on the map, and selling all the rooms at the end now, to leave total desolation) - I got the speedrun achievement for finishing in under 13 mins:

(cleared PW).


Additionally, the enemy character now says his things like, "they're all dead?!" and "this time attack from the North AND the South!", actually launches his attacks upon saying, "they're all dead?!" after the gnarlings destroy the first room of enemies (which he doesn't if you have built a foundry but not laid an impasse), and the quests are no longer broken on subsequent levels.

I did however use possession in this run, and led the warband myself, which I am not sure a lot of players do - will try again with fresh instance and no possession / warband, and building foundry.

AND I gained enough sin for the "unlock the blade lotus" nag to start, which locks out all panels.
It is still possible to beat the level with 25 workers, 2 gnarlings, an archivist and a chunder, even if you can't cast spells or build rooms (is this the only difficulty the campaign has, really..?).

Once you reach this point, even though you can beat the level - it would be difficult for most people to continue (from frustration or skill, or because they are compelled to follow orders, or whatever - I know I sure did exactly what I was told the first time I played this level...) with being "locked out" until they complied with the "build lotus" order.

At one point, a kO'd gnarling fell through the floor and was lost to the cause.

//oh, I should also meniton that it took 20 mins I was messing with a memory editor at the time, trying to help a guy who didn't want mouse-panning active because he has three monitors (I failed - it disables all panning, not just from the mouse). The solution to that problem is simply to use 3rd party mouse-lock software to clip the cursor to one screen, or reconfigure the screens into a diagonal, rather than side by side. Idk if that had anything to do with the achievement unlock - I won't touch the game process again, promise.

+1

I have isolated the breaking point to the quest, "wait for your cultists to research you a new sin". That's where the logic fails.

You can totally ignore building a foundry, you just have to unlock it.
You can ignore the impasse, and you can ignore the lockout-nag, "build a blade lotus".

The game works fine if any of these quests are ignored.

You may notice in the video, that I pull the archivists away to battle as soon as they have discovered the artefact, and before they have researched a new sin.

Without the sin to spend on unlocking the blade lotus, the nagging "blade lotus" lock is never engaged.

The game breaks.

The most simple fix I can think of, to defeat irrational minds such as myself who refuse to follow instruction when they've done it a billion times already - would be to just give the player a sin point to unlock the blade lotus for free (like with the foundry), thereby circumventing this "wait for your archivists to research a sin" issue entirely.

Seem's that step proves to be a tad chaotic for your game's logic - players are unpredicable beasts.

http://steamcommunity.com/sharedfiles/filedetails/?id=680941319
Still falling thru the floor sometimes - usually if they are KO and the animation puts them thru a wall.

hah - after watching the beating heart of the dungeon revolve for a few minutes and coming to the conclusions I did in the previous post - I alt-tabbed from the game, to write said post, then back in - it is fixed and working :)

Didn't need to open debug console, didn't need to toggle mightyquest or restart or anything.

Simple alt-tab...







Just swung by to hammer the thumbs up nail into that bug's coffin.

For some reason, I'm someone else again :/

Nice one fixing it!

oh yeah! I used your comment as a reference in a couple of job applications to Ubisoft and Rockstar for testing last week.
No idea what SCRUM is so Ubisoft said, no thanks - doubt Rockstar will write back (It's Edinburgh anyway).

Guess I'm consigned to continuing my lowly existence playing games for fun, rather than profit :`(