+1
Backlog

Game crashes when try to play custom campaigns.

PKCrafty 10 months ago updated by Lee "Noontide" Moon (Designer & Community Manager) 1 month ago 8

CPU: i5 6600K

GPU: Aorus 1080 GTX

RAM: 16gb DDR4

Build version: 2.0.6f2

output_log.txt

Everytime I go into Single player, then click Custom Campaign, my game freezes, and locks up my desktop. Then i get an error from windows saying that the application has stopped working. I have tried reinstalling WftO, restarting my PC, verifying game cache, testing it on a different PC, and none have solved the problem.

Game Version:
Steam Public
Platform:
Windows
Pending Customer

Hi PKCrafty,

Sorry to hear you're suffering from an issue with WFTO and thanks for supplying your specs and output log.

To best help you I wonder if I could ask you to provide specs and a log from your other PC if it is suffering from the same issue and could you also confirm the following:

  • What campaigns you're subscribed to on the workshop
  • All other items you're subscribed to
  • If you leave the game for a short while after clicking custom campaign does this issue still occur (may be loading but windows kills it because it thinks its not responding)
  • Do you have any of your own custom maps?

I've had a look at the output log you provided and it seems to indicate there is a duplicate map present and at that point, it seems to just end. It'd be very odd for you to have two instances of a unique map installed and this may very well be the cause.

Perhaps after providing us the details above you can try identifying the offending map "mapinfo.heroes_of_the_past.76561198284790003" and unsubscribing from it, possibly followed by removing any remaining files from your workshop downloads folder.

Once you get back to us we'll follow up when we can. I will be away for the next few weeks but I've asked my colleague to keep an eye on these tickets.


Hope we can get you running again,


Lee

+1

The custom campaigns I'm subscribed to are: The original UnderLord - DK1 Remake, Dungeon Keeper 2 - tribute, True Mystical Journey., Rise of Overseers. Dark Crusade Enhanced Edition., and Inhibitors Must Fall. I'm also subscribed to 431 maps, so I will not be listing each one of those individually as that's not practical.

I have deleted the map heroes of the past, and it did not resolve it. I also tried removing all workshop maps, then redownloading them. That also did not work. I do not own any of my own custom maps.

I left the game running for 15mins after it froze from clicking on the custom campaign, and it popped up that the program stopped running. 

I would like to make note that when I try to verify the integrity of the game files, it says, "1 file failed to validate and will be reacquired." But I'm pretty sure it doesn't reacquire it because if I verify the files again it says the same thing.

As for my other PC build and output log, I can not acquire the output log at this time for my girlfriend has it. But the specs are as follows:

CPU: i7 9700K

GPU: 1050TI

RAM: 8gb DDR4

Backlog

This will be looked into soon once we are working on WFTO bug fixes again

Cannot Replicate

We just tried to replicate this issue with those campaigns you suggested and couldn't. Does the situation improve if you subscribe to less maps?

It did not resolve the problem. I've also tried reinstalling the game and still no success. 

Backlog

Hi PKCrafty,

Sorry to hear you're still having issues. We are aware that the custom campaigns menu especially can be quite slow to open if the player has multiple large custom campaigns downloaded and is exacerbated if the game is installed on a Hard Disk Drive.

I myself have many custom campaigns installed and it can take a while before this menu loads. If I leave the computer for a while it does eventually complete loading, but otherwise presents as if the game has locked up. If you attempt to interract with the game during this time Windows may believe the game is frozen and attempt to close it. 

I advise clicking on the menu and then stepping away from the computer for a little while to see if the menu opens as intended.

I will be reopening this ticket for further investigations in the next triage pass.

Thanks,

Lee