0
Completed - Resolved

Missing UI and unable to interact after level loading

Rudolph Reindeer 9 months ago • updated by Cian Noonan (Development Support Engineer) 8 months ago 6

Stuck with cinematic(depending if in campaign, or skirmish) camera - no UI and no response to buttons except opening console, minions moving around if already present. Happens occasionally on new level, restart or load - Increased likelihood with cumulative level time without restarting the game.

Managed to reproduce with:

Main campaign, completed up to level #3 and starting on #4, visited home realm for 10 minutes each time. Had the bug multiple times sporadically, but now manage to reproduce it consistently.

On level #4: Spam space to skip opening cinematic, build Underminer and spawn 7 extra imps(12 total), activate underminer, press escape and hit restart level, bug. Strangely enough in this case I can move around with WASD or cursor to edges, but not interact in any way(ALT+F4 or Task Manager only). Imps are spawned but stationary, animations and ambient sound play as normal.

All previous bug event logs end with the same exception as included. Three identical(first time, second test, third verification on Main Campaign level #4), one from visiting Home Realm. Home Realm exception is identical except:

at WftoUI.IngamePage.load (CoherentUIGTView) <0x00264>

Not sure what I can try locally to fix, drivers should all be up to date and tried running game as admin just because.

PS: This issue was not present on previous campaign playthrough, which I believe took place in 2.0.4. Never seen the bug before 2.0.5, 150+ hours game time.


output_log.ReproducedCameraBug.txt
Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED

How can I complain, the patch for it is released within 6 days. Two thumbs up!

Satisfaction mark by Rudolph Reindeer 8 months ago
Marked for Review

Hi Rudolph Reindeer,

Thanks for submitting the report this is very interesting indeed and could be a result of the transition to a new version of our UI Middleware. Perhaps you've uncovered an issue in this new version. I'll raise this with our QA Analyst to take a look at.

Thank you for the output log and reproduction steps.

Cheers,

Lee

Possibly relevant addition: I run the game with launch option "-popupwindow"

Completed - Next Patch

This will be fixed in the next update, avoid this exact set of steps until then

Something that has helped for me as well is to instead of jumping directly to next level, go all the way back to main menu. Not sure why this works, some GC that runs for the UI Middleware? Anyways, haven't had the bug since starting to do this.

+1

The middleware shit the bed and sent the "Done loading" message to the game before it was done loading, this completely broke the UI initialisation. We've worked around this so it should no longer happen