0
Completed - Resolved

steam version of war for the overworld runs on integrated gpu

andreasaspenberg 1 år siden opdateret af Cian Noonan (Graphics Plumber) 1 år siden 42
as steam does not support dedicated laptop gpus, the game needs code to switch gpu during startup which it does not have. please add that code so that the game can run on my dedicated gpu. 
Game Version:
Platform:
DÅRLIG, JEG ER UTILFREDS

i have already tried that solution but steam overrides it. it does that for all games not programmed to switch gpu.

Tilfredshedsangivelse af andreasaspenberg 1 år siden
Pending Customer

I've never heard of Steam overriding this setting, many many users have successfully followed these steps in the past.


Can you please send us a screenshot of your GPU settings so that we can verify? 

What is making you think that it is not on the dedicated GPU? 

Can you also send us your system specs?

There are also 2 WFTO executables , make sure that you are applying this setting to WFTOGame.exe

the actually tells me that my pc is trying to run it on the integrated gpu. the nvidia gpu is set as standard gpu but the problem here is still which can not run on the m series opf nvidia gpus. you have to code around that.

i have told the control panel to run both on the dedicated gpu and the game still runs on the integrated one. here is an idea you could try: program out the game`s ability to run on integrated gpus.

Please try and add -window-mode exclusive to your launch parameters

it is the steam version, not the gog version. that is therefore not an option as steam overrides all settings.

You can access launch parameters in steam by right clicking the game in your library, opening properties and clicking "Set launch options..."

no, that is not the case. the options i have is properties, uninstall, make shortcut on desktop, specify categories, write a report, show community guides, show forum, show community central, show news, show downloadable content and play.

Hi andreasaspenberg,


Yup that's right. Click properties to open the properties window and then you'll see "Set launch options". See the attached images for an example.


that forced the game to run on the integrated gpu. as such my problem remains unsolved.

At this point we're at a loss as to what to suggest. The steps we've provided have worked in any case where this has been an issue for other users and for the vast majority this issue never occurs at all thanks to the developments in OS and Driver software.


The Graphics Renderer is not determined by us in the game's code rather it's determined at below game-engine level as part of the setup of the Graphics Driver. The game engine thusly uses the API to render the game on whatever renderer the operating system is telling it to use, rather than the other way around. Here's an image which shows that concept in action.



Generally as the drivers get smarter and operating systems are improved the heuristic algorithm which determines dynamically what hardware should be used become more intelligent. For most users on the latest OS and Drivers this shouldn't be a problem, and we can confirm this based on our own systems which have switchable graphics.


So to summarise the decision of which graphics hardware to use is done on a level below software, not by our game, the engine, Steam or even the OS but rather by drivers which are running in the Kernel. As such you setting up a profile for our program should override the settings which it has determined to use.


At this point we are unable to offer further assistance to you unless you are willing to engage further in troubleshooting with us. To do that we need a few things from you:


  • A Full DXDiag output on the hardware and software configuration of your computer.
  • A Screenshot showing how you've determined the game is running on the integrated chip rather than the discrete card.
  • Average FPS shown on the Main Menu, it's possible that the Integrated running is being misreported to you and the game is correctly running on your discrete card.
  • Screenshots of your Nvidia Control Panel setup for WFTO.exe, WFTOGame.exe, Steam.exe and Global Settings

Without this we'll be unable to help you further and can only direct you to seek help from other technical sources on the topic, such as Nvidia or third-party forums.


Thanks,


Lee

i posted a dxdiag link in my steam topic but when i tried to create a screen shot the game crashed my system.

Thanks for the Dxdiag output, we'll review it as soon as we can, though we're starting to close up for the day and we'll be able to review tomorrow.


There shouldn't be a need to take a screenshot from within the game, though it certainly shouldn't crash if you take a screenshot. :O


I noticed the screenshot you sent to us though on Steam though, was this the screenshot you were trying to get? 


From what I can see this is a message we've had around for a while to detect an issue related to this. What happens when you click ignore on this message?


Can you provide the requested screenshots from your Nvidia control panel?


If we can get all that we'll probably be in a good position to offer some advice tomorrow morning.


Cheers,


Lee

wether i click on quit or ignore does not matter as the game goes through with it and tries to run on the integrated gpu anyway. i will post the other screen shot soon.

Can you post an output log:


Posting Output Logs

In addition, a log is created by the game every time you play. Posting this will help resolve some issues. 


Please note that this file is wiped every time the game launches, so ensure the bug you are reporting happened during your last play session. 


The location of the log can be found in the following location based on OS:


Windows

C:\Program Files (x86)\Steam\SteamApps\common\War For The Overworld\WFTOGame_Data\output_log.txt

OS X

~/Library/Logs/Unity/Player.log

Linux

~/.config/unity3d/Subterranean Games/War For The Overworld/

it does prove that the integrated gpu is used to run the game. if you want a closer look at it, please check the steam post.

Please double check that you have C++ redist 2010,2012,2013,2015. 2015 is the most important one. You can see which ones are installed in Control Panel -> Programs and Features.  You will find all installed Visual C++ Redistributable in your system.


If you are missing any then please go to the "_CommonRedist/vcredist" folder in the game's install directory and install the missing versions.

Really useful, thanks!


Can you confirm if you also have WFTO.exe in your Nvidia Control Panel programs list? The provided screenshot only shows WFTOGame.exe.


If not then you can add WFTO.exe by doing the following.


1. Click add next to the program list



2. On the second screen click browse


3.Navigate to your WFTO Folder (For you this would probably be "C:\Program Files(x86)\steam\steamapps\common\War For The Overworld")

4. Select WFTO.exe and click open



Once that's added make sure it's assigned to the High Performance Nvidia Card as well.


In addition my colleague Cian has identified an issue in your Output Log which also needs resolving he'll assist you with that.


Cheers,


Lee


the 2015 ones will not install on my system for some reason. that issue is also preventing me from running final fantasy 15. check the steam post for error log.

i have already done the configuration the nvidia control panel.

If 2015 does not install then that is likely the root of the issue that I can see in your log.


Please try and uninstall it if it is already installed and try again

i have already tried that and it is still not installing.

Pending Customer

Does the game launch? What is the average fps you get in the main menu?

Regarding the configuration in the Nvidia Control Panel.


Would you kindly provide a screenshot of the configuration for the WFTO.exe program as well as the global settings. So far you've provided a screenshot of WFTOGame.exe. This is mostly for our security of mind before we proceed to more nuclear options to trying to resolve this.


Wftogame.exe (the one you've shown us the configuration for) will look like this with the WFTO Logo and a path rather than a name:

Whilst wfto.exe will look like this with a generic icon and the name "War for the Overworld"



We need to see the configuration of both of these to ensure they match up, apologies for the inconvenience.

i am still not getting to the main menu as the game does not launch. i have configured the nvidia control panel properly.

The game not launching is a completely separate issue from the wrong GPU being used.


You need to install Microsoft Visual C++ 2015 Redistributable to play the game. If you cannot install this you cannot play the game.


If you successfully install it and the game still does not work that let us know. If it fails the please contact Microsoft Support: https://support.microsoft.com/en-gb/contactus/

no it is not. the dll files is installed so final fantasy 15 now works(that also uses the 2015 redist packages). war for the overworld does not work. final fantasy 15 runs on the gtx 770m while war for the overworld tries to run on the intel hd 4600 which it is not even compatible with.

Pending Customer

As stated by Lee earlier we do not have any control over what GPU we run on, the driver decides where to process the load created by WFTO.


If you have managed to install 2015 can you please send us another log


Can you also verify that you have no pending Windows Updates.

of course you do. games can jbe programmed to prefer a dedicated gpu. war of the overworld is not. final fantasy 15 however is. one issue here is steam which is programmed to run on integrated gpus only. it can not run on dedicated gpus as long as there is an integrated one. steam tells games what gpu to run on unless the game is coded to choose its own gpu. that is why the steam version of star wars empire at war runs on integrated gpu while the disc version runs on dedicated. i can not send you any files now that you have locked my steam topic.

Please send the files directly here, it is much more helpful to keep them all linked in this topic. Just drag the file into the comment box.


NVIDIA Optimus alone decides what GPU is going to be used. We have no control.


https://en.wikipedia.org/wiki/Nvidia_Optimus


This video explains what Optimus is:


i can not because i am trying to run the game on a different pc than the one where i have my email. steam have a lot of power over the games it runs. that includes what gpu they use. unless they are programmed to run on a specific gpu which is the case with slender: the arrival and ducktales remastered and final fantasy 15. here is another example: star wars empire at war disc version runs on my gtx 770m, the steam version runs on my intel hd 4600. only difference is the DRM

We cannot help you if you do not send the files

and i can not send them unless you reopen my topic. if you reopen my topic i can send all the files you need. either way, it is unlikely thet you will be able to solve my problem without patching the game to prefer dedicated gpu.

If you follow this link you can directly access the ticket: https://brightrockgames.userecho.com/communities/1/topics/4400-steam-version-of-war-for-the-overworld-runs-on-integrated-gpu


Unfortunately we cannot troubleshoot an issue that is so specific to one machine. Once you can show that you have the required redists for WFTO

so reopen my steam topic so that i can post there. the issue however is not specific to one machine but present on all machines running nvidia optimus.

My guess would be that the aforementioned games which are running on your correct GPU have in-built Nvidia profiles designed by Nvidia which recognises the program and then sets the appropriate card, or the heuristic algorithm that dynamically determines which card to use is detecting something particular about the way they want to use the GPU but that's the domain of Nvidia and I couldn't comment. 


As an example the reason why Empire at War probably behaves differently from the Steam version is because the Steam version may have different identifiers to the original disk version. If the original game had a Nvidia Profile but that profile doesn't correctly relate to the Steam version you may be suffering a similar issue to what WFTO is suffering.


As WFTO has never been audited by Nvidia they'll never have created a profile for it and therefore it's down to the heuristic to determine what card to use unless set correctly by the user. We do know however that this issue does not affect everyone who use a Optimus enabled laptop, having a couple in our own office they correctly identified which card to use.


In any case we're pretty confident that the failure to boot to the main menu is not related to the use of the Intel Integrated GPU.


Whether this is because of Driver, Windows or BIOS differences between your PC and ours we couldn't say but it is certainly not a general issue, otherwise we'd see far more cases of it.


So for us to proceed the next steps are:


  • Provide the requested screenshot of the Nvidia Control Panel setup for WFTO.exe (You have only provided a screenshot of the setup for WFTOGame.exe, these are separate processes and must both be configured)
  • Also include a screenshot of the Global settings of your Nvidia Control Panel.
  • Provide a log for the success of the redist installation as requested by Cian above.
  • Ensure there are no pending Windows Updates and that your version of Windows is completely up to date.
  • Provide an up to date Output log from your latest attempt to launch the game, following the redist installation.
  • Your DXDiag indicates your Nvidia Drivers are from November 13th 2017, please update to v397.64 dated 9th of May 2018

Please upload these directly on Userecho, we cannot continue to switch between sources as it consumes a great deal of our time and energy trying to follow both threads. Either by attaching direct to email, in the thread itself from the above linkor simply by dropping links in your future emails to the previous download locations.

then by all means follow the steam topic only as it is easier for me to post links in steam as that runs on my laptop. my drivers is up to date but i have no way to give you the dxdiag from here.

Cannot Replicate

Unfortunately at this point we've done all we can to assist you. It is extremely difficult to try and troubleshoot the issue without receiving confirmation of the steps above and being able to pour over the images in a single location showing that the requested actions has been done.


As was previously addressed by my colleague your logs were showing that a Windows redistributable required for War for the Overworld to run is not working correctly and we don't have much of a reason as to why that would be. At this point it is beyond the remit of our support team to address the issue you're experiencing and the troubleshooting process has come to a standstill.


All I can advise is to once again double check everything I've said in my previous response but beyond that I can only advise you either seek further support from first-party support for the operating system or from a technical forum which specializes in the operations of the OS. Beyond that all I could advise is to seek a refund from Steam on the grounds that the game is not working and that every effort has been made by the development team to resolve the issue. Hopefully that should help support any request you put in with Steam support, but we cannot guarantee any refund as we do not have control over the refund process.


I am sorry that we could not resolve your issue.

there seems to have no problem in the first place. my harddrive was just slow to load it the first time and because of a glitch, it did not run on the gtx 770m until its loading screen showed up. after the loading screen showed up it switched gpu without issues.i am not sure what you can use this information for but here it is anyway.

Kundesupport af UserEcho