0
Completed

Game Crashes

christie.schonborn 11 months ago • updated by Lee "Noontide" Moon (Community Manager) 9 months ago 12
2018-05-04_110224.zip

Good Day,


The game crashes when trying to load a game or save a game, and currently also crashes randomly when loading the main menu of the War of the Overworld game. I have included the crash reports in attached zip file.

Game Version:
Platform:
Pending Customer

Hey Christie,


What level are you trying to save? Looks like the game is running out of memory while doing so. Do you have the map or a successful save that you can send us to try?

Hi,


It is in the Heart of Gold campaign, the 2nd map "Rhoad - Search for the Summoning Stone". I made a couple of saves there, all of them load, but when I now save the game freezes and then crashes with a report send to Microsoft. I don't know where the saved games are stored, I play the game through Steam on Windows 10.

Game Version: 2.0f9

Save files can be located at the following locations:


Windows

X:\Program Files (x86)\Steam\userdata\Your User ID\230190\remote

OS X

~/Library/application support/steam/userdata/Your User ID/230190/remote

Linux

~/.local/share/Steam/userdata/userdata/Your User ID/230190/remote


You will need to add both the save file & the meta file. 

These save files will not have the display name that you gave them whilst saving, they will reference the level and a timestamp:

[level_number][map_name][level_name][timestamp]  

4 bonus round  cornucopia_20180418165553

4  bonus round  cornucopia_20180418165553.meta

If you have multiple saves with very similar names, then simply sort you save files by date and you should be able to find you most recent that way.

I have had the exact same problem on the smae mission.


WftO version 2.0f9


Win 10 Home (fully up to date), 64 bit

16 gig RAM

AMD Ryzan 5 1600 Six-core 3.2Ghz

2GB Gddr5 factory superclocked EVEA Gtx 760


The game keeps completely locking up when I try to save on Heart of Gold mission two. I have got partway into the mission (having made some quicksaves fine) until the point where the game fails to save either manually or quicksave (which was working up until the current point). 

I managed to make one save after the point I had been having difficulty (but only by going into the save files and deleting one that was not showing up to load, clearly corrupted when it crashed), but then the quick save ceased to work as well. That save continues to load and the game appears to run until you try to save.

After the quicksave crashed, quicksave does not appear on the load menu.

The problem persisted through a reboot. I ran a  check on the game cache, which found one file that needed to be fixed (and fixed it). I went back in, loaded a Demonic Park scenario save (one that had taken me about four hours, so a large map with a lot of creatures and thus seemed like a good test for); did both a manual and quicksave succesfully. Loaded save from HoG mission 1, did both a manual and quick save successfully. Loaded save for HoG mission 2, game locked up again on save.

Subsequent verification found 1 file corrupted again. (Presumably from the crash.)


output_log.txt


Save (corrupted, in that it loads (for me) but crashed on save):


dlc1_campaign_level2_name_20180509234905.meta

dlc1_campaign_level2_name_20180509234905


Save (the latter succesfuly save mentioned above, apparently working, for comparison if that's any help)

dlc1_campaign_level1_name_20180510003111.meta

dlc1_campaign_level1_name_20180510003111


It would appear there's something off with this level in particular. I did a thread on the Steam community first to see if it was just me, and there was some suggestion it was a more general issue, but the fact that I, at least, have not had troubles with saving until this level, and that christie.schonborn have had problems on the smae level suggests there's something amiss.


I am hardly a programmer, but, given I have played scenarios (and the entire Undergames and Remastered main campaign up until now, and managed the first level in the current (now fixed internally, I understand) respawning bug, I wonder if maybe there is something to do with the spawning of the patrols?


Hope this additional information (and corroboration) is of use to you!

Marked for Review

Remarking this for review now that we have the requested files. Thanks!

Pending Customer

When you say crash, what does it look like? Do you get the windows "Program not responding" grey screen? What happens if you let it wait

I didn't get a CTD, just a complete lock-up when I tried to save. The screen just froze. I didn't time how long i left it, but after the sort of "five-minute wait, get a drink, go to the loo, still frozen" sort of period, I considered that was long enough that it was unlikely to be coming back, and had to tab out and shut it down via Task Manager (and I think I did get a program not responding once or twice after tabbing out. Sorry, it's been a couple of weeks.)


I do remember that, if I looked in the files, it appeared to have started making the save files when it locked-up.

Completed - Next Patch