Completed - Resolved

Game does not close properly and is still "Running" on Steam

theghost 5 years ago updated by Insantyz 4 years ago 31


I have an issue with the game.

When I exit the game, it's not properly ended.

The game process is still running in background and in the Steam library the game is still marked as "Running". So I always have to kill the game process after exiting manually.

Game Version:
Steam Public

ok thats good 

i am not the only one ;-)

Pending Customer

Where are you both exiting the game from?

From inside a the game with quit to desktop

and also from the main menu

Pending Customer

Are you both on Linux? This seems to not be an issue on Windows

I am on Linux
thats right

Could I get a log from you?

Posting Output Logs


I am using Linux too and always get the issue when I leave the game from the main menu (using "Quit"-button).

You can find my Player.log attached. Player.log

Completed - Next Patch

We have made an attempt to fix this. Let us know if this occurs after the patch next week

With today's released update 2.0.1 it's still not fixed.

sry, still not fixed

Thanks for updating us. I've marked this for review in the coming weeks.

I have the same problem. Linux Ubuntu 18.04, latest Steam version from the official repositories and latest WTFO version (2.0.1) I have to kill it using system monitor.

is this not going to get fixed? still present in 2.0.2

Sorry a response seems to have been omitted.

We are at the absolute end of support for WFTO and cannot look into issues that do not block the progression of gameplay like this one. Unfortunately this is something that is handled by Unity and we have no control over it, the only way to fix it would be to update the engine but at this point it is far too costly to invest months into getting to the new unity version as an attempt to fix this, especially as its not guaranteed that doing so would correct this.

We are sorry that this is something that you'll have to fight against but there's nothing further we can do.

I understand, no worries! I can see you are hard at work already with improving this game. But should it not be enough to make a script run when the game is shut down? it is as simple as "kill 28086" in terminal, doesnt even require sudo. Thank you for your time.

I'll this up with the code team, no promises

this issue is not present in the 2.0f10 version/linux stable brand

Marked for Review

Thats great to know, thanks Insantyz

does not close properly in 2.0.3

Pending Customer

Can you confirm if this is still an issue in 2.0.3f1


I can confirm that this issue persists with 2.0.3f1.

Marked for Review

Marking for further review as this issue is persisting in v2.0.3f1

still an issue in 2.0.4, do you have any update regarding if its possible to include a script in the game that does *kill WTFO-ID"

Thank you for your time.

Completed - Next Patch

Hey Insantyz,

I've had a crack at it by calling Unity's Application.Quit() and following this with System.Environment.Exit(0). I'll test this internally and if it doesnt work I'll go full sledge hammer and use System.Diagnostics.Process.GetCurrentProcess().Kill()

Completed - Resolved

works for me aswell! thank you very much