0
Completed - Resolved

WFTO Campaign Level 2 Achievement

Stephen Byron 2 years ago updated by Cian Noonan (Graphics Plumber) 2 years ago 11

I have played this level more than enuogh times to get the achievement "FIND ARTIFACT."

I not only FIND it but also CLAIM and then USE it but the game does not recognize ANY of this and will not grant me this overly, siple achievement.

Any assistance is greatly appreciated.

Game Version:
Steam Public
Platform:
Windows

Just to check, you did finish/complete the level after finding the artefact right? (Rather than immediately quitting after using it)

Yes. I have tried a variety of scenarios.

1) used PROPHECY to 'see' it. but claim it much later.

2) mine out to artifact but dont unearth it.

3) unearth/claim/research/use it and THEN complete the game

What's your game version?

With OS are you useing?

Could you also uplosd your Output_log, when you finished that lvl please?


http://brightrockgames.userecho.com/forums/2-war-for-the-overworld-knowledge-base/topics/118-how-to-submit-a-bug-ticket/

Pending Customer

Thanks for the input from our QA volunteers. I'd certainly welcome an  output_log on this and also if possible a save file before and after claiming the Artefact. :)

my apologies for the missing info.


OS: WINDOWS 8.1

Hewlit-Packard System Model h8-1534, x-64 based PC

Processor: AMD FX(tm)-6200 Six-Core Processor, 3800 Mhz, 3 Core(s), 6 Logical Processor(s)


Installed Physical Memory (RAM) 10.0 GB

Total Physical Memory 9.80 GB

Available Physical Memory 6.51 GB

Total Virtual Memory 15.8 GB

Available Virtual Memory 9.03 GB


GPU ???, never heard of it


game version 1.6.66f6


Campaign Map level 2

INDY: Locate hidden Atrefact on level 2 is not being acknowledged.


output_log.txt

As for the 'Save' file, I dont know which one you require as there are TWO versions of the same name.

A "FILE" and a "META file", so I am providing both files for the start and end of the level.


2 welcome to kairos_20180107222709 - start of level

2 welcome to kairos_20180107222709.meta - start of level META

2 welcome to kairos_20180107224202 - end of level, Atrefact is IN the Archive

2 welcome to kairos_20180107224202.meta - meta of same ending

Under Review

Thanks for this, we'll take a look into it.


Just so you know I gave this a try this morning and can confirm the achievement is being awarded when the condition is met so I can't understand why it has not yet been awarded to you.


Now we've got your save files I'll pass this on to our QA Analyst to review when he's got a moment, if there's a scenario where it is not being awarded we'd be quite interested in it. Just out of curiosity at what point did you try retrieve the artifact in each attempt? I went straight for it and the achievement was flagged the moment the artifact was acquired.


Something you can do is open the debug console (Scroll lock) before acquiring the artifact and seeing if the flag fires for the achievement. You'll see it presented in blue text.


Cheers,


Lee

As I mentioned previously, I have tried different approaches.


1) I dig out and claim up to the Artfeact but do NOT dig it out. The AOE from the Imp reveals it behind the wall.

2) I dig it out, claim it, identify it and use it and then finish the level.

3) I wait for PROPHECY to become available and use it to 'see' it but do NOT dig it out.

4) same as 3 except I dig it out and claim it.

5) dig, claim, ID and finish level

6) dig, claim, ID, use and then finish level.

I went and tried your suggestion abuot SCROLL LOCK.


And the game has went and made a liar out of me.


"AchievementCompleteLevel2Unlock" is listed twice and the INDY title is now yellow/gold. (sigh)


Now to try for the other achievements and see what else I can break (besides my keyboard)

Thank you for all the feedback and help.

Good to hear.


I'll keep this in review until our QA Analyst has an opportunity to look into the logs and save files. For now all I'd has for is any additional things you can think of if there's any elements that were consistent between your previous attempts? Perhaps your progress through the level was different compared to this time and fairly consistent in your previous attempts. Anytrhing that might help point us in a direction for any possible cause would be useful. Likely the only possible cause on our end would be a scripting conflict at some point in the level.


My only other thought to the cause and I'm not sure on this as I'm not 100% familiar with the code behind it. Perhaps there couuld have been an issue on steam's side. As achievements are handled via the Steamworks API they are flagged and sent to the Steam servers to award the player. The game then displays the awarded achievement at the end of a match. If there was a communication error perhaps the achievements were not being awarded correctly in the communication to the Steam servers. If so this might be something your log might reveal, or it might not. Either way I'll have our QA Analyst look into it when we're a little more free.


Cheers,


Lee