0
Completed - Resolved

Game unplayable

assemblerhead 2 года назад обновлен Cian Noonan (Graphics Plumber) 2 года назад 8

OS : Windows 7 x64 Pro ( w/SP1 )
CPU : AMD FX-9590 ( 4.7Ghz )
GPU : AMD RX 480 ( 8Gg )

Memory : DDR3 2133 ( 32Gg )


Game Version : 1.6.66   GOG Version + All 5 DLCs
Time Stamp : 16451


Problem Description :
Unable to access "skirmish" / "sandbox" / "crucible" / "my pet dungeon"  from the Main Menu.
Only the "campaign" is accessible from the Main Menu.
Main Campaign Tutorial not completable. ( The completion event never triggers. )


Tested with both GOG standalone / classic installer and installed by GOG Galaxy.


NOTE : Completed both campaigns in an earlier version of WFTO.


The GOG built installer is installing everything in 32bit mode. No 64bit.
GOG installer logs included.


GOG Files :
setup_war_for_the_overworld_64_1.6.66_(16451)_(g).exe
setup_war_for_the_overworld_64_1.6.66_(16451)_(g)-1.bin
setup_crucible_1.6.66_(16451).exe
setup_heart_of_gold_1.6.66_(16451).exe
setup_my_pet_dungeon_1.6.66_(16451).exe
setup_underlord_edition_content_1.6.66_(16451).exe
setup_worker_skin_bundle_1.6.66_(16451).exe

ALL Requested DxDiags / Logs : Req_Data.zip

Game Version:
GOG Galaxy
Platform:
Windows

Ответ

Ответ

Found the problem.


GOG Galaxy is assuming that the person playing the game is connected to the Internet and logged into their GOG account. If not --> the response to the game is gibberish.



The Fix :

# 1 : Uninstall GOG Galaxy

OR

Stop && Disable both GOG Galaxy services under Administrator Tools -> Services.


# 2 : Delete ALL Galaxy related .DLL files in the game install directory. ( 3 files )



Note to Admin : Please mark this problem as solved.

ХОРОШО, МНЕ ПОНРАВИЛОСЬ
Оценка удовлетворенности от assemblerhead 2 года назад
Pending Customer

Hey assemblerhead,


Looking at the log it seems that the game is failing to call the Galaxy API, could you attempt to disable your firewall?

Ответ

Found the problem.


GOG Galaxy is assuming that the person playing the game is connected to the Internet and logged into their GOG account. If not --> the response to the game is gibberish.



The Fix :

# 1 : Uninstall GOG Galaxy

OR

Stop && Disable both GOG Galaxy services under Administrator Tools -> Services.


# 2 : Delete ALL Galaxy related .DLL files in the game install directory. ( 3 files )



Note to Admin : Please mark this problem as solved.

I play OFFLINE. No Networking Connection AT ALL. ( Single Player / Standalone )


I will try with it the firewall *disabled* later today and report back.

Same problem, no change.


Disabled the firewall for all tests. Did three tests.

Test # 1 : Ran it with Galaxy running in the background.

Test # 2 : Ran it with Galaxy shut down.

Test # 3 : Ran it with Galaxy shutdown and ALL Galaxy DLL files in the WFTO install directory deleted.


Also included the launcher output log.

Updated_Data_Logs.zip

Cannot Replicate

Hey assemblerhead,


Everything we have seen so far has been a failure inside of the GOG API, could you please take all of the evidence that you have given us and put it in a ticket to GOG support. 


You can contact them at: https://support.gog.com/hc/en-us/requests/new?category=info


Unfortunately we cannot follow this issue up any further on our end and are personally unable to replicate this situation. GOG support will be able to troubleshoot the Galaxy client for why it cannot find you achievement(This is how we track campaign progress)

Completed - Resolved

There is a workaround in the above comment.


I would still suggest opening a ticket so they can rectify this.

Already done.


Also posted the fix in the WFTO forum at GOG.


Ran into this problem before with GOG, different game, different symptoms.


https://www.gog.com/forum/breach_and_clear_series/how_to_fix_startup_problems_windows


Had a Loooooooong "discussion" with GOG support over this. It went nowhere.

GOG support can be tricky, let us know if you have any other issues

Сервис поддержки клиентов работает на платформе UserEcho